version 1.31.43 in iconner PPA zoneminder-master

Forum for questions and support relating to the 1.31.x releases only.
Post Reply
rockedge
Posts: 882
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

version 1.31.43 in iconner PPA zoneminder-master

Post by rockedge » Sun Apr 29, 2018 11:49 pm

Does version 1.31.43 belong in iconner PPA zoneminder-master? I noticed while updating that v 1.31.43 is in the master branch and not storageareas.
Anyway installed and the web console does not work correctly. CSS seems missing. changing display style / skin /css has no effect.
although zmNinja works well and ZM seems to be streaming. Not sure why so I am mentioning the glitch.
zm13143-fixed.png
zm13143-fixed.png (68.13 KiB) Viewed 984 times
zm13143-1-fixed.png
zm13143-1-fixed.png (85.39 KiB) Viewed 984 times
zm13143-2-fixed.png
zm13143-2-fixed.png (21.4 KiB) Viewed 984 times

padeath
Posts: 2
Joined: Sun May 03, 2015 3:50 pm

Re: version 1.31.43 in iconner PPA zoneminder-master

Post by padeath » Mon Apr 30, 2018 4:58 pm

I upgraded to this version today too, I'm also seeing this missing css issue.

I'm also getting email alerts of alerts from my oldest events, I keep 3 days of images, and as they are getting deleted it seems I'm getting an email alert be sent by the filter that I have setup that is supposed to only send on new movement. I'm thinking that the filter code doesn't realise that the event alert has already been sent?

padeath
Posts: 2
Joined: Sun May 03, 2015 3:50 pm

Re: version 1.31.43 in iconner PPA zoneminder-master

Post by padeath » Mon Apr 30, 2018 7:26 pm

I was looking into this a bit and found that the css files are there, they are just forbidden by apache config.

I added Require all granted to the <Directory> in the config for apache now the are able to be loaded.

Still not sure on all the past alerts that are coming through though.

juanmoura
Posts: 86
Joined: Fri Nov 24, 2017 11:46 am

Re: version 1.31.43 in iconner PPA zoneminder-master

Post by juanmoura » Mon Apr 30, 2018 7:44 pm

same problem with me

rockedge
Posts: 882
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: version 1.31.43 in iconner PPA zoneminder-master

Post by rockedge » Mon Apr 30, 2018 11:41 pm

I fixed it by removing the Alias /zm/cache statement from the web server config and I replaced it with a sym-link I made from the command line
from -> /var/cache/zoneminder/cache to -> /usr/share/zoneminder/www/cache

then the CSS was working again for the web console

juanmoura
Posts: 86
Joined: Fri Nov 24, 2017 11:46 am

Re: version 1.31.43 in iconner PPA zoneminder-master

Post by juanmoura » Tue May 01, 2018 12:44 am

how can i do this?

rockedge
Posts: 882
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: version 1.31.43 in iconner PPA zoneminder-master

Post by rockedge » Tue May 01, 2018 1:48 am

are you running Apache as the web server? If yes, open /etc/apache2/conf-available/zoneminder.conf and around line 10
comment out this line :

Code: Select all

#Alias /zm/cache /var/cache/zoneminder/cache
make sure that the copy in /etc/apache2/conf-enabled/zoneminder.conf is the same (should be a sym-link)

restart Apache

in a terminal enter ->

Code: Select all

ln -s /var/cache/zoneminder/cache /usr/share/zoneminder/www/cache
I am not sure if it will work for you or not. My setup that I fixed is running Hiawatha 10.8.1 as the web server and the configuration is different but it should have a similar effect in Apache.

elchavodel8
Posts: 8
Joined: Thu Nov 09, 2017 7:03 pm

Re: version 1.31.43 in iconner PPA zoneminder-master

Post by elchavodel8 » Fri May 04, 2018 10:21 pm

rockedge wrote:
Tue May 01, 2018 1:48 am
are you running Apache as the web server? If yes, open /etc/apache2/conf-available/zoneminder.conf and around line 10
comment out this line :

Code: Select all

#Alias /zm/cache /var/cache/zoneminder/cache
make sure that the copy in /etc/apache2/conf-enabled/zoneminder.conf is the same (should be a sym-link)

restart Apache

in a terminal enter ->

Code: Select all

ln -s /var/cache/zoneminder/cache /usr/share/zoneminder/www/cache
I am not sure if it will work for you or not. My setup that I fixed is running Hiawatha 10.8.1 as the web server and the configuration is different but it should have a similar effect in Apache.
Thank you ! :D it repair my css now can go to tabs , but still having problem with one camera that stops each moment

rockedge
Posts: 882
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: version 1.31.43 in iconner PPA zoneminder-master

Post by rockedge » Sat May 05, 2018 12:55 am

If you are running an Apache web server then it would be better to remove the sym-link and make sure the newer zoneminder.conf is active and has all the lines it needs for it to work.
So again open /etc/apache2/conf-available/zoneminder.conf and around line 10
un-comment the Alias and add the 2 lines
AllowOverride All
Require all granted
as it is below.

Code: Select all

Alias /zm/cache /var/cache/zoneminder/cache
<Directory /var/cache/zoneminder/cache>
  Options -Indexes +FollowSymLinks
  AllowOverride All
  Require all granted
</Directory>
Restart the Apache web server.
This would be a better way to correct the css locating, the other way was a hack I can use in Puppy Linux when using the Hiawatha web server.

Post Reply

Who is online

Users browsing this forum: asker and 2 guests