1.31.42 Camera Pass through

Forum for questions and support relating to the 1.31.x releases only.
Post Reply
gsaindon
Posts: 42
Joined: Fri Apr 13, 2018 2:02 pm

1.31.42 Camera Pass through

Post by gsaindon » Mon Apr 23, 2018 7:21 pm

Hi,
Camera pass through seems to work with trendnet cameras but not with dahua. Here is what I get in the log file:

Apr 23 15:18:29 zmtest zmc_m4[2507]: INF [zmc_m4] [Opening video storage stream /var/cache/zoneminder/events/4/2018-04-23/5211/5211-video.mp4 format: mp4]
Apr 23 15:18:29 zmtest zmc_m4[2507]: WAR [zmc_m4] [Unable to set movflags to frag_custom+dash+delay_moov]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Error occurred when writing out file header to /var/cache/zoneminder/events/4/2018-04-23/5211/5211-video.mp4: Invalid argument#012]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Got signal 11 (Segmentation fault), crashing]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Signal address is 0x18, from 0x7f8b021e627c]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 0: /usr/bin/zmc(_Z14zm_die_handleriP9siginfo_tPv+0x78) [0x563cf757adf8]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 1: /lib/x86_64-linux-gnu/libpthread.so.0(+0x11390) [0x7f8b0393a390]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 2: /usr/lib/x86_64-linux-gnu/libavformat-ffmpeg.so.56(+0xd427c) [0x7f8b021e627c]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 3: /usr/lib/x86_64-linux-gnu/libavformat-ffmpeg.so.56(av_write_trailer+0x2ff) [0x7f8b0220279f]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 4: /usr/bin/zmc(_ZN10VideoStoreD1Ev+0x514) [0x563cf7597864]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 5: /usr/bin/zmc(_ZN12FfmpegCamera16CaptureAndRecordER5Image7timevalPc+0xa2d) [0x563cf75e523d]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 6: /usr/bin/zmc(_ZN7Monitor7CaptureEv+0x3a2) [0x563cf7536a02]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 7: /usr/bin/zmc(main+0x904) [0x563cf750c954]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 8: /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f8aff757830]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: ERR [zmc_m4] [Backtrace 9: /usr/bin/zmc(_start+0x29) [0x563cf750f1d9]]
Apr 23 15:18:29 zmtest zmc_m4[2507]: INF [zmc_m4] [Backtrace complete, please execute the following command for more information]
Apr 23 15:18:29 zmtest zmc_m4[2507]: INF [zmc_m4] [addr2line -e /usr/bin/zmc 0x563cf757adf8 0x7f8b0393a390 0x7f8b021e627c 0x7f8b0220279f 0x563cf7597864 0x563cf75e523d 0x563cf7536a02 0x563cf750c954 0x7f8aff757830 0x563cf750f1d9]
Apr 23 15:18:29 zmtest zmdc[1769]: ERR ['zmc -m 4' exited abnormally, exit status 11]

Thanks,

gsaindon
Posts: 42
Joined: Fri Apr 13, 2018 2:02 pm

Re: 1.31.42 Camera Pass through

Post by gsaindon » Mon Apr 23, 2018 7:54 pm

Ok, found the problem. Audio codec must be set to AAC. Now only problem left is that after a zoneminder restart, the first event is viewable but not the subsequent ones.

Thanks,

User avatar
iconnor
Posts: 1325
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: 1.31.42 Camera Pass through

Post by iconnor » Thu Apr 26, 2018 1:34 pm

I'd really like some more detailed logs, with debugging turned on.
Please set debug level to 4.
the code SHOULD re-encode whatever the camera sends to AAC. Works for my cameras that send pcm audio.

gsaindon
Posts: 42
Joined: Fri Apr 13, 2018 2:02 pm

Re: 1.31.42 Camera Pass through

Post by gsaindon » Mon Apr 30, 2018 12:08 pm

Pretty weird but it seems to be working now. I'll do more testing and try to figure out what solved it.

amritgary
Posts: 16
Joined: Sun Apr 29, 2018 4:41 pm
Location: Dallas, TX

Re: 1.31.42 Camera Pass through

Post by amritgary » Tue May 01, 2018 4:55 am

gsaindon wrote:
Mon Apr 23, 2018 7:54 pm
Ok, found the problem. Audio codec must be set to AAC. Now only problem left is that after a zoneminder restart, the first event is viewable but not the subsequent ones.

Thanks,
How did you set the audio codec to AAC? (camera or within zoneminder settings someplace)?

gsaindon
Posts: 42
Joined: Fri Apr 13, 2018 2:02 pm

Re: 1.31.42 Camera Pass through

Post by gsaindon » Tue May 01, 2018 11:47 am

Hi, the setting was on the camera

amritgary
Posts: 16
Joined: Sun Apr 29, 2018 4:41 pm
Location: Dallas, TX

Re: 1.31.42 Camera Pass through

Post by amritgary » Tue May 01, 2018 12:56 pm

thank you.. for some reason i am unable to get audio to work with unless it encode it into AAC using cmdline options.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests