1.31.40 Upgrade error

Forum for questions and support relating to the 1.31.x releases only.
Post Reply
DVB Hardware
Posts: 127
Joined: Thu Jan 01, 2015 5:12 pm
Location: Rhode Island

1.31.40 Upgrade error

Post by DVB Hardware » Sat Mar 31, 2018 1:55 am

1.31.40~20180329122723-xenial

Linux Mint 18.3 Mariadb I ran zmupdate.pl and it corrected the problem

Setting up zoneminder (1.31.40~20180329122723-xenial) ...
MySQL/MariaDB not found; assuming remote server.
Done Updating; starting ZoneMinder.
Job for zoneminder.service failed because the control process exited with error code. See "systemctl status zoneminder.service" and "journalctl -xe" for details.
zoneminder.service couldn't restart.
Job for zoneminder.service failed because the control process exited with error code. See "systemctl status zoneminder.service" and "journalctl -xe" for details.
invoke-rc.d: initscript zoneminder, action "start" failed.
● zoneminder.service - ZoneMinder CCTV recording and surveillance system
Loaded: loaded (/lib/systemd/system/zoneminder.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Fri 2018-03-30 21:35:02 EDT; 4ms ago
Process: 18397 ExecStart=/usr/bin/zmpkg.pl start (code=exited, status=255)
Main PID: 2711 (code=exited, status=0/SUCCESS)

Mar 30 21:35:02 server systemd[1]: Failed to start ZoneMinder CCTV recordin...m.
Mar 30 21:35:02 server systemd[1]: zoneminder.service: Unit entered failed ...e.
Mar 30 21:35:02 server systemd[1]: zoneminder.service: Failed with result '...'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package zoneminder (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up intel-microcode (3.20180312.0~ubuntu16.04.1) ...
update-initramfs: deferring update (trigger activated)
intel-microcode: microcode will be updated at next boot
Processing triggers for initramfs-tools (0.122ubuntu8.11) ...
update-initramfs: Generating /boot/initrd.img-4.13.0-31-generic
Warning: No support for locale: en_US.utf8
Errors were encountered while processing:
zoneminder
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up zoneminder (1.31.40~20180329122723-xenial) ...
MySQL/MariaDB not found; assuming remote server.
Done Updating; starting ZoneMinder.
Job for zoneminder.service failed because the control process exited with error code. See "systemctl status zoneminder.service" and "journalctl -xe" for details.
zoneminder.service couldn't restart.
Job for zoneminder.service failed because the control process exited with error code. See "systemctl status zoneminder.service" and "journalctl -xe" for details.
invoke-rc.d: initscript zoneminder, action "start" failed.
● zoneminder.service - ZoneMinder CCTV recording and surveillance system
Loaded: loaded (/lib/systemd/system/zoneminder.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Fri 2018-03-30 21:35:39 EDT; 4ms ago
Process: 26339 ExecStart=/usr/bin/zmpkg.pl start (code=exited, status=255)
Main PID: 2711 (code=exited, status=0/SUCCESS)

Mar 30 21:35:39 server systemd[1]: Failed to start ZoneMinder CCTV recordin...m.
Mar 30 21:35:39 server systemd[1]: zoneminder.service: Unit entered failed ...e.
Mar 30 21:35:39 server systemd[1]: zoneminder.service: Failed with result '...'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package zoneminder (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
zoneminder

Error in Log
Version mismatch, system is version 1.31.40, database is 1.31.39, please run zmupdate.pl to update.
Linux Mint 20.04 Cinnamon Mariadb using Master

DVB stands for Digital VIdeo Broadcasting , retired satellite downlink supplier

Eradicator
Posts: 41
Joined: Tue Jan 24, 2017 5:58 am

Re: 1.31.40 Upgrade error

Post by Eradicator » Mon Apr 02, 2018 5:54 am

You need to run zmupdate.pl then apt upgrade

DVB Hardware
Posts: 127
Joined: Thu Jan 01, 2015 5:12 pm
Location: Rhode Island

Re: 1.31.40 Upgrade error

Post by DVB Hardware » Wed Apr 04, 2018 4:44 pm

NEW UPGRADE ERROR same Linux Mint 18.3 as above ....Zoneminder will not start
1.31.40~20180403212315-xenial

E: zoneminder: subprocess installed post-installation script returned error exit status 1

018-04-04 12:37:47.668040 zmpkg 9835 FAT Can't execute: Unknown column 'Id' in 'field list' zmpkg.pl

04/04/2018 12:40:37.936620 zmpkg[11279].INF [Sanity checking States table...]
04/04/2018 12:40:37.972192 zmpkg[11279].INF [Command: start]
04/04/2018 12:40:38.143584 zmsystemctl[11285].INF [Redirecting command through systemctl]
Job for zoneminder.service failed because the control process exited with error code. See "systemctl status zoneminder.service" and "journalctl -xe" for details.
Linux Mint 20.04 Cinnamon Mariadb using Master

DVB stands for Digital VIdeo Broadcasting , retired satellite downlink supplier

User avatar
iconnor
Posts: 1325
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: 1.31.40 Upgrade error

Post by iconnor » Thu Apr 05, 2018 12:35 am

I think someone broke the automatic run of zmupdate.pl.

You will have to run it yourself.

sudo zmupdate.pl
sudo zmupdate.pl -f
sudo apt-get -f install

DVB Hardware
Posts: 127
Joined: Thu Jan 01, 2015 5:12 pm
Location: Rhode Island

Re: 1.31.40 Upgrade error

Post by DVB Hardware » Thu Apr 05, 2018 1:13 am

Still the same, if it is my system I can reinstall new, hardly never had a upgrade error before.

server jimmy # sudo zmupdate.pl

Database already at version 1.31.40, update aborted.

server jimmy # sudo zmupdate.p
l -f

Freshening configuration in database
Loading config from DB 221 entries
Saving config to DB 221 entries

server jimmy # sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up zoneminder (1.31.40~20180403212315-xenial) ...
MySQL/MariaDB not found; assuming remote server.
Done Updating; starting ZoneMinder.
Job for zoneminder.service failed because the control process exited with error code. See "systemctl status zoneminder.service" and "journalctl -xe" for details.
zoneminder.service couldn't restart.
Job for zoneminder.service failed because the control process exited with error code. See "systemctl status zoneminder.service" and "journalctl -xe" for details.
invoke-rc.d: initscript zoneminder, action "start" failed.
● zoneminder.service - ZoneMinder CCTV recording and surveillance system
Loaded: loaded (/lib/systemd/system/zoneminder.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2018-04-04 21:06:03 EDT; 5ms ago
Process: 5134 ExecStart=/usr/bin/zmpkg.pl start (code=exited, status=255)

Apr 04 21:06:03 server systemd[1]: Failed to start ZoneMinder CCTV recordin...m.
Apr 04 21:06:03 server systemd[1]: zoneminder.service: Unit entered failed ...e.
Apr 04 21:06:03 server systemd[1]: zoneminder.service: Failed with result '...'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package zoneminder (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
zoneminder
E: Sub-process /usr/bin/dpkg returned an error code (1)
server jimmy #
Linux Mint 20.04 Cinnamon Mariadb using Master

DVB stands for Digital VIdeo Broadcasting , retired satellite downlink supplier

DVB Hardware
Posts: 127
Joined: Thu Jan 01, 2015 5:12 pm
Location: Rhode Island

Re: 1.31.40 Upgrade error

Post by DVB Hardware » Wed Apr 11, 2018 9:34 pm

Zoneminder log

Can't execute: Unknown column 'Id' in 'field list' zmpkg.pl

Is it a bug or sould I just reinstall on this test machine

Jimmy
Linux Mint 20.04 Cinnamon Mariadb using Master

DVB stands for Digital VIdeo Broadcasting , retired satellite downlink supplier

amritgary
Posts: 16
Joined: Sun Apr 29, 2018 4:41 pm
Location: Dallas, TX

Re: 1.31.40 Upgrade error

Post by amritgary » Tue May 01, 2018 11:13 pm

I have the same issue. did you figure out what was wrong?

DVB Hardware
Posts: 127
Joined: Thu Jan 01, 2015 5:12 pm
Location: Rhode Island

Re: 1.31.40 Upgrade error

Post by DVB Hardware » Tue May 01, 2018 11:36 pm

On 1.31.44 strorageareas now
Linux Mint 20.04 Cinnamon Mariadb using Master

DVB stands for Digital VIdeo Broadcasting , retired satellite downlink supplier

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests