Event playback fails after update

Forum for questions and support relating to the 1.31.x releases only.
Post Reply
skydiver
Posts: 86
Joined: Wed Jun 16, 2004 7:15 pm

Event playback fails after update

Post by skydiver » Tue Aug 08, 2017 4:20 am

I have ZM 1.31.1 installed via dpkg on Ubuntu 16.04. System has been solid and running for a few years and been updated regularly.
I recently did apt-get update on the Zoneminder package which upgraded from 1.30 to 1.31

After the update (After having to manually run zmupdate.pl):

- API live and event playback works with ZM Ninja
- Web interface live playback
- Event timeline view has roken imaged thumbnails
- Event Timeline mouse over thumbnail preview creates the the following errors:

Code: Select all

web_php		2044	ERR	Can't create frame images from video because there is no video file for this event	/usr/share/zoneminder/www/includes/functions.php	1010
- Event view video shows the events but produced produces errors and the playback controls do not work:

Code: Select all

2017-08-07 22:59:58.336717	web_js		2042	ERR	Uncaught TypeError: Cannot set property 'vid' of undefined	http://zm.scottrobertmorgan.com/zm/skins/classic/views/js/timeline.js	7
2017-08-07 22:59:57.834183	web_php		2042	ERR	Can't create frame images from video because there is no video file for this event	/usr/share/zoneminder/www/includes/functions.php	1010
I believe this may be due to some incorrect permissions but I need some directions to where to look.

moorsey
Posts: 51
Joined: Sun Jan 03, 2010 8:56 am

Re: Event playback fails after update

Post by moorsey » Tue Aug 08, 2017 10:27 am

Can confirm I see exactly the same issue after running an "apt-get update" a few days ago on my Mint 17.3 installation.

Possibly related, the "3 grid wide scaled" view does not scale anymore, just shows images as the cameras resolution

skydiver
Posts: 86
Joined: Wed Jun 16, 2004 7:15 pm

Re: Event playback fails after update

Post by skydiver » Tue Aug 08, 2017 1:21 pm

I have also noticed:
- The "3 grid wide scaled" view does not scale anymore, just shows images as the cameras resolution
- Montage Review screen displays controls behind the Screen image montage

I didn't realize that 1.31.1 was still not stable. I am willing to work through but as a fallback position, is there a simple way to roll back to 1.30.x in case the system will not be stable soon?

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Event playback fails after update

Post by rockedge » Tue Aug 08, 2017 3:45 pm

at the very top of this forum section it pretty much says it all.
ZoneMinder 1.31.x has not been released yet
there are some other little bugs in 1.31.x as well. I have been wondering if there was a solid way of rolling back a version. Usually I just start from scratch but a system that has been running well and in a production role that seems to be not a good option. I wonder if version 1.30.4 will run with the updated mysql database? Simplifying the rollback if it does......

User avatar
iconnor
Posts: 1394
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Event playback fails after update

Post by iconnor » Wed Aug 09, 2017 1:44 pm

Yeah there is a PR that fixes all these issues, but no one will merge it.

You might try my branch, in which I fix every little problem I find. ppa:iconnor/zoneminder-storageareas

skydiver
Posts: 86
Joined: Wed Jun 16, 2004 7:15 pm

Re: Event playback fails after update

Post by skydiver » Wed Aug 09, 2017 10:53 pm

I am running from dpkg using this repository:

Code: Select all

deb http://ppa.launchpad.net/iconnor/zoneminder-master/ubuntu xenial main 
Curious why the not-yet-released version got published via apt-get.

If I wanted to go to using git for the distro, what would be the best process? I would rather not start from scratch, this system is finely tuned for resources, zones, etc.

User avatar
knight-of-ni
Posts: 2341
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Event playback fails after update

Post by knight-of-ni » Thu Aug 10, 2017 1:33 am

skydiver wrote:
Wed Aug 09, 2017 10:53 pm
I am running from dpkg using this repository:

Code: Select all

deb http://ppa.launchpad.net/iconnor/zoneminder-master/ubuntu xenial main 
Curious why the not-yet-released version got published via apt-get.
You got the development version of zoneminder because you added iconnor's master branch ppa to your system.
This is bleeding edge.

If you want official releases only, then you need to use iconnor's stable ppa instead:
https://launchpad.net/~iconnor/+archive ... zoneminder
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

User avatar
knight-of-ni
Posts: 2341
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Event playback fails after update

Post by knight-of-ni » Thu Aug 10, 2017 1:36 am

iconnor wrote:
Wed Aug 09, 2017 1:44 pm
Yeah there is a PR that fixes all these issues, but no one will merge it.

You might try my branch, in which I fix every little problem I find. ppa:iconnor/zoneminder-storageareas
Was it this one?
https://github.com/ZoneMinder/ZoneMinder/pull/1930

I went ahead and merged it.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

skydiver
Posts: 86
Joined: Wed Jun 16, 2004 7:15 pm

Re: Event playback fails after update

Post by skydiver » Fri Aug 11, 2017 1:48 am

knnniggett wrote:
Thu Aug 10, 2017 1:33 am
You got the development version of zoneminder because you added iconnor's master branch ppa to your system.
This is bleeding edge.

If you want official releases only, then you need to use iconnor's stable ppa instead:
https://launchpad.net/~iconnor/+archive ... zoneminder
GTK...
iconnor wrote:
Wed Aug 09, 2017 1:44 pm
Yeah there is a PR that fixes all these issues, but no one will merge it.

You might try my branch, in which I fix every little problem I find. ppa:iconnor/zoneminder-storageareas
iconnor, I am going to use \your branch instead. Are you sub-versioning the the version designation?

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests