getting MySQL error when adding monitor

Forum for questions and support relating to the 1.31.x releases only.
Post Reply
bisana
Posts: 23
Joined: Sun Nov 11, 2007 4:10 am

getting MySQL error when adding monitor

Post by bisana » Wed Jul 19, 2017 7:58 am

Hi All,
Just finished the 1.31.1~20170714144256-xenial install
when tried adding monitor got this error

Code: Select all

SQL-ERR 'SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'Method' cannot be null', statement was 'INSERT INTO Monitors SET LinkedMonitors = NULL, Device = '/dev/video0', Channel = '0', Format = '255', Palette = '0', V4LMultiBuffer = NULL, V4LCapturesPerFrame = '1', Protocol = NULL, Host = NULL, Port = '80', Method = NULL, Options = NULL, Path = NULL, User = NULL, Pass = NULL, Colours = '3', Width = '320', Height = '240', Orientation = '0', Deinterlacing = '0', SaveJPEGs = '3', VideoWriter = '0', EncoderParameters = '# Lines beginning with # are a comment \r\n# For changing quality, use the crf option\r\n# 1 is best, 51 is worst quality\r\n#crf=23', RecordAudio = '0', RTSPDescribe = '0', LabelFormat = '%N - %d/%m/%y %H:%M:%S', LabelX = '0', LabelY = '0', LabelSize = '1', ImageBufferCount = '50', WarmupCount = '25', PreEventCount = '25', PostEventCount = '25', StreamReplayBuffer = '1000', AlarmFrameCount = '1', EventPrefix = 'Event-', SectionLength = '600', FrameSkip = '0', MotionFrameSkip = '0', AnalysisUpdateDelay = '0', FPSReportInterval = '1000', DefaultView = 'Events', DefaultRate = '100', DefaultScale = '100', WebColour = 'red', Exif = '0', SignalCheckColour = '#0000c0', Name = 'Lenova Phone', ServerId = NULL, Type = 'Remote', Function = 'Monitor', Enabled = '1', AnalysisFPS = NULL, MaxFPS = '20', AlarmMaxFPS = '10.00', RefBlendPerc = '6', AlarmRefBlendPerc = '6', Sequence = 1'

Later when I restarted the instance and tried it worked, this just I am sending it for feedback of my experience, Now I just created one monitor
A Linux User

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 4 guests