Page 1 of 1

ZM 1.30.4 and HTTP/2

Posted: Sun Apr 19, 2020 2:05 pm
by pat2
Recently I enabled HTTP/2.0 in my Apache Web Server on Ubuntu 16.04. There are many benefits.

My website is working without regressions.And ZM too, almost...
ZM is 1.30.4. The browser is Firefox 75.0. Tests done in LAN.

The only issue in ZM is in Montage functionality (seeing all together my 7 cameras): in a randomic way, after some time, the image for any camera disappears. To solve I have to close the Montage view and reopen it.

I think it's due to the server push and multiplexing technology adopted in HTTP/2. It imporoves the fast loading of pages, but creates confusion to the images flow (especially if many cameras together) so that in a randomic way the montage view loses synchronism and the camera diasappears.

You could test removing "h2" from the line Protocols h2 http/1.1 in virtual host.
Removing "h2" the server works in the classical http1.1 mode and no issue, with "h2" in the statement the server works in advanced mode using the http/2 protocol with the issues in ZM I reported.

Did you notice a similar behaviour? if so, did you find a solution?
I think few users could have experienced the issue since HTTP/2 is still not already broadly diffused.
I didn't try with more recent ZM versions since I'm not using them (I found them not mature on ARM board).


Re: ZM 1.30.4 and HTTP/2

Posted: Sun Apr 26, 2020 7:15 pm
by pat2
SOLVED ! As I understood it is needed in Ubuntu 16.04 and depending on the apps suite you are using. I modified the php.ini file in the following way adding at the bottom the following code:

Code: Select all

upload_max_filesize = 32M 
post_max_size = 48M 
memory_limit = 256M 
max_execution_time = 600 
max_input_vars = 3000 
then restarted the php service:

Code: Select all

sudo service php7.4-fpm restart