Page 1 of 1

zmcontrol socket issues

Posted: Thu Aug 16, 2018 2:19 pm
by jedix

I have a GW Security 5071IP and I can't get zoneminder to control the PTZ. This is my first camera and install. The camera is supposed to be ONVIF, but the detection doesn't seem to work. The web interface for the camera shows PTZ config for PELCO_D, PELCO_P, MOLYN_D, SANTA_P. I've tried PELCO_D over ffmpeg with no luck with many ports. Both with and without credentails.

nmap shows these ports:

Code: Select all

80/tcp   open  http
554/tcp  open  rtsp
8000/tcp open  http-alt
8091/tcp open  unknown
8200/tcp open  trivnet1
I think 8091 is the correct port, but I've had no success.

I also see the following in the logs:

Code: Select all

Can't connect: Connection refused after 11 attempts to /var/run/zm/zmcontrol-2.sock

Code: Select all

/usr/bin/ --panspeed=26 --autostop --command=moveConRight --id=2=>
I've noticed some odd behaviour with the socket pipe, that is zmcontrol-2.sock remains forever, but from what I read in the code it should be unlinked. I tried removing that file and it is not recreated unless I change the configuration. zmcontrol doesn't seem to be running (not in ps). lsof does not show the file is opened, so I *think* there is an issue with the server quitting before the unlink of the file. Without any accurate information on how this camera is supposed to work, I'm concerned I'm going down the wrong path debugging a perl script while it's just a configuration issue.

Specific version of zoneminder is 1.30.4-xenial1

Any help or pointers would be appreciated.


Re: zmcontrol socket issues

Posted: Thu Aug 16, 2018 5:09 pm
by jedix
The control module is stopping when it sets the baudrate:

Code: Select all

I don't understand why this is necessary when going over ethernet

Re: zmcontrol socket issues

Posted: Thu Aug 16, 2018 7:48 pm
by iconnor
There is definitely some oddness in the zmcontrol socket code.

Re: zmcontrol socket issues

Posted: Thu Aug 16, 2018 9:09 pm
by jedix
I'm thinking I'm going to send these back and pick some other cameras.. the web interface doesn't even work to move these.

Re: zmcontrol socket issues

Posted: Thu May 23, 2019 2:14 pm
by camelreef

Sorry for waking up that topic...

I appear to have a similar issue


Was there any solution found?