Page 1 of 1

wyze cam running openipc

Posted: Sat May 12, 2018 2:13 pm
by botzen67
Bleeding edge question here. I have a V2 wyze camera running openipc. (From what I understand it's the same underlying hardware as Xiaofang)

I'm trying to get it hooked up to ZoneMinder. So far I've been able to connect to the RTSP stream but when I open the monitor I get a blue screen.
Log screenshot attached
2018-05-12.png
2018-05-12.png (59.15 KiB) Viewed 4280 times
(sorry for using a screenshot, when I tried to export the log to a text file I got a server error)

Has anyone been successful getting a wyze cam to work with ZoneMinder?

Re: wyze cam running openipc

Posted: Sat May 12, 2018 2:47 pm
by bbunge
Use VLC to check the stream and resolution. Zoneminder will show the blue screen when the resolution is wrong.

Re: wyze cam running openipc

Posted: Sun Jul 01, 2018 4:24 am
by srthimsen
Did you happen to get this figured out @botzen67? Considering a jump to ZM to run some Wyze cams (v2).

Re: wyze cam running openipc

Posted: Sun Jul 01, 2018 10:27 pm
by iconnor
Looks to me like you need to add auth info.

rtsp://username:password@192.168.0.1/unicast

Re: wyze cam running openipc

Posted: Thu Jul 12, 2018 5:23 pm
by bbolin
Wyze V2

ii zoneminder 1.31.44~20180711020114-stretch arm64 video camera security and surveillance solution
ii zoneminder-doc 1.31.44~20180711020114-stretch all ZoneMinder documentation


cat /system/sdcard/config/rtspserver.conf
#######################################################################
# Edit this file and move it to /system/sdcard/config/rtspserver.conf #
# if you need to add options, otherwise defaults will be used #
#######################################################################

# Configure RTSP Servers
# Use /system/sdcard/bin/v4l2rtspserver-master -h to see available options

# H264 RTSP server options
# Examples:
# RTSPH264OPTS="-S -W960 -H540"
# To enable authentication:
# RTSPH264OPTS="-U user:password"
RTSPH264OPTS="-W640 -H480"

# MJPEG RTSP server options
# Examples:
# RTSPMJPEGOPTS="-W960 -H540"
# To enable authentication:
# RTSPMJPEGOPTS="-U user:password"
RTSPMJPEGOPTS="-W640 -H480"

Re: wyze cam running openipc

Posted: Tue Aug 21, 2018 2:49 pm
by dhoepp
I THINK I FIGURED IT OUT.

I have only one camera connected right now, but you do need to make sure the IP is correct. I fell prey to the autofill of my browser and it tried to use another URL I had in that field recently. The IP was wrong. When changing the IP, I was able to get a feed. Then you also need to make sure you set the max FPS to 100 (at least that's what I set it to.) I have been streaming a WyzeCam V2 running OpenIPC to ZoneMinder on Ubuntu for the past 30 minutes.

It's a bit choppy at times, but with my current network speeds, I am able to stream a solid 10-15fps with an occasional 5 second freeze.

Re: wyze cam running openipc

Posted: Sat Dec 29, 2018 3:49 am
by botzen67
Anybody still trying to get this working? I came back to it after a while and keep finding the same thing. I can get ZoneMinder to connect using various resolutions but then after a brief period of time (less than a few hours) the ZoneMinder connection seems to "die". Using VLC I can always access the RTSP feed so I know the camera is still working. Just curious if anyone is seeing similar results.