Page 1 of 1

ZM not displaying any camera streams

Posted: Fri Mar 23, 2018 2:14 pm
by DinghySailor
I have installed ZM (v1.30.4) on my new system (Ubuntu 16.04). I used to have it working well on a previous system, but had to upgrade, and now I am having troubles with ZM. I have tried looking to solve the problem by searching the forum and web in general to no avail, so any help would be most appreciated.
The problem is that I have a USB camera attached to the PC running ZM. I can "see" it using Cheese or VLC, so I know the video works.
I can also use ZM to detect "events", and can see the captured still images. Sadly, I have not found any way to watch a live stream - if I use the "Montage" option, I get no video display - just some heading is the case with "Cycle". The "Montage Review" gives an area with "No Data" displayed.
In the main window, for the camera, I can see there are 332 events, and if I click on these, I get to a window which looks as though there should be a video playback - but there is a blank screen under the playback controls, but no images.
I have tried the same tests in a browser for 17.04, and I get the same results. The browser in both cases was Firefox (for 17.04 this was version 59.0.1).
I have also tried Chrome on the Ubuntu 16.04 system with no different results.
Any clues would be gratefully appreciated, as I am trying to add another camera, and would like to prove the simplest solution first!
Many thanks,

Just to add a little more detail:-
I have tried the system on the local and a remote PC, each using Firefox, Chrome and the default Ubuntu browser. All the results are identical.
There are no images displayed - so when I look at the camera (one local, and one IP based), I can see the camera is configured, but no stream nor images displayed for the cameras, nor for the montage...
I have tried adjusting the parameters for the frame grabbing to no effect.
I do (on some browsers) see a "broken" image icon. The url of the broken image is of the form:-
http://ipaddress/zoneminder/cgi-bin/nph ... 1234567890
One camera is 640x480px and the other is 1920x1080.
I wonder if the link is invalid, but I don't know how to validate it. Also, the system is saving the images it captures to a server, so I know it can capture images.
Many thanks for your help.

Re: ZM not displaying any camera streams

Posted: Fri Mar 23, 2018 5:16 pm
by bbunge
For local cameras you need:

Create a new user

adduser www-data video

Two common errors:
PATH_ZMS is not set to /zm/cgi-bin/nph-zms
Camera resolution in Zoneminder does not match camera output. Use VLC (Tools, Media Information, Codec) to check camera Display Resolution. ... e_easy_way

Re: ZM not displaying any camera streams

Posted: Sat Mar 24, 2018 11:29 am
by DinghySailor
Thanks bbunge for your suggestions.
I did check the PATH issue, but that wasn't it. I also added the user as you suggested, and that didn't work.
I also checked the resolution, and that was correct.
Are there any other things I can check? I am puzzled as to how images can be captured, but the video cannot be displayed in the Montage (or any other place I can find that should have the video present).
I have tried the montage with both Modetect and Monitor settings, all to no avail. And I still cannot see any images that have been captured.
Many thanks for any help or further guidance.

Re: ZM not displaying any camera streams

Posted: Sat Mar 24, 2018 2:38 pm
by rockedge
Does your Apache web server configuration check out? there must be a missing Alias or incorrect path to the /cgi-bin
is the /etc/apache2/conf-avialable/zoneminder.conf enabled and a sym-link for it in /etc/apache2/conf-enabled....?

Re: ZM not displaying any camera streams

Posted: Tue Mar 27, 2018 3:47 pm
by DinghySailor
Dear Rockedge,

Thank you for your help. As far as I am aware, they all check out. But...

I could not find any reference to /cgi-bin in the apache2.conf file.

I did find a cgi-bin folder in a zoneminder folder.

How do I know if /etc/apache2/conf-avialable/zoneminder.conf is enabled? Zoneminder is running and capturing images from the camera. Just won't display it.

There is a zoneminder.conf symlink in /etc/apache2/conf-enabled - so I guess that is OK.

Sorry if I am ignorant - but I do appreciate all the guidance.

Many thanks,

Re: ZM not displaying any camera streams

Posted: Tue Jul 17, 2018 10:32 am
by HeyYou
This happens without warning and has now happened to me on two occasions. The only way to fix it seems to be to re-install Zoneminder.

Zoneminder works well for a long time, and then, suddenly, exhibits this symptom.
Too weird.
I'm getting frustrated.

Re: ZM not displaying any camera streams

Posted: Thu Jul 19, 2018 4:11 pm
by rockedge
I am seeing a strange usb webcam error similar now! I have been trying some ZM configs and using 3 different types of webcam. with a cheap logitech it always seems to work...but with this one I tried (USB the other UCV) works a moment then fails with the same symptoms you report. There seems to be a difference in the UCV and USB type webcams with ZM....I am looking further into it

Re: ZM not displaying any camera streams

Posted: Sat Jul 28, 2018 5:49 am
by doubleosix
I have a similar issue. Sometimes the video feeds are not properly displayed in firefox and safari, there will just be a question mark where the video should be. The montage view never works properly in firefox, it is always a single column even though 4 wide grid is selected.

Safari seems to work 95% of the time, and rebooting the computer seems to fix any issues with video not displaying.

I have not noticed any difference in video not being displayed based on camera or dvr type. only that sometimes in montage view the first 12 or so cameras video will work and the other 60 cameras just get a ? in place of video.

Re: ZM not displaying any camera streams

Posted: Fri Jan 04, 2019 12:06 pm
by DinghySailor
I have now upgraded to v.1.32.3. I can still have the picture capture, but still I am unable to see any video streams in the montage window.
I can see the placeholders where the video should be, but nothing is evident.
I wanted to check the placeholders, but the new options list seems greatly simplified, and so any pointers as to how to get the full functionality from ZM as I used to have would be greatly appreciated.
Many thanks,