No image streaming on Floureon SP12 camera

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
johnaaronrose
Posts: 44
Joined: Tue Feb 27, 2018 9:27 am

No image streaming on Floureon SP12 camera

Post by johnaaronrose » Fri Mar 16, 2018 1:49 pm

I've upgraded from ZM 1.29 to ZM 1.30 (under Ubuntu 16.04 Desktop) as per the wiki. ZM comes up with http://localhost:81/zm/index.php (in Chrome browser) as I set Apache up (by amending the appropriate apache php file) to listen on port 81. My router has Port Forwarding on port 81 to this PC. I'm able to configure ZM but images do not stream to ZM in the window that it opens when I click on the static ip address (assigned by my router according to camera's MAC address). I've tried both wired & wireless connections of the camera to my router. I'm able to stream images to my Android tablet (using the onvifer app but only with rtsp stream as it does not discover the camera using onvif), and to my PC with vlc using the Network Stream rtsp://192.168.101.50:554/onvif1 for wired or rtsp://192.168.101.51:554/onvif1 for wireless (interestingly I don't need the username & password for the camera in vlc). However, even though ispy's camera database shows my Floureon SP012 as an acceptable camera http://www.ispyconnect.com/man.aspx?n=floureon using ffmpeg, I can't see any pics when trying to stream in ZM. ZM 1.30 doesn't give an ffmpeg (in the Source tab) when creating/editing a camera's configuration as per ZM's documentation. I've tried RTSP as the Remote Protocol as well as HTTP. What should I enter in the Source tab's fields to get ZM 1.30 to work with my camera?
PS The ZM documentation for the Source tab is very confusing: I see no mention of ffmpeg anywhere when running ZM even though it's referred to in the documentation:
"Remote Protocol
Choices are currently HTTP and RTSP. Before RTSP became the industry standard, many ip cameras streamed directly from their web portal. If you have an ip camera that does not speak RTSP then choose HTTP here. If you camera does speak RTSP then you should change your source type to ffmpeg instead of selecting RTSP here. The Remote -> RTSP method is no longer being maintained and may go away at some point in the future.
Remote Method
When HTTP is the Remote Protocol, your choices are Simple and Regexp. Most should choose Simple. When RTSP is the Remote Protocol, your choices are RTP/Unicast, RTP/Multicast, RTP/RTSP, RTP,RTSP,HTTP. Try each of these to determine which works with your camera. Most cameras will use either RTP/Unicast (UDP) or RTP/RTSP (TCP).
Remote Host/Port/Path
Use these fields to enter the full URL of the camera. Basically if your camera is at http://camserver.home.net:8192/cameras/camera1.jpg then these fields will be camserver.home.net, 8192 and /cameras/camera1.jpg respectively. Leave the port at 80 if there is no special port required. If you require authentication to access your camera then add this onto the host name in the form <username>:<password>@<hostname>.com. This will usually be 32 or 24 bit colour even if the image looks black and white. Look in Supported Hardware > Network Cameras section, how to obtain these strings that may apply to your camera."
John

bbunge
Posts: 2385
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: No image streaming on Floureon SP12 camera

Post by bbunge » Sat Mar 17, 2018 1:41 am

Two common errors:
PATH_ZMS is not set to /zm/cgi-bin/nph-zms
Camera resolution in Zoneminder does not match camera output. Use VLC (Tools, Media Information, Codec) to check camera Display Resolution.

If you can stream in VLC use that string in Zoneminder, ffmpeg, source path. Use TCP and double check the resoution as discovered in VLC above.

johnaaronrose
Posts: 44
Joined: Tue Feb 27, 2018 9:27 am

Re: No image streaming on Floureon SP12 camera

Post by johnaaronrose » Sat Mar 17, 2018 5:54 pm

PATH_ZMS is set to /zm/cgi-bin/nph-zms
Camera resolution in ZM matches camera output obtained from vlc.
So I set General->Source Path to Ffmpeg. But what do I set Source->Remote Method to (options being: TCP, UDP, UDP Multicast, HTTP Tunnel)? Also, how do I set the rest of the working vlc's 'Open Network Stream' of rtsp://192.168.101.50:554/onvif1 in ZM?
John

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests