Zoneminder drops camera almost daily (white screen)

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
flyride
Posts: 1
Joined: Sun Dec 10, 2017 8:30 pm

Zoneminder drops camera almost daily (white screen)

Post by flyride » Sun Dec 10, 2017 9:00 pm

I have a strange problem with one of my Zoneminder machines and I'm not sure if anyone has any suggestions. Every day or two one of the cameras somehow loses communication with Zoneminder. If I click the liveview it's blank and it doesn't record any events after it disappears. I just reboot the Zoneminder server and it starts working fine again.

Here's what I have observed:

-Rebooting Zoneminder server corrects the problem immediately (liveview and motion detection / recording start working as soon as it boots back up)
- It doesn't matter how long you leave it, it will never come back to life on its own without a reboot
- If I access the camera directly via VLC or webpage after it has dropped off Zoneminder it still works fine, and I can ping it no problem even though Zoneminder can't see it any more
- If I don't reboot Zoneminder and I only reboot the camera (disconnecting ethernet cable on the PoE switch) Zoneminder still won't detect it until the server is rebooted
- Only affects 1 camera, all other cameras are fine

What I have attempted to do to narrow the problem down:
- Completely deleted the 'monitor' and recreated it from scratch
- Deleted and recreated the 'zone'
- Tried changing random settings in the 'monitor' to no avail
- Tried moving the camera to a new port on the PoE switch
- Tried updating the camera firmware to the latest version

Configuration / Make / Model / Info:
- ASUS P6P67 Deluxe System Board
- i7 2600K
- 16gb DDR3 1600
- 60gb SSD (OS) + 4TB WD Purple (Videos)
- CentOS 7 + Zoneminder 1.30.x latest (Dedicated to Zoneminder only)
- AX750 Power Supply
- Load is good, usually 1.5-3.5

Problem Camera Information:
- 1x AvertX HD810 4MP (RTSP port 554, 2560x1440 @ 15fps, H.264)

5 Other Cameras on this machine (all these seem to be working fine):
- 2x AvertX HD810 4MP (this one works fine with same configuration settings on a different IP)
- 2x Swann 3MP dome cameras
- 1x Qsee 1080p bullet camera

For what it's worth I have 2 other Zoneminder machines running similar configurations and I have never had a problem with the AvertX HD810 cameras.

Really strange problem as I can't see how it could possibly be Zoneminder, but that is certainly how it seems. If no one has any suggestions I will probably get a ladder and swap it out with another AvertX camera on another known-working machine in a different location and see what happens. Any suggestions or thoughts would be greatly appreciated!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests