Page 1 of 1

Image tearing and other issues

Posted: Mon May 08, 2017 4:04 pm
by danensis
I've finally migrated from an old Mandriva version of ZM to Ubuntu 14.04 with ZM v1.20.2

I'm using the same capture card that I had in the old machine, and all the same settings. The only difference as far as I can see is that the new setup uses V4L2 rather than V4L. However I have three remaining problems - firstly that the cameras only seem to work when set to NTSC, whereas they were set to PAL on the previous system, and they only show B+W images, whereas they were in colour before, but worse than that, the picture is corrupted, and looks to be interlaced, even though I'm restricting the size to 320x240. There is a black bar down the LH side of the picture, and some duplicated lines at the top.

Any bright ideas? The problem is the same on all six of my cameras.
zm sample.jpg
zm sample.jpg (93.73 KiB) Viewed 2647 times

Re: Image tearing and other issues

Posted: Mon May 08, 2017 8:50 pm
by bbunge
I suspect that your capture card is not fully supported in 14.04. Suggest you search for Zoneminder and your capture card to see what pops up. Try PALB and slow the frame rate down to 5 fps

Re: Image tearing and other issues

Posted: Mon May 08, 2017 9:20 pm
by danensis
Sadly that didn't work. The PALB option just gives a scrambled image.
ZM sample 2.jpg
ZM sample 2.jpg (93.09 KiB) Viewed 2638 times

Re: Image tearing and other issues

Posted: Tue May 09, 2017 5:48 pm
by marcopete87
danensis wrote:
Mon May 08, 2017 4:04 pm
the cameras only seem to work when set to NTSC, whereas they were set to PAL on the previous system, and they only show B+W images, whereas they were in colour before, but worse than that, the picture is corrupted, and looks to be interlaced, even though I'm restricting the size to 320x240. There is a black bar down the LH side of the picture, and some duplicated lines at the top.
are you sure your resolution is correct?
When i used webcams, i had a lot of trouble with nonstandard resolutions, images seemed like yours.
If camera is pal, you have to use pal, 720x576 (or 768×576), if i remember correctly.

Re: Image tearing and other issues

Posted: Tue May 09, 2017 6:18 pm
by mastertheknife
The image is interlaced by default when using V4L2.
Please select "V4L2: Capture top field only" or "V4L2: Capture bottom field only" in the "Deinterlacing" selection.
Regarding the corruption, what card are you using?

Re: Image tearing and other issues

Posted: Mon Jun 05, 2017 1:23 pm
by danensis
I decided to try another capture card, and obtained one that uses the Conexant 8210 chip. I now see full colour images when I use xawtv, but ZoneMinder only captures part of the image, and in very poor quality. I'm beginning to wonder if there is an issue with V4L2 and ZoneMinder?

Re: Image tearing and other issues

Posted: Mon Jun 05, 2017 3:50 pm
by danensis
I managed to get the full-size image using PAL and 720 x 576, but I'm still not seeing as good quality on ZM as I see on xawtv