new install on Ubuntu, not finding Kodicom 8800

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
darkpaw
Posts: 164
Joined: Thu Apr 26, 2007 2:35 am

new install on Ubuntu, not finding Kodicom 8800

Post by darkpaw » Mon Apr 17, 2017 8:36 pm

I had to flatten my server, so I figured I'd go to the most recent Ubuntu (17.4). It installed fine, and the new docs for installing ZM are fantastic, it was a breeze.

The problem appears to be my input card. I setup the bttv.conf in modprobe.d, and it finds the card fine. But no /dev/video* gets created. Is this something that changed in newer versions of Ubuntu? My previous (running long time) install was 14.4 LTS.

root@zm:/dev# dmesg | grep bttv
[ 14.545525] bttv: driver version 0.9.19 loaded
[ 14.545527] bttv: using 2 buffers with 2080k (520 pages) each for capture
[ 14.545569] bttv: Bt8xx card found (0)
[ 14.545909] bttv: 0: Bt878 (rev 17) at 0000:06:0c.0, irq: 17, latency: 64, mmio: 0xf4ffe000
[ 14.545927] bttv: 0: using: IVC-200 [card=102,insmod option]
[ 14.546109] bttv: 0: tuner absent
[ 14.546110] bttv: 0: the autoload option is obsolete
[ 14.546111] bttv: 0: use option msp3400, tda7432 or tvaudio to override which audio module should be used
[ 14.546178] bttv: probe of 0000:06:0c.0 failed with error -34
[ 14.546185] bttv: Bt8xx card found (0)
[ 14.546249] bttv: 0: Bt878 (rev 17) at 0000:06:0d.0, irq: 18, latency: 64, mmio: 0xf4ffc000
[ 14.546258] bttv: 0: using: IVC-200 [card=102,insmod option]
[ 14.546413] bttv: 0: tuner absent
[ 14.546414] bttv: 0: the autoload option is obsolete
[ 14.546415] bttv: 0: use option msp3400, tda7432 or tvaudio to override which audio module should be used
[ 14.546498] bttv: probe of 0000:06:0d.0 failed with error -34
[ 14.546506] bttv: Bt8xx card found (0)
[ 14.546574] bttv: 0: Bt878 (rev 17) at 0000:06:0e.0, irq: 19, latency: 64, mmio: 0xf4ffa000
[ 14.546581] bttv: 0: using: IVC-200 [card=102,insmod option]
[ 14.546718] bttv: 0: tuner absent
[ 14.546719] bttv: 0: the autoload option is obsolete
[ 14.546720] bttv: 0: use option msp3400, tda7432 or tvaudio to override which audio module should be used
[ 14.546798] bttv: probe of 0000:06:0e.0 failed with error -34
[ 14.546806] bttv: Bt8xx card found (0)
[ 14.546858] bttv: 0: Bt878 (rev 17) at 0000:06:0f.0, irq: 16, latency: 64, mmio: 0xf4ff8000
[ 14.546866] bttv: 0: using: IVC-200 [card=102,insmod option]
[ 14.546994] bttv: 0: tuner absent
[ 14.546995] bttv: 0: the autoload option is obsolete
[ 14.546996] bttv: 0: use option msp3400, tda7432 or tvaudio to override which audio module should be used
[ 14.547061] bttv: probe of 0000:06:0f.0 failed with error -34
root@zm:/dev# ls /dev/video*
ls: cannot access '/dev/video*': No such file or directory
root@zm:/dev#

darkpaw
Posts: 164
Joined: Thu Apr 26, 2007 2:35 am

Re: new install on Ubuntu, not finding Kodicom 8800

Post by darkpaw » Tue Apr 18, 2017 2:13 am

Turns out the card was dead. Swapped it with another card and good to go. These cards seem to burn out fairly easily.

User avatar
iconnor
Posts: 705
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: new install on Ubuntu, not finding Kodicom 8800

Post by iconnor » Sat Apr 22, 2017 1:12 pm

I've heard it said that you should put heatsinks on the chips... I usually just make sure there is direct airflow over them.

mastertheknife
Posts: 678
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Re: new install on Ubuntu, not finding Kodicom 8800

Post by mastertheknife » Fri Feb 15, 2019 10:31 pm

A bit late but this also happened to me today, after upgrading my ZM box from CentOS6 to CentOS7.
The exact same error: "bttv: probe of 0000:06:08.0 failed with error -34"
I know for a fact that the card is fine because it has been working fine for years.
After many attempts with the options in bttv.conf, i found that its the combfilter option causing this error. Removing it got the card working!
So don't give up, its not your card, its just a newer kernel\driver.

Here is my /etc/modprobe.d/bttv.conf file that is currently working (after removing combfilter):

Code: Select all

# bttv module options
# For fast loading
options i2c-algo-bit bit_test=1
# The first bttv device is a pico2000 clone, the other 8 are a kodicom 8800 clone.
options bttv gbuffers=16 card=102,102,102,102,102,102,102,102 radio=0,0,0,0,0,0,0,0 tuner=4,4,4,4,4,4,4,4 chroma_agc=1 full_luma_range=1 coring=1
Kfir Itzhak.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests