Cheap eBay POE IP Camera setup issues

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
Mad Professor
Posts: 106
Joined: Wed Dec 15, 2010 11:20 am
Location: Isle Of Wight, UK

Cheap eBay POE IP Camera setup issues

Post by Mad Professor » Sun Mar 26, 2017 8:18 am

Hi All.

Earlier this week I was browsing around eBay and came across some what I would class a very cheap POE IP CCTV Cameras.
When I say cheap I am talking less than £30 delivered.
So for that kind of price I thought I might as well have a try for that kind of price, and I was not really expecting it to have POE, but that being a misprint.
I knew it would not even come anywhere close to the hikvision cameras that I already own.

Anyway to my problem(s).
I am currently unable to get any video feed (stream) working withing zoneminder.
On the Zoneminder main screen (dashboard) the source is green.
But when I click on Monitor I will either get a blue screen, or a white screen, depending on what settings I have.

Looking at the Log, I can see the follow two items regarding this camera.
Level: ERR, File: zm_ffmpeg_camera.cpp
Unable to open input rtsp://xxx.xxx.xxx.xxx:554/live0.264 due to: Operation now in progress

Level: WAR, File: zm_ffmpeg_camera.cpp
Unable to parse ffmpeg option 0 '', expecting key=value
And if I enable username and password for the camera, the source is still green, when you click monitor, you get a white background, then an empty box with a logo of a broken picture file in the top left, this will pulse on and off every half a second.

Looking at the Log I can see the output has also changed, lots of errors, mostly complaining about sock missing or already in use.
Level: ERR, File: zmdc.pl
'zmc -m 2' exited abnormally, exit status 255

Level: FAT, File: zm_ffmpeg_camera.cpp
Unable to find stream info from rtsp://username:password@xxx.xxx.xxx.xxx:554/live0.264 due to: Operation now in progress

Level: WAR, File: zm_ffmpeg_camera.cpp
Unable to parse ffmpeg option 0 '', expecting key=value

Here is some of the background so far.

Camera turned up, and the quality of the camera is what to be expected for less then £30.
Connected the camera up to my POE switch and the camera sprung into life, wow it is POE.
There is no manual or setup cd in the box with the camera, there is a small slip of paper pointing saying the following.
Dear Customer,

Thank you purchasing out IP camera through eBay.
To download the video management software (CMS) and other useful programs please visit the website below:

https://app.box.com/s/i6gn568n1vrkrk3zzwzqhff7c589pprs
Should you have any question, please send us an email; we will reply to you ASAP.

We are the manufacturer of these IP cameras. For full list of available products please go to our website.
http://www.ipnetcamera.com
Thank you.
I did not trust that the files from the above link has not been tampered with, so I downloaded ONVIF Device Manager from https://sourceforge.net/projects/onvifdm/

ONVIF Device Manager can detect the camera, view main and sub streams, as well as being able to adjust some of the cameras settings.

Main Stream: rtsp://xxx.xxx.xxx.xxx:554/live0.264
Sub Stream: rtsp://xxx.xxx.xxx.xxx:554/live1.264

Thanks for your time.

Best Regards.

bbunge
Posts: 2709
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Cheap eBay POE IP Camera setup issues

Post by bbunge » Sun Mar 26, 2017 3:18 pm

Try your streams in VLC then check the resolution VLC reports. Use that resolution in the ffmpeg monitor setup in Zoneminder or divide the resolution by half.

Mad Professor
Posts: 106
Joined: Wed Dec 15, 2010 11:20 am
Location: Isle Of Wight, UK

Re: Cheap eBay POE IP Camera setup issues

Post by Mad Professor » Tue Mar 28, 2017 7:55 pm

bbunge: Thanks for your reply.

I am sure that VLC reports the same details as above, but I will check that when I am next on site over the weekend, is there anything else that I can try in the meantime via the zoneminder ui?

empty01
Posts: 50
Joined: Tue Mar 28, 2017 1:30 pm

Re: Cheap eBay POE IP Camera setup issues

Post by empty01 » Tue Mar 28, 2017 11:33 pm

I get the same problems. Have tried 3 different cameras:
DBPower 301e
Y-cam Bullet (white) 640x480
Vista vk2
Can't get any to work in zoneminder despite being able to view them on VLC

I installed unbuntu then zoneminder and vlc. Nothing else. Is it possible I have failed to install some dependencies. Here is some typical logs - any help greatly appreciated

2017-03-29 00:32:23.588544 web_js 2762 ERR getStreamCmdResponse stream error: socket_sendto( /var/run/zm/zms-323013s.sock ) failed: No such file or directory - checkStreamForErrors() ?view=watch
2017-03-29 00:32:23.548584 web_php 2762 ERR socket_sendto( /var/run/zm/zms-323013s.sock ) failed: No such file or directory /usr/share/zoneminder/www/includes/functions.php 1993
2017-03-29 00:32:11.542947 web_js 2762 ERR getStreamCmdResponse stream error: socket_sendto( /var/run/zm/zms-323013s.sock ) failed: No such file or directory - checkStreamForErrors() ?view=watch
2017-03-29 00:32:11.479660 web_php 5036 ERR socket_sendto( /var/run/zm/zms-323013s.sock ) failed: No such file or directory /usr/share/zoneminder/www/includes/functions.php 1993
2017-03-29 00:32:05.200360 zmdc 1413 ERR 'zmc -d /dev/video0' exited abnormally, exit status 255 zmdc.pl
2017-03-29 00:32:05.177973 zmc_dvideo0 5591 ERR No monitors found zmc.cpp 246
2017-03-29 00:32:05.072990 zmdc 5591 INF 'zmc -d /dev/video0' started at 17/03/29 00:32:05 zmdc.pl
2017-03-29 00:32:05.065090 zmdc 1413 INF 'zmc -d /dev/video0' starting at 17/03/29 00:32:05, pid = 5591 zmdc.pl
2017-03-29 00:32:05.024030 zmdc 1413 INF Starting pending process, zmc -d /dev/video0 zmdc.pl
2017-03-29 00:31:59.310165 web_js 5036 ERR getStreamCmdResponse stream error: socket_sendto( /var/run/zm/zms-323013s.sock ) failed: No such file or directory - checkStreamForErrors() ?view=watch

dstren
Posts: 2
Joined: Fri Oct 28, 2016 3:27 am

Re: Cheap eBay POE IP Camera setup issues

Post by dstren » Wed Mar 29, 2017 1:29 am

Thanks! This was just what I was looking for. I have an Escam QD300 which uses the /11 and /12 for the feeds... many other online sources said that those were reserved for the QD900...

By the way - I've noticed terrible... terrible IR performance at night from this device. Do you have the same experience? Wondering if I got a bad unit. Daytime performance is outstanding!
EscamBrickQD300.JPG
EscamBrickQD300.JPG (214.23 KiB) Viewed 6162 times

empty01
Posts: 50
Joined: Tue Mar 28, 2017 1:30 pm

Re: Cheap eBay POE IP Camera setup issues

Post by empty01 » Wed Mar 29, 2017 5:48 pm

Solved my problem - seems its that common issue of making sure PATH_ZMS is set to /zm/cgi-bin/nph-zms
Apologies for not fully reading the installation guide - damn nubies :-)

Mad Professor
Posts: 106
Joined: Wed Dec 15, 2010 11:20 am
Location: Isle Of Wight, UK

Re: Cheap eBay POE IP Camera setup issues

Post by Mad Professor » Sat Apr 01, 2017 3:33 pm

I am still having issues with getting this camera working with zoneminder.

I have tried viewing the stream with VLC on my windows computer, and both the main and sub stream works just fine.

Within the command line of the zoneminder computer I ran ffmpeg -i rtsp://xxx.xxx.xxx.xxx:554/live0.264 output.mpg
This seems to be working, it spits details out (see below) and the output file is also view able.

Code: Select all

~$ ffmpeg -i rtsp://xxx.xxx.xxx.xxx:554/live0.264 output.mpg
ffmpeg version 2.8.11-0ubuntu0.16.04.1 Copyright (c) 2000-2017 the FFmpeg developers
  built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.4) 20160609
  configuration: --prefix=/usr --extra-version=0ubuntu0.16.04.1 --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-libx264 --enable-libopencv
  libavutil      54. 31.100 / 54. 31.100
  libavcodec     56. 60.100 / 56. 60.100
  libavformat    56. 40.101 / 56. 40.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 40.101 /  5. 40.101
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.101 /  1.  2.101
  libpostproc    53.  3.100 / 53.  3.100
Input #0, rtsp, from 'rtsp://xxx.xxx.xxx.xxx:554/live0.264':
  Metadata:
    title           : Session Streamed by LIBZRTSP
    comment         : live0.264
  Duration: N/A, start: 0.240000, bitrate: N/A
    Stream #0:0: Video: h264 (Main), yuv420p, 1280x720, 25 fps, 25 tbr, 90k tbn, 50 tbc
[mpeg @ 0x1f14a00] VBV buffer size not set, using default size of 130KB
If you want the mpeg file to be compliant to some specification
Like DVD, VCD or others, make sure you set the correct buffer size
Output #0, mpeg, to 'output.mpg':
  Metadata:
    title           : Session Streamed by LIBZRTSP
    comment         : live0.264
    encoder         : Lavf56.40.101
    Stream #0:0: Video: mpeg1video, yuv420p, 1280x720, q=2-31, 200 kb/s, 25 fps, 90k tbn, 25 tbc
    Metadata:
      encoder         : Lavc56.60.100 mpeg1video
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> mpeg1video (native))
Press [q] to stop, [?] for help
frame=   21 fps=0.0 q=15.1 size=     284kB time=00:00:00.76 bitrate=3061.2kbits/s dup=0 drop=4 [NULL @ 0x1ebdee0] RTP: missed 16 packets
[h264 @ 0x2004100] error while decoding MB 52 41, bytestream -9
[h264 @ 0x2004100] concealing 317 DC, 317 AC, 317 MV errors in P frame
frame=   47 fps= 45 q=26.7 size=     382kB time=00:00:01.80 bitrate=1738.5kbits/s dup=1 drop=4
frame=   60 fps= 38 q=31.0 size=     420kB time=00:00:02.32 bitrate=1483.0kbits/s dup=1 drop=4
frame=   73 fps= 35 q=31.0 size=     456kB time=00:00:02.84 bitrate=1315.3kbits/s dup=1 drop=4
frame=   86 fps= 33 q=24.8 size=     522kB time=00:00:03.36 bitrate=1272.7kbits/s dup=1 drop=4
frame=   99 fps= 32 q=31.0 size=     556kB time=00:00:03.88 bitrate=1173.9kbits/s dup=1 drop=4
**********************************************************************************************
[NULL @ 0x1ebdee0] RTP: missed 1 packets
[h264 @ 0x2018c20] concealing 1415 DC, 1415 AC, 1415 MV errors in I frame
frame=  762 fps= 26 q=31.0 size=    2472kB time=00:00:30.40 bitrate= 666.1kbits/s dup=1 drop=4
frame=  775 fps= 26 q=31.0 size=    2508kB time=00:00:30.92 bitrate= 664.5kbits/s dup=1 drop=4
frame=  788 fps= 26 q=31.0 size=    2544kB time=00:00:31.44 bitrate= 662.9kbits/s dup=1 drop=4
frame=  801 fps= 26 q=31.0 size=    2580kB time=00:00:31.96 bitrate= 661.3kbits/s dup=1 drop=4
frame=  814 fps= 26 q=31.0 size=    2616kB time=00:00:32.48 bitrate= 659.8kbits/s dup=1 drop=4
video:2810kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.486626%
~$
Zoneminder logs are still showing the following.
Level: INF, File: zmc.cpp
Starting Capture version 1.30

Level: INF, File: zm_ffmpeg_camera.cpp
Priming capture from rtsp://xxx.xxx.xxx.xxx:554/live0.264

Level: FAT, File: zm_ffmpeg_camera.cpp
Unable to find stream info from rtsp://xxx.xxx.xxx.xxx:554/live0.264 due to: Operation now in progress

Level: ERR, File: zmdc.pl
'zmc -m 2' exited abnormally, exit status 255
Thanks again for your time.

Mad Professor
Posts: 106
Joined: Wed Dec 15, 2010 11:20 am
Location: Isle Of Wight, UK

Re: Cheap eBay POE IP Camera setup issues

Post by Mad Professor » Fri Apr 07, 2017 3:40 pm

I am still not getting anywhere with this camera.

I welcome any suggestions and pointers.

User avatar
iconnor
Posts: 1394
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Cheap eBay POE IP Camera setup issues

Post by iconnor » Sat Apr 08, 2017 2:58 pm

try either the remote or libvlc source type

Mad Professor
Posts: 106
Joined: Wed Dec 15, 2010 11:20 am
Location: Isle Of Wight, UK

Re: Cheap eBay POE IP Camera setup issues

Post by Mad Professor » Sat Apr 08, 2017 3:50 pm

Today I tried a spare system, and did a clean install of Ubuntu Server 16.04.2 LTS + Zoneminder 1.30.2, and the camera is now working, but keeps on dropping the connection.

So there is clearly something wrong with my current setup.

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests