Wansview W2 blurry image/pixelation

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
theskunk
Posts: 2
Joined: Fri Jan 13, 2017 5:39 pm

Wansview W2 blurry image/pixelation

Post by theskunk » Fri Jan 13, 2017 6:11 pm

Hello,

I've purchased a Wansview W2 outdoor camera, and am using it with ZoneMinder.

I'm using the RTSP stream (rtsp://user:pass@ip/live/ch0) found here:

http://marc.merlins.org/perso/linuxha/p ... l#NCM625GA

I've tried flipping it to VLC, which at lower resolutions seems to work okay, but turning it to the 1080p breaks the image again.

My challenge has to do with zone minder, as the application on my iPhone appears to have a smooth video stream. Here's a shot of my back porch, which obviously should be a clear-isa image.
Untitled.jpg
Untitled.jpg (328.99 KiB) Viewed 2382 times
The post I referred to above mentions using a "standard mjpeg" method, but I can't seem to figure out how to configure that.

For what it's worth, I have a K1 and a K2, which are both working perfectly.

Any help/suggestions of how to configure this would be greatly appreciated!

theskunk
Posts: 2
Joined: Fri Jan 13, 2017 5:39 pm

Re: Wansview W2 blurry image/pixelation

Post by theskunk » Fri Jan 13, 2017 8:38 pm

Found a wiki article here:

https://wiki.zoneminder.com/Doing_your_ ... SP_streams

Which seems to address many of my issues. I did switch over to libvlc and saw the same skyrocket in cpu usage. I have 4 cams going (one is an iPhone), so I can't possibly run LibVLC on all of them. Continuing to investigate, but this probably has me 80% of the way along. Thanks to the guy that put this together!

User avatar
iconnor
Posts: 1345
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Wansview W2 blurry image/pixelation

Post by iconnor » Sat Jan 14, 2017 2:27 pm

Blurry/pixellation is often caused by having the wrong width/height entered in the monitor. zm will scale the image to fit the dimensions you entered, so check that

User avatar
MJN
Posts: 250
Joined: Wed Jan 17, 2007 10:29 am
Location: Wiltshire, UK
Contact:

Re: Wansview W2 blurry image/pixelation

Post by MJN » Mon Feb 13, 2017 8:49 pm

theskunk wrote:For what it's worth, I have a K1 and a K2, which are both working perfectly.
Might you able to share your settings for the K1? I've just bought one today and whilst all is working well with the Wansview app and Firefox I'm struggling with integrating with ZM...

User avatar
MJN
Posts: 250
Joined: Wed Jan 17, 2007 10:29 am
Location: Wiltshire, UK
Contact:

Re: Wansview W2 blurry image/pixelation

Post by MJN » Tue Feb 14, 2017 6:47 pm

To follow up on my query I applied the patch at the marc.merlins.org site and this enabled me to use a snapshot JPEG type approach. Also got RTSP working. Rather than post the details here for others I'll look at writing a wiki page so it's all in one place.

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests