SOLVED: API/cake issues: Error: ZoneminderController could not be found.

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
davidma
Posts: 22
Joined: Fri Oct 16, 2015 1:40 am

SOLVED: API/cake issues: Error: ZoneminderController could not be found.

Post by davidma » Fri Dec 02, 2016 12:27 am

Hello I'm using the zoneminder package from Arch Linux AUR. v1.30

Everything else appears to be working however when trying to get the api working upon going to the "http://mylocaliphere/zoneminder/api/" url I get the following:
"Missing Controller

Error: ZoneminderController could not be found.

Error: Create the class ZoneminderController below in file: app/Controller/ZoneminderController.php"
Any help or hints?

I'm guessing maybe this is related to a alias issue? Here is what I have:

Code: Select all

# /etc/httpd/conf/extra/httpd-zoneminder.conf
# Config for zoneminder web app

Alias /zm "/srv/http/zoneminder"
<Directory "/srv/http/zoneminder">
  Options -Indexes +MultiViews +FollowSymLinks
  AllowOverride None
  Order allow,deny
  Allow from all
  # Provide PHP directory and file access, see http://php.net/manual/en/ini.core.php#ini.open-basedir
  php_admin_value open_basedir "/tmp/:/etc/zm.conf:/srv/http/zoneminder/:/var/cache/zoneminder/:/var/lib/zoneminder/:/var/log/zoneminder/"
</Directory>

ScriptAlias /cgi-bin "/srv/http/cgi-bin"
<Directory "/srv/http/cgi-bin">
  AllowOverride None
  Options +ExecCGI +FollowSymLinks
  Order allow,deny
  Allow from all
</Directory>

<Directory /srv/http/zoneminder/api>
    AllowOverride All
</Directory>
As said everything else seems to be working. I have three IP cameras which can stream, record, and detect motion perfectly. I just cannot work with the API. Of note I did upgrade from v.1.29 recently however I did not use the api before so I have no idea if it worked with the current config then either.

Thank you.

davidma
Posts: 22
Joined: Fri Oct 16, 2015 1:40 am

Re: SOLVED: API/cake issues: Error: ZoneminderController could not be found.

Post by davidma » Fri Dec 02, 2016 12:44 am

Well that was easy. using "http://mylocaliphere/zm/api" works fine. Zmninja wizard also now completes successfully. Solved. :)

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests