Can't see my cam video but can record it?

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
milesnz
Posts: 5
Joined: Wed Nov 02, 2016 8:42 am

Can't see my cam video but can record it?

Post by milesnz » Fri Nov 04, 2016 2:57 am

Hi,

I am not able to see my camera feed when in Monitor mode - but when I switch it to Record mode then it records and I can play it back in the montage window.
There is definitely data flowing because I can see the Network Receiving stats happening at about 300kbs.
I've tried all possible settings, including trying from another pc in the house, trying IE and also Chrome, on Windows and also on Linux.
What have I done wrong?

When I load the mrl into VLC I can see the video feed no problem.

zm1.30.x
Linux Ubuntu Server 16.04.1 LTS 64bit

Chinese IPCams
SourceType=Ffmpeg
rtsp://admin:tlJwpbo6@192.168.1.71:554/user=admin_password=tlJwpbo6_channel=1_stream=1.sdp?real_stream
RTP/RTSP
640x480

Tantamount
Posts: 71
Joined: Wed Feb 03, 2016 7:51 am

Re: Can't see my cam video but can record it?

Post by Tantamount » Fri Nov 04, 2016 9:07 pm

Milesnz,

From /zm/index.php, click on Log

Leave that window open, and then try to view a monitor. Do any recent log entries appear? Anything that might help clue you into what may be happening?

Also, so that others here can get a bigger picture, please do the following:

From /zm/index.php, click on the Source that is giving you trouble.
Look at the top left of that windows -- There should be some blue text that starts with "Monitor - " followed by the monitor name and a number in parenthesis. Make note of that number.
Get a terminal prompt on your Zoneminder server (ssh works well for this).
Issue this command:
curl -k https://127.0.0.1/zm/api/monitors/NUMBER.json
where NUMBER is the number within the parenthesis.
I.E. if the number is 2:
curl -k https://127.0.0.1/zm/api/monitors/2.json

That should output all of the settings for that monitor -- just copy and paste that here (preferably within a CODE block).

The only thing else I can think of to try is to give us the Codec Information that VLC has while viewing your stream. We can verify that you've got the right dimensions, etc from that.
2 LaView LV-PB932F4
4 ReoLink RLC-411
CentOS 7.4 - 8 Core Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 16 Gigs ram (Running under XenServer as a VM)
ZoneMinder Version : 1.31.1 Release : 1.320.20180206gitga177d8e9.el7.centos

milesnz
Posts: 5
Joined: Wed Nov 02, 2016 8:42 am

Re: Can't see my cam video but can record it?

Post by milesnz » Fri Nov 04, 2016 10:51 pm

Hi,
Thanks for responding

Log errors seen when opening a monitor

Code: Select all


Date/Time
Component	Server	PID	Level	Message	File	Line
2016-11-05 11:42:24.342665	web_js		16286	ERR	getStreamCmdResponse stream error: socket_sendto( /var/run/zm/zms-607969s.sock ) failed: No such file or directory - checkStreamForErrors()	?view=watch	
2016-11-05 11:42:24.284706	web_php		16286	ERR	socket_sendto( /var/run/zm/zms-607969s.sock ) failed: No such file or directory	/usr/share/zoneminder/www/includes/functions.php	1993
HTTPS is denied but the command works under http - is that the issue?

Code: Select all

miles@ubuntu:/$ curl -k https://localhost/zm/api/monitors/10.json
curl: (7) Failed to connect to localhost port 443: Connection refused
miles@ubuntu:/$ 
curl -k http://localhost/zm/api/monitors/10.json
{
    "monitor": {
        "Monitor": {
            "Id": "10",
            "Name": "NVT",
            "ServerId": "0",
            "Type": "Ffmpeg",
            "Function": "Monitor",
            "Enabled": "1",
            "LinkedMonitors": "1",
            "Triggers": "",
            "Device": "rtsp",
            "Channel": "0",
            "Format": "255",
            "V4LMultiBuffer": false,
            "V4LCapturesPerFrame": "1",
            "Protocol": "rtsp",
            "Method": "rtpRtsp",
            "Host": "http:\/\/192.168.1.71:8899\/onvif\/device_service",
            "Port": "554",
            "SubPath": "",
            "Path": "rtsp:\/\/admin:tlJwpbo6@192.168.1.71\/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp?real_stream",
            "Options": "",
            "User": "",
            "Pass": "",
            "Width": "1920",
            "Height": "1080",
            "Colours": "4",
            "Palette": "3",
            "Orientation": "0",
            "Deinterlacing": "0",
            "RTSPDescribe": false,
            "Brightness": "-1",
            "Contrast": "-1",
            "Hue": "-1",
            "Colour": "-1",
            "EventPrefix": "Event-",
            "LabelFormat": "%N - %d\/%m\/%y %H:%M:%S",
            "LabelX": "10",
            "LabelY": "10",
            "LabelSize": "2",
            "ImageBufferCount": "50",
            "WarmupCount": "25",
            "PreEventCount": "25",
            "PostEventCount": "25",
            "StreamReplayBuffer": "1000",
            "AlarmFrameCount": "1",
            "SectionLength": "600",
            "FrameSkip": "0",
            "MotionFrameSkip": "0",
            "AnalysisFPS": "0.00",
            "AnalysisUpdateDelay": "0",
            "MaxFPS": "0.00",
            "AlarmMaxFPS": "0.00",
            "FPSReportInterval": "1000",
            "RefBlendPerc": "6",
            "AlarmRefBlendPerc": "6",
            "Controllable": "0",
            "ControlId": "0",
            "ControlDevice": null,
            "ControlAddress": null,
            "AutoStopTimeout": null,
            "TrackMotion": "0",
            "TrackDelay": "0",
            "ReturnLocation": "-1",
            "ReturnDelay": "0",
            "DefaultView": "Events",
            "DefaultRate": "100",
            "DefaultScale": "100",
            "SignalCheckColour": "#0000c0",
            "WebColour": "red",
            "Exif": false,
            "Sequence": "1"
        }
    }




VLC Codec info

Code: Select all

Stream 0
	Type: Video
	Codec: H264 - mpeg-4 avc (part 10) (h264)
	Resolution: 1920x1080
	Frame Rat: 25
	Decoded format: Planar 4:2:0 YUV
	
Stream 1
	Type: Audio
	Codec: PCM ALAW (alaw)
	Channels: Mono
	Sample Rate: 8000Hz
	Bits per Sample: 16

Blue Iris shows the camera config as such (works perfectly)

Code: Select all

Opening port 80...
HTTP request...
OK
GetCapabilities...
No response
Opening port 8899...
GetCapabilities...
Response!
requesting device information
Manufacturer: H264
Model: NVT
FirmwareVersion: V100
has Media services: /onvif/Media
has RTP/RTSP, requesting profiles
first profile is 000
requesting URI for profile 000
RTSP URI: /user=admin_password=tlJwpbo6_channel=1_stream=0.sdp?real_stream
has PTZ services
Preset: =
Done


SteveGilvarry
Posts: 418
Joined: Sun Jun 29, 2014 1:12 pm
Location: Melbourne, AU

Re: Can't see my cam video but can record it?

Post by SteveGilvarry » Sat Nov 05, 2016 5:17 am

Production Zoneminder 1.32.3
Random Selection of Cameras (Dahua and Hikvision)
More Dev VM's than I care to count.

jkemp
Posts: 13
Joined: Thu Mar 05, 2015 10:20 pm

Re: Can't see my cam video but can record it?

Post by jkemp » Sat Nov 05, 2016 5:22 am

Did you change the port to :554? Normally rtsp:\\ uses port :8554

milesnz
Posts: 5
Joined: Wed Nov 02, 2016 8:42 am

Re: Can't see my cam video but can record it?

Post by milesnz » Sat Nov 05, 2016 5:57 am

Hi jkemp, according to wiki the default port for rtsp is 554 and 8554 is an alternate port. I didn't change it myself to 554, it came as the default.

milesnz
Posts: 5
Joined: Wed Nov 02, 2016 8:42 am

Re: Can't see my cam video but can record it?

Post by milesnz » Sat Nov 05, 2016 6:13 am

Hi SteveGilvarry,
That worked - for some reason the path in options was set to /cgi-bin/nph-zms instead of /zm/cgi-bin/nph-zms.
Awesome, thanks for all the help and advice everyone.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests