CentOS7 Nothing in /var/www/html

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
Posts: 3
Joined: Sat Oct 29, 2016 7:15 pm

CentOS7 Nothing in /var/www/html

Post by Wiggy » Sat Oct 29, 2016 7:25 pm


I am new to ZoneMinder. I installed ZoneMinder on CentOS7 following the instructions. Everything went smoothly. I then followed the instructions in the README, and again, everything went smoothly.

However, when I went to http://IPaddress/zm, I just received a generic error from IE. I tried multiple variations, but kept receiving the same error.

I am not new to CentOS and have created my own, basic webserver before. So I went into the /var/www/html and there is nothing there, not even a single file. I am assuming that during the installation process, it would have created/moved stuff into there.

I started with a fresh CentOS minimal install. The only things I did was to disable/stop firewalld, download/enable/start iptables, download wget, and perform a yum update.

If anyone has any suggestions of where to go from here, that would be great. I can do a fresh install if need be, however it seems like an issue with the installer.


EDIT: I didn't do anything with Apache such as changing permission, editing Apache's conf file, or creating new users. I noticed that all of those commands were for Ubuntu. I thought that the installer would take care of this (if this is even the issue).

EDIT 2: I just did a complete fresh install with CentOS 6 and ran into the same issue.

EDIT 3: I did another install, this time using Ubuntu Server 16.x. It works! The only thing that I had to do on Ubuntu and not on CentOS (as per the instructions), is set permissions and ownerships. So I'm not sure if there is something wrong with the CentOS .rpm or if the instructions are missing some steps.
Last edited by Wiggy on Sun Oct 30, 2016 12:14 am, edited 3 times in total.

Posts: 2704
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: CentOS7 Nothing in /var/www/html

Post by bbunge » Sat Oct 29, 2016 8:27 pm

Likely you will need to open the firewall to get to Apache.

Posts: 3
Joined: Sat Oct 29, 2016 7:15 pm

Re: CentOS7 Nothing in /var/www/html

Post by Wiggy » Sat Oct 29, 2016 8:40 pm

The default settings for iptables on the ZoneMninder server are all set to "Allow".

Posts: 3
Joined: Sat Oct 29, 2016 7:15 pm

Re: CentOS7 Nothing in /var/www/html

Post by Wiggy » Sat Oct 29, 2016 8:42 pm

I just performed a complete reinstall (this is on a VM so I just deleted the whole thing and started fresh) and have the same issue.

User avatar
Posts: 2327
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS7 Nothing in /var/www/html

Post by knight-of-ni » Mon Oct 31, 2016 4:48 pm

Just like Windows (I can't believe I just said that), many Linux distros ship with the firewall enabled. Redhat distros are no exception, but it turns out that Ubuntu is an exception.

In order to access zoneminder from a remote machine, you have to open HTTPS port 443 on the server, or just turn off the firewall. CentOS 7 uses firewalld as the active firewall, so you've got to open the ports using that tool, not iptables.

Modern Linux distros have stopped placing files under/var/www/html since a long time ago. Instead, relevant sites are Aliased in, usually under /usr/share.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Posts: 71
Joined: Wed Feb 03, 2016 7:51 am

Re: CentOS7 Nothing in /var/www/html

Post by Tantamount » Mon Oct 31, 2016 8:02 pm

One of the first things I do when installing Centos 7 is swap out firewalld for iptables.

It looks like the instructions here should work if you want to do this:
http://www.tejasbarot.com/2014/08/02/rh ... -iptables/
2 LaView LV-PB932F4
4 ReoLink RLC-411
CentOS 7.4 - 8 Core Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 16 Gigs ram (Running under XenServer as a VM)
ZoneMinder Version : 1.31.1 Release : 1.320.20180206gitga177d8e9.el7.centos

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests