Qcam IP2M822E

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
AndyMac
Posts: 18
Joined: Thu Sep 15, 2016 11:55 pm

Qcam IP2M822E

Post by AndyMac » Fri Sep 23, 2016 8:14 pm

I'm now trying a second camera on zoneminder and having problems again ... similar symptom, but solution must be different.

Note that my first camera (a Foscam C1) is now working perfectly in zoneminder using ffmpeg, so there shouldn't be any underlying ZM or ffmpeg problems.

This is an Amcrest (which is foscam) Qcam IP2M822E. The closest I could find to what's in the list on the hardware guide (https://wiki.zoneminder.com/Amcrest_QCam). I think this is the same camera as that second one (the 2MP one), but in a different color.

The errors I'm getting are simply:

Code: Select all

Unable to open input rtsp://admin:12345@192.168.1.16:554/realmonitor?channel=1&subtype=0 due to: Operation now in progress
Also, a blue screen in the monitor.

I've tried now at different resolutions (1280x720 and 1920x1080, predominantly). I've set it to max of 10 FPS (the camera is set up to just use 8 frames per second though I also tried max of 30fps just in case it wasn't setting correctly and I tried with those left blank, but it went into buffer overrun analyzing the blue screen).

I've got it set up for RTP/RTSP

The camera is viewable using their qcam "SmartClient" software (which is what I used to set it to 8fps)

The source path I've tried is above, but I also tried without the username/pass (those don't appear changeable ... they're on a sticker on the camera and not configurable in SmartClient).

Any ideas what to try next?

AndyMac
Posts: 18
Joined: Thu Sep 15, 2016 11:55 pm

Re: Qcam IP2M822E

Post by AndyMac » Mon Sep 26, 2016 3:21 pm

If no one has any answer for that specifically ... is there any other debugging I can do? I'm trying to figure out next steps here.

User avatar
knight-of-ni
Posts: 2257
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Qcam IP2M822E

Post by knight-of-ni » Mon Sep 26, 2016 5:03 pm

Operation now in progress means you either don't have the parameters quite right (particularly the resolution) or some other application has already acquired the stream.

Use the free Onvif Device manager to tell you what the correct url should be. Once you know that, put that url into vlc. Assuming vlc plays the stream, use the resolution vlc reports. Don't rely on the resolution stated on the box. The resolution has to match what the camera is sending, down to the exact pixel.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

AndyMac
Posts: 18
Joined: Thu Sep 15, 2016 11:55 pm

Re: Qcam IP2M822E

Post by AndyMac » Mon Sep 26, 2016 6:18 pm

Gotcha. I can't imagine anything else has the stream since I've tried rebooting both the camera and the server (and closing down / killing all browsers) between trying to set up again.

I'd love to try this onvif manager to determine the actual resolution, but it seems that's a windows-only tool? Are there any tools for finding the resolution via linux command line or osx (or even GUI-based for either of those)? I don't have a windows box available.

User avatar
knight-of-ni
Posts: 2257
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Qcam IP2M822E

Post by knight-of-ni » Mon Sep 26, 2016 6:22 pm

I completely forgot to mention.... ZoneMinder 1.30 now has onvif discovery. Try zoneminder's Onvif discovery and see if it populates the camera parameters for you.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

AndyMac
Posts: 18
Joined: Thu Sep 15, 2016 11:55 pm

Re: Qcam IP2M822E

Post by AndyMac » Mon Sep 26, 2016 7:19 pm

Oooo!!! This should be selling feature #1!

Just tried it and it worked beautifully. In case anyone stumbles over here, the settings it picked are:
rtsp://admin:12345@192.168.1.16:554/h264Preview_01_main
RTP/Unicast
24 bit colour
1920x1080

It also had a 640 resolution smaller stream. I don't see, though, that zoneminder has a way to use the lower bitrate stream to do motion capture and then record the higher resolution stream (which makes sense), so I picked the 1080P stream.

User avatar
knight-of-ni
Posts: 2257
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Qcam IP2M822E

Post by knight-of-ni » Mon Sep 26, 2016 7:34 pm

Glad it worked for you.

You will need to add a second monitor, configured for the second stream, if you want to analyse the secondary stream and let that trigger an event on the primary stream. You do this by linking the two monitors.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

AndyMac
Posts: 18
Joined: Thu Sep 15, 2016 11:55 pm

Re: Qcam IP2M822E

Post by AndyMac » Mon Sep 26, 2016 8:05 pm

Gotcha. Pretty swift :).

I don't think I need to do that ... running 5 cameras on a gig network ... so I'll leave it alone and working for now, but good to know it's possible!

Thanks!

AndyMac
Posts: 18
Joined: Thu Sep 15, 2016 11:55 pm

Re: Qcam IP2M822E

Post by AndyMac » Mon Sep 26, 2016 11:08 pm

One more question in case anyone knows for this camera (couldn't find it online)

I see a lot of "smearing / smudging" in the monitoring view. Virtually every five seconds I stare at a second or two of smearing. I looked at this site:
https://wiki.zoneminder.com/Doing_your_ ... SP_streams

And one of the suggestions was to use the ZM "remote" source type. Now, I got it to work with FFMPEG (but with smearing), but can't get the same settings to work with "remote".

Specific errors are:
socket_sendto( /tmp/zm/zms-970116s.sock ) failed: No such file or directory
getStreamCmdResponse stream error: socket_sendto( /tmp/zm/zms-970116s.sock ) failed: No such file or directory - checkStreamForErrors()
Terminating, last frame sent time 1474931145.468866 secs more than maximum of 10.000000

And then I just get the occasional "broken image" image for the monitor.

My settings in source are:
protocol: rtsp
method: rtp/rtsp
host name: admin:12345@192.168.1.16
port:554
path: /h264Preview_01_main
color: 24 bit
width: 1920
height: 1080

So ... identical to the ffmpeg, but split out into the correct (I believe) sections.

I'll play with the camera itself in ffmpeg mode when I get home, but currently, it smears way worse than the foscam_c1 I've also got hooked up, which is a way worse camera (and there's no smears on the qcam software when I use that to view the camera).

User avatar
knight-of-ni
Posts: 2257
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Qcam IP2M822E

Post by knight-of-ni » Tue Sep 27, 2016 12:17 am

The libvlc source type was added as a work around to the ffmpeg smearing issue.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

AndyMac
Posts: 18
Joined: Thu Sep 15, 2016 11:55 pm

Re: Qcam IP2M822E

Post by AndyMac » Tue Sep 27, 2016 3:44 am

Understood, and that appears to work. Just as the linked site says, it definitely does take far more CPU (went from 25% to 35% for each camera ... good thing this is a quad core machine since I'm going to be using at least 5 cameras).

User avatar
knight-of-ni
Posts: 2257
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Qcam IP2M822E

Post by knight-of-ni » Tue Sep 27, 2016 11:59 am

There are different work arounds for the ffmpeg smearing issue.

Here is one such thread that discusses what ffmpeg parameters you can adjust which might help:
https://github.com/ZoneMinder/ZoneMinder/issues/811

This question gets asked a lot so you can also find many threads in the user forums regarding this by searching ffmpeg, smearing, or tearing.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

AndyMac
Posts: 18
Joined: Thu Sep 15, 2016 11:55 pm

Re: Qcam IP2M822E

Post by AndyMac » Tue Sep 27, 2016 2:51 pm

Thanks for the tip there. I'm also noticing smearing even with libvlc, though instead of every 5 seconds, it's every couple hours ... looks like I could adjust the minimum average alarm score or something to not alarm all of those, but I'll check out the link and search out threads as well.

Much appreciated!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests