Upgrade to 1.30 Error

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
mattionline
Posts: 53
Joined: Thu Jun 18, 2015 7:27 pm
Contact:

Upgrade to 1.30 Error

Post by mattionline » Fri Aug 05, 2016 10:53 am

Hello,

today i wanted to upgrade zoneminder to 1.30.

Then i got this error:

zoneminder (1.30.0-xenial) wird eingerichtet ...
Can't locate ZoneMinder/ConfigAdmin.pm in @INC (you may need to install the ZoneMinder::ConfigAdmin module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/local/bin/zmupdate.pl line 75.
BEGIN failed--compilation aborted at /usr/local/bin/zmupdate.pl line 75.
dpkg: Fehler beim Bearbeiten des Paketes zoneminder (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
Fehler traten auf beim Bearbeiten von:
zoneminder
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can i install 1.30 correctly?

sources.list

deb http://ppa.launchpad.net/iconnor/zoneminder/ubuntu xenial main
deb-src http://ppa.launchpad.net/iconnor/zoneminder/ubuntu xenial main
My Personal Blog: https://mattionline.de

User avatar
knight-of-ni
Posts: 2257
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Upgrade to 1.30 Error

Post by knight-of-ni » Fri Aug 05, 2016 2:31 pm

You have stale files on your system. This is caused by having previously installed ZoneMinder from-source at one point or another. See how the error message points to /usr/local/bin/zmupdate.pl rather than /usr/bin/zmupdate.pl? Packages don't install to /usr/local, which means your filesystem has a fatal mix of old and new zoneminder files.

What you need to do is uninstall the ZoneMinder package currently on your system, then manually search your entire filesytem for any remnants of ZoneMinder: delete all zoneminder perl modules, delete any zm.conf files, delete old init scripts. Once you've purged everything ZoneMinder related, begin the install from package again, following the documentation for that particular package.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

mattionline
Posts: 53
Joined: Thu Jun 18, 2015 7:27 pm
Contact:

Re: Upgrade to 1.30 Error

Post by mattionline » Fri Aug 05, 2016 4:19 pm

Thank you very very much!
This has solved my problem.
My Personal Blog: https://mattionline.de

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests