Page 1 of 1

Capture frame rate changes mid recording.

Posted: Fri Nov 25, 2016 5:30 pm
by SpikeyGG

I've used ZM for a long time and I've always had an issue with this but I have never figured it out. When a recording is triggered the first few frames ~20-30 are at an acceptable frame rate (and motion is smooth), after that the frame rate drops to a much lower value and you can see this as the subject in the frames starts jerking about. Occasionally, the video freezes for a while (seconds) and when it comes back the subject is long gone having dropped all the important frames.

I've tried playing with the Captures per Frame, Analysis FPS, Maximum FPS and Alarm Maximum FPS but I cannot find a set of values that makes the triggered capture a smooth recording. I've tried to find definition of these terms using google and found some of them described here but Captures per frame and Analysis FPS are not described. It seems any time I try to use the Analysis FPS the recording is terrible and drops many of the frames.

My tests are below and you can see from each one that it either drops entirely when the analysis starts or it just gets choppy. In each recording I wave the dust wand up and down 4 times smoothly (4 ups and 4 downs). I have read that leaving these fields blank is supposed to be the best but when I do that it drops much of the capture (see the first one in the list). When I leave the Max FPS blank, the camera runs at 30 fps (Idle state).
Details of my setup:
  • Single Camera, V4L v2 analog composite input (pcHTDV HD-3000 capture card using video input)
  • Capture Resolution: 640x480x24bit
  • Computer is a server 6-core (12HT) with 128GB of ram so I have a huge /dev/shm (~60GB).
  • I am using a deinterlacer but I tried disabling it and it does not toggle this issue.

Re: Capture frame rate changes mid recording.

Posted: Sun Nov 27, 2016 4:18 pm
by SpikeyGG
FYI, I just upgraded to 1.30 and the problem persists.