Page 1 of 1

Is Max Framerate my only choice?

Posted: Sun Mar 27, 2016 9:48 pm
by jasauders
Hello friends. I'm on Ubuntu Server 14.04 with ZM 1.29.0. Everything is running great, however I am having an issue with one of my indoor cameras. It's a Foscam 8910W acting as a baby camera for my youngster. It's 640x480 via MJPG.

The issue is it does not look like the camera itself reflects its framerate setting with its output. (either that, or ZM is not seeing it properly). At first I thought the issue was a lacking feature in the rather bland firmware of the camera (unsurprising, given it's Foscam). Curious, I spun up a Windows system *just* to test an ActiveX login, as Foscam (frustratingly) seems to still cater towards IE specifically for configuring cameras (all I have here are Linux systems). Under ActiveX, I found the FPS setting, but here's what's weird. Regardless of what I set the camera's FPS to, it doesn't actually change it from ZM's perspective. It does however change the framerate in the IE web browser I'm using to configure the camera. If I change it anywhere from 0.5 FPS to 20 FPS, ZM still sees it as a steady 8-10 FPS, while IE itself shows the framerate speeding up/slowing down, as if it's listening to the FPS settings change.

It's worth noting that streaming this camera in VLC directly reflects ZM, as in, neither ZM nor VLC change the rated FPS of the Foscam, no matter what I set it to on the Foscam. Even with it set to 1/2 FPS, it *clearly* is streaming frames significantly faster than 1/2 FPS with both ZM and VLC. Yet again, in the IE web interface, I see it change accordingly.

I'm also getting some errors now and then in ZM, specifically with this camera. I like to let the Montage run when both kids are down for a nap (each has a Foscam, one 8910, one 9821). I noticed that the 8910 would stop responding. I would simply see the last frame permanently plastered there in the Montage. The time stamp and everything would just stop. If I refresh, it's back. (it also appears that according to the events page, the camera doesn't *drop* as it keeps populating events feeds every 10 minutes [mocord], but it's just the montage view where it drops and doesn't respond again unless I refresh the page). That being said, all other cameras were fine -- why did this one freeze? The logs populate this whenever this "Foscam 8910 montage lockup" takes place:

zmwatch 22728 INF Restarting capture daemon for Claire_Camera, time since last capture 12 seconds (1459112977-1459112965)

(I also set my ZM_HTTP timeout from 2500 [the default], to 5000 for testing, but it made no change in terms of montage view lockups for this camera)

This makes me wonder if the camera is trying to pump out too many frames over wireless than what it can actually provide.

With me seemingly at a loss for not being able to control the FPS, I'm wondering if setting the maximum FPS in the settings of the camera is acceptable. I read the help text and I've been advised in the IRC channel that max FPS should only be set *if* it's above the camera's FPS setting. I did end up setting this setting, and so far it's good (but it's only been a half hour). With all of this said, I'm curious what you folks have to say about it. Is my assumption about the camera possibly accurate? Is maximum FPS something that might serve a non-consequential use here given the goofiness of this camera? Is the log entry above of any other suggestive fixes I haven't considered/thought of?

Thanks ahead of time for any and all suggestions. Loving this project!

Re: Is Max Framerate my only choice?

Posted: Sun Mar 27, 2016 11:50 pm
by bbunge
I believe you need to set the rate in the remote host path and use remote type ... or&rate=11

Here are some Foscam settings I have saved from an old project..

Video Stream Url and Parameter
http://<IP-CAM>/ videostream.cgi? user=A& pwd=B& resolution=C &rate=D
User Password 8 => 320x240 0 => maxframe
32 => 640x480
1 => 20 fps
3 => 15 fps
6 => 10 fps
11 => 5 fps
12 => 4 fps
15 => 3 fps
14 => 2 fps
15 => 1 fps
17 => 1 fps/2s
19 => 1 fps/3s
21 => 1 fps/4s
23 => 1 fps/5s

Re: Is Max Framerate my only choice?

Posted: Mon Mar 28, 2016 1:05 am
by jasauders
Thanks for your quick response! Just to recap, before I posted here I actually set my max framerate (via source tab in ZM) to 5 FPS. The camera itself was clearly pushing more than that, so it was ZM in this case keeping the FPS "at bay" and steady at 5 FPS.

In 3 hours, I did not have that error pop up again in the logs.

A half hour ago I saw your post bbunge, but sadly within a half hour's time the exact same error popped up in the logs. I had added rate=11 to the path. Sure enough, it worked in the sense that ZM detected a steady 5 FPS flow, but as mentioned the error still came up.

Just for a little extra, I restarted the ZM service and will watch to see if it surfaces again. If it does though... I can't help but to think that earlier, ZM ran for 3 hours without a single error (when the camera was set to max FPS, yet max framerate in ZM was set to 5). Previously I was averaging 2 or 3 of these errors per hour. It makes me wonder if that's the route to go.

My only hesitation is the fact I've been told + read that using max framerate in ZM can lead to issues if you're using it to limit the camera's framerate. Is that something I should even concern myself with given this situation?

Thanks again!

Re: Is Max Framerate my only choice?

Posted: Mon Mar 28, 2016 2:38 am
by bbunge
Am using &rate=11 on four cameras, remote mode, with No errors. That is a Foscam command not Zoneminder.

Re: Is Max Framerate my only choice?

Posted: Mon Mar 28, 2016 2:41 am
by jasauders
Are one of those four camers an 8910 by chance? Just an FYI one of my other cams is a Foscam wireless camera as well, but a different model (9821). This camera has never had any issues, as it's only been this 8910.

My 8910 is set to remote, which pulls mjpg. My 9821 is an H264 camera, so it's working with ffmpeg.

Also, potentially dumb question, but should a user reboot the ZM service after making changes such as the source path, etc?

The first time, I did not reboot the service. The error came up about a half hour later. I made no changes but rebooted the service afterwards, and so far it's been good for about an hour and a half. Fingers crossed...

PS bbunge - do you find yourself using montage for long periods of time? Only reason I ask is if it wasn't for the camera locking up in montage, I would *never* know there was any sort of issue as everything else is flawless. I only caught on to this after I filtered my logs for and saw the "Restarting capture daemon for abc-xyz" entries.

EDIT - Just got hit with "Restarting capture daemon..." 5 times in a row. This was with &rate=11 in the source path and a blank max framerate in the ZM camera settings. Unfortunately that doesn't seem to be the ticket here. :(

EDIT V2 - Before I checked in for the night, I changed the source path back to excluding &rate=11 and set max framerate to 5 FPS. This morning, I had no errors. I didn't review footage to make sure things were smooth but I took the lack of error logs as a good thing. I noticed in the help text that ZM provides that older IP cameras might prefer having this set. I wonder if the FI8910W is considered an older IP camera as per ZM's view?

Re: Is Max Framerate my only choice?

Posted: Mon Mar 28, 2016 11:51 pm
by bbunge
The Max FPS and Alarm FPS should be (blank) unless you have a Local camera. Yes, I have several 8918's which are the same as the 8910.

Re: Is Max Framerate my only choice?

Posted: Sun Oct 21, 2018 6:24 am
by johnaaronrose
I've tried setting the Analysis FPS to 1.00 and 1 but with blank Analysis FPS & Alarm FPS, it shows the Source (i.e. ip address) in ZM Console as red. No events occur . This is with ZM 1.30 & Ubuntu Bionic.

Re: Is Max Framerate my only choice?

Posted: Fri Oct 26, 2018 4:46 pm
by johnaaronrose
Further to FPS problem: 'sudo service zoneminder status' gives:
Oct 26 17:42:30 Laptop zmc_m1[15138]: ERR [Can't run query: Unknown column 'AnalysisFPS' in 'field list']
I've tried 'sudo service zoneminder restart' but doesn't help.

Re: Is Max Framerate my only choice?

Posted: Fri Oct 26, 2018 4:48 pm
by johnaaronrose
Just realised that this should be under version 1.30.