Localhost not found in Servers Table. Fedora 23 zmrepo

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
linforpros
Posts: 39
Joined: Fri Jan 29, 2016 6:12 pm

Localhost not found in Servers Table. Fedora 23 zmrepo

Post by linforpros » Tue Feb 16, 2016 7:19 pm

Hello,
Zoneminder's logs show the following info. It is difficult to figure out where to clear it.

Code: Select all

2016-02-16 12:56:40.386501 undef 1761 INF No Server ID or Name specified in config. Not using Multi-Server Mode.	zm_config.cpp	139

My attempt to resolve the issue was to run zmupdate.pl -f but it did not help. The command ran without errors.
Adding "localhost" to /etc/zm/zm.conf
# Host of this machine
ZM_SERVER_HOST=localhost
does not help but produces errors:
ERR ZM_SERVER_HOST set to localhost in config, but not found in Servers table

Adding hostname and server name via the web errors out with:

Code: Select all

[code]SQL-ERR 'SQLSTATE[42S22]: Column not found: 1054 Unknown column 'Hostname' in 'field list'', statement was 'INSERT INTO Servers set Name = 'Serv1.29', Hostname = 'localhost''
[/code]

Code: Select all

DATE/TIME
COMPONENT	SERVER	PID	LEVEL	MESSAGE	FILE	LINE
2016-02-16 13:15:57.764137	web_php		1711	ERR	ZM_SERVER_HOST set to localhost in config, but not found in Servers table.	/usr/share/zoneminder/www/includes/config.php	183

Zoneminder was installed from zmrepo on fedora 23 in ver 1.29.0-2, and then updated via dnf upgrade to ver 1.29.0-3.

Also important is that streaming from cameras stops working if I leave "localhost" in zm.conf file.



Is there a way to fix this?
best regards
LinforPros

PacoLM
Posts: 967
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Localhost not found in Servers Table. Fedora 23 zmrepo

Post by PacoLM » Wed Feb 17, 2016 5:15 pm

Stop ZM and try to run "zmupdate.pl -f"

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.31.1)

User avatar
knight-of-ni
Posts: 2226
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Localhost not found in Servers Table. Fedora 23 zmrepo

Post by knight-of-ni » Wed Feb 17, 2016 6:29 pm

ERR ZM_SERVER_HOST set to localhost in config, but not found in Servers table
This error means exactly what it says.
It is saying that you manually set ZM_SERVER_HOST in zm.conf to the value "localhost", but you have not put a corresponding value for the localhost entry under Options -> Server tab

I'm not sure why you decided to assign a value to ZM_SERVER_HOST, however.

The README instructions definitely did not say to do this:
https://github.com/ZoneMinder/ZoneMinde ... DME.Fedora

If you are trying to configure Multi-server, which is what this variable is for, then please follow the instructions here:
https://zoneminder.readthedocs.org/en/s ... erver.html
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

User avatar
knight-of-ni
Posts: 2226
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Localhost not found in Servers Table. Fedora 23 zmrepo

Post by knight-of-ni » Wed Feb 17, 2016 6:38 pm

INF No Server ID or Name specified in config. Not using Multi-Server Mode. zm_config.cpp 139
Probably answers my question in the previous post regarding why you set ZM_SERVER_HOST.
This is not an error message, but an indication things are working fine (unless of course you really are trying to configure Multi-Server). Notice the "INF" means, "INFO" and not Warning or Error.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

User avatar
knight-of-ni
Posts: 2226
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Localhost not found in Servers Table. Fedora 23 zmrepo

Post by knight-of-ni » Wed Feb 17, 2016 6:45 pm

Code: Select all

SQL-ERR 'SQLSTATE[42S22]: Column not found: 1054 Unknown column 'Hostname' in 'field list'', statement was 'INSERT INTO Servers set Name = 'Serv1.29', Hostname = 'localhost''
I can't explain how this happened, but I can tell you how to fix this one.

Manually run this sql script:

Code: Select all

mywl -uroot -p zm < /usr/share/zoneminder/db/zm_update-1.28.109.sql
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests