It does not show streaming video

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
zusul
Posts: 7
Joined: Thu Feb 04, 2016 10:09 am
Location: Kiev. Ukraine
Contact:

It does not show streaming video

Post by zusul » Thu Feb 11, 2016 6:26 pm

Hi
Ubuntu 14.04х64
It does not show streaming video, photo saved

Code: Select all

socket_sendto( /var/run/zm/zms-830140s.sock ) failed: No such file or directory

getStreamCmdResponse stream error: socket_sendto( /var/run/zm/zms-147782s.sock ) failed: No such file or directory - checkStreamForErrors()

bbunge
Posts: 2403
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: It does not show streaming video

Post by bbunge » Thu Feb 11, 2016 9:01 pm

Did you enable CGI?
Did you edit the PATH_ZMS

zusul
Posts: 7
Joined: Thu Feb 04, 2016 10:09 am
Location: Kiev. Ukraine
Contact:

Re: It does not show streaming video

Post by zusul » Thu Feb 11, 2016 9:26 pm

bbunge wrote:Did you enable CGI?
Did you edit the PATH_ZMS
Module cgi already enabled
PATH_ZMS /zm/cgi-bin/nph-zms

asanti
Posts: 6
Joined: Sat Mar 03, 2012 5:47 pm

Re: It does not show streaming video

Post by asanti » Mon Feb 15, 2016 3:19 am

Try This info: worked for me

viewtopic.php?f=34&t=24265

edit /etc/apache2/conf-available/zoneminder.conf
#ScriptAlias /zm/cgi-bin "/usr/lib/zoneminder/cgi-bin"
ScriptAlias /zoneminder/cgi-bin "/usr/lib/zoneminder/cgi-bin"

service apache2 restart
service zoneminder restart

danz
Posts: 1
Joined: Thu Jan 24, 2019 2:44 pm

Re: It does not show streaming video [SOLVED]

Post by danz » Thu Jan 24, 2019 3:03 pm

I had difficulty with this too. Not sure if my solution exactly matches your problem, but this worked for me. I am using version 1.32.3 on Ubuntu 1804.1 LTS. I found that, that within the ZoneMinder console, if I set Options>System>Auth_Relay to "None," or unchecked OPT_USE_AUTH, I could see streaming video. The problem turned out to be a mismatch of time zones, causing the authentication to throw an error. When installing ZoneMinder, I configured the time zone per the instructions. This however did not match the computer time. I simply executed the following line from terminal to set the computer time to the same time zone as configured in ZoneMinder, and the problem immediately resolved. Additionally this made the time stamps the correct local time.

cp /usr/share/zoneinfo/America/Chicago /etc/localtime
[Substitute your timezone for Chicago. Note the space before /etc.]

Restart ZoneMinder.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests