Samsung Smartcam SNH-P6410BN

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
baradanikto
Posts: 13
Joined: Mon Feb 08, 2016 11:11 pm

Samsung Smartcam SNH-P6410BN

Post by baradanikto » Mon Feb 08, 2016 11:20 pm

I know that this camera is not listed as a generally supported camera, but, I wanted to inquire if anyone has successfully configured it with ZoneMinder. I've had the camera for a while and it works well using the Samsung provided phone app. I also had it writing to a Synology NAS using their Surveillance Station software. Recently, Samsung upgraded their firmware and removed the ability to "see" this camera from the NAS. So, I looked for an alternative solution and found ZoneMinder. Since I run multiple OS, I thought I would give it a try on Ubuntu. I've tried multiple camera configurations, all of which seem to work. But, when I go to the web console to view the camera feed, I see nothing.

Is this a lost cause? Should I look elsewhere for a solution?

User avatar
asker
Posts: 1077
Joined: Sun Mar 01, 2015 12:12 pm

Re: Samsung Smartcam SNH-P6410BN

Post by asker » Tue Feb 09, 2016 12:05 am

Do these instructions still work?
https://www.sighthound.com/forums/topic11831

You can try it with VLC player first
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

bbunge
Posts: 2421
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Samsung Smartcam SNH-P6410BN

Post by bbunge » Tue Feb 09, 2016 2:07 am

You did not say what Ubuntu install instructions you used. There is one final step that, if missed, will stop ZM from showing you the camera video...

Under Options/Paths set PATH_ZMS to /zm/cgi-bin/nph-zms

Of course, it could be the camera configuration...

baradanikto
Posts: 13
Joined: Mon Feb 08, 2016 11:11 pm

Re: Samsung Smartcam SNH-P6410BN

Post by baradanikto » Tue Feb 09, 2016 6:51 pm

Asker: Those settings did not work for me.

BBunge: I already had a path set but I updated it to use what you suggested. No luck. Still no stream.

Additionally, I took a look in the log and I consistently get "Unable to connect RTSP socket"

baradanikto
Posts: 13
Joined: Mon Feb 08, 2016 11:11 pm

Re: Samsung Smartcam SNH-P6410BN

Post by baradanikto » Wed Mar 02, 2016 11:00 pm

I finally had time to get back to this. I'm still struggling with finding the right combination of settings. In fact, I've found at least one other user with the same problem as evidenced by viewtopic.php?t=22328. Basically, I'm seeing the same thing. That is, nothing appears when I click on the camera entry.

Here's hoping someone can point me in the right direction, or, tell me what to look for in the log file. I'm still not convinced that this camera is compatible.

bbunge
Posts: 2421
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Samsung Smartcam SNH-P6410BN

Post by bbunge » Thu Mar 03, 2016 3:43 am

Check your PATH_ZMS entry to see of there is a space at the end of the string.
Bb

PacoLM
Posts: 967
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Samsung Smartcam SNH-P6410BN

Post by PacoLM » Thu Mar 03, 2016 7:23 am

Hi baradanikto,

Are you using Ffmpeg or Libvlc as Source type for thus camera? If you selected Libvlc, try to switch to Ffmpeg and give it a try. Use Remote Method RTP/RTSP and be sure that the resolution selected on Zoneminder exactly matches the resolution set on the capture stream.

To check that ffmpeg is installed and get its path, run the command "which ffmpeg" is will return something like "/usr/bin/ffmpeg". You could also try avconv (which avconv -> /usr/bin/avconv). Check that Options::Images::OPT_FFMPEG is enabled, also Options::Images::OPT_FFMPEG::PATH_FFMPEG must be set to the location of your ffmpeg binary ( for instance, /usr/bin/ffmpeg). Set Options::Images::FFMPEG_OUTPUT_OPTIONS to "-r 23.976 -qscale 1" (no quotes!). Restart zoneminder after the changes. Check the logs.

Hope it helps, post results!

PacoLM

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.31.1)

baradanikto
Posts: 13
Joined: Mon Feb 08, 2016 11:11 pm

Re: Samsung Smartcam SNH-P6410BN

Post by baradanikto » Thu Mar 03, 2016 3:23 pm

Bd...The path does not contain a space.

PacoLM....I took your advice and tried ffmpeg. While I could not find "ffmpeg", I was able to find "avconv". I set the flags you recommended accordingly. I now get a completely blue screen for the monitor and the string "Unable to open input 192.168.0.xx:xxx/profile5/media.smp.

While I understand it can be difficult setting up these cameras, I'm about ready to start looking elsewhere for a solution.

PacoLM
Posts: 967
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Samsung Smartcam SNH-P6410BN

Post by PacoLM » Thu Mar 03, 2016 4:01 pm

baradanikto wrote: PacoLM....I took your advice and tried ffmpeg. While I could not find "ffmpeg", I was able to find "avconv". I set the flags you recommended accordingly. I now get a completely blue screen for the monitor and the string "Unable to open input 192.168.0.xx:xxx/profile5/media.smp.

While I understand it can be difficult setting up these cameras, I'm about ready to start looking elsewhere for a solution.
Let me ask you a stupid question...Are you including your user and password in the path to the camera?

Should be something like rtsp://USER:PWD@192.168.0.xx:xxx/profile5/media.smp

Post results,

Paco

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.31.1)

baradanikto
Posts: 13
Joined: Mon Feb 08, 2016 11:11 pm

Re: Samsung Smartcam SNH-P6410BN

Post by baradanikto » Thu Mar 03, 2016 8:30 pm

Paco...thanks for the heads up. I was including the user and password. However, I had left off "rtsp://". Once I added that, I was able to connect to the camera! Thanks for taking the time to help. It's much appreciated.

PacoLM
Posts: 967
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Samsung Smartcam SNH-P6410BN

Post by PacoLM » Thu Mar 03, 2016 9:25 pm

baradanikto wrote:Paco...thanks for the heads up. I was including the user and password. However, I had left off "rtsp://". Once I added that, I was able to connect to the camera! Thanks for taking the time to help. It's much appreciated.
Good to hear that you solved your problem!

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.31.1)

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests