Linux Noob Setting up from a blank hard drive. Installation problems.

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
Pele
Posts: 12
Joined: Tue Apr 17, 2018 9:40 am

Linux Noob Setting up from a blank hard drive. Installation problems.

Post by Pele » Tue Apr 17, 2018 9:42 am

So I'm following the instructions at this website to the "T"

http://zoneminder.readthedocs.io/en/sta ... untu-16-04

Fresh install of Ubuntu Server 16.04.4 (Downloaded early April 2018)

Fresh download from the apt-get repository of ZoneMinder as of 15 April 2018, so I'm assuming it's the last stable release 1.30.4 (EDIT: I mistakenly put 1.29 because the easy instructions linked above are for 1.29.)

I always have to start my ethernet interface and add the default gateway route on boot. I guess this isn't a big deal... If this was an old school DOS machine, I'd just stick the commands in autoexec.bat. But I have no clue what the Linux equivalent is.

I get to the step, "a2enmod cgi"

I get an error message, ERROR: Conf cgi does not exist!

The last step, "systemctl start zoneminder"

I also get an error message, Job for zoneminder.service failed because the control process exited with an error code. See "systemctl status zoneminder.service" and "journalctl -xe" for details.

The first command, systemctl status shows me that ZoneMinder can't connect to the database at /usr/share/perl5/ZoneMinder/Config.pm line 119. There's also some stuff about failing to compile at line 33 and 48.

(I'm not compiling from any make file... I downloaded from the repository with the apt-get command. Why is ANYTHING compiling?)

The second command, "journalctl -xe" gives me so much crap I can't even begin to process what it all means.

I can hit my ZoneMinder server from another computer's browser, but it's just a default Apache webpage and not the Zoneminder front end.

HALP PLZ!

I'm in over my head.
Last edited by Pele on Wed Apr 18, 2018 9:20 am, edited 1 time in total.

bbunge
Posts: 2154
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by bbunge » Wed Apr 18, 2018 2:06 am

See the zoneminder Wiki for easy instructions
No, zm 1.30.4 is the stable release.

Pele
Posts: 12
Joined: Tue Apr 17, 2018 9:40 am

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by Pele » Wed Apr 18, 2018 9:14 am

The wiki has the same command to set up Apache CGI with no instructions on how to proceed if it fails.

Can a mod please move this to the appropriate section. I will edit my top post to reflect the version.

Pele
Posts: 12
Joined: Tue Apr 17, 2018 9:40 am

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by Pele » Wed Apr 18, 2018 11:17 am

So I'm trying to enable cgi and apparently I need to do some messing around in/etc/httpd/httpd.conf
There is no directiory called /etc/httpd/
I also need to mess with /etc/apache/sites-available
There is no directory called /etc/apache/

How can this be if apache is installed and working properly?! If I use my laptop to go to my ZoneMinder server's IP, I get a basic "apache is working" website.

bbunge
Posts: 2154
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by bbunge » Wed Apr 18, 2018 12:03 pm

Please do a fresh install of Ubuntu server with LAMP installed. Then follow the WIKI Zoneminder install instructions. It will work! Do not waste your time trying to fix something you think is broken!

Pele
Posts: 12
Joined: Tue Apr 17, 2018 9:40 am

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by Pele » Wed Apr 18, 2018 1:41 pm

I don't like LAMP... CCFL bulbs last longer and are more energy efficient. LEDs are even moreso and tolerate on-off cycles better.

I kid, I kid.

But this IS a fresh install, LAMP server was selected on the install. Along with mail server and a bunch of other options.

bbunge
Posts: 2154
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by bbunge » Wed Apr 18, 2018 11:29 pm

I still recommend you reinstall Ubuntu. If it is a server install just install LAMP and Openssl server. Use Putty from your Windows PC to run the commands.
Get Zoneminder to run then add mail and etc.
An easy way is to use a shell script. See https://wiki.zoneminder.com/Shell_scrip ... 28MySQL.29

In a terminal run:
nano install
This sets up to make an install file. Copy the contents of the Sript for Ubuntu with LAMP (MySQL) and paste into the Putty terminal window opened with nano. Paste by right clicking in the window.
Save and close nano:
Ctrl + o
Ctrl +x

Make the file executable:
chmod 755 install

Run the file and follow the prompts:
./install (press Enter)

How easy is that?

Pele
Posts: 12
Joined: Tue Apr 17, 2018 9:40 am

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by Pele » Thu Apr 19, 2018 5:27 pm

I had to reinstall three times last night but finally got it.

When I got to the point of installing ZoneMinder with the command apt install zoneminder I kept getting a "Password does not satisfy the requirements" error message.

I changed my root password and that didn't help. I reran the mysql-secure-installation to change the sql root password. No dice there...

I finally reinstalled and didn't do ANY of the optional steps. No secure install, no mysqltuner. My password for the sql root is some 30 characters long written on a post-it.

I also redid the filesystem and put /(root), /var, /home, and /usr in separate partitions. Never tried that one before. Not sure if that helped. Before I was doing everything in one partition, not counting swap.

bbunge
Posts: 2154
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by bbunge » Thu Apr 19, 2018 11:43 pm

Pele wrote:
Thu Apr 19, 2018 5:27 pm
I had to reinstall three times last night but finally got it.

When I got to the point of installing ZoneMinder with the command apt install zoneminder I kept getting a "Password does not satisfy the requirements" error message.

I changed my root password and that didn't help. I reran the mysql-secure-installation to change the sql root password. No dice there...

I finally reinstalled and didn't do ANY of the optional steps. No secure install, no mysqltuner. My password for the sql root is some 30 characters long written on a post-it.

I also redid the filesystem and put /(root), /var, /home, and /usr in separate partitions. Never tried that one before. Not sure if that helped. Before I was doing everything in one partition, not counting swap.
Creating separate partitions like you did is old school Linux. While there is nothing wrong with what you did it may limit the storage you can use for events. I've put everything in a single / partition for a long time now with no ill effects.

Pele
Posts: 12
Joined: Tue Apr 17, 2018 9:40 am

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by Pele » Tue Apr 24, 2018 12:03 am

bbunge wrote:
Thu Apr 19, 2018 11:43 pm
Pele wrote:
Thu Apr 19, 2018 5:27 pm
I had to reinstall three times last night but finally got it.

When I got to the point of installing ZoneMinder with the command apt install zoneminder I kept getting a "Password does not satisfy the requirements" error message.

I changed my root password and that didn't help. I reran the mysql-secure-installation to change the sql root password. No dice there...

I finally reinstalled and didn't do ANY of the optional steps. No secure install, no mysqltuner. My password for the sql root is some 30 characters long written on a post-it.

I also redid the filesystem and put /(root), /var, /home, and /usr in separate partitions. Never tried that one before. Not sure if that helped. Before I was doing everything in one partition, not counting swap.
Creating separate partitions like you did is old school Linux. While there is nothing wrong with what you did it may limit the storage you can use for events. I've put everything in a single / partition for a long time now with no ill effects.
I have a whole 1TB drive dedicated to video recording, separate from the 240 GB SSD that the system runs on.

Just as soon as I figure out how to get this thing running.

I followed the directions here:
https://wiki.zoneminder.com/Using_a_ded ... Hard_Drive

But when I typed "mount -a" it said:
"mount: mount point /var/cache/zoneminder/images does not exist"
"mount: mount point /var/cache/zoneminder/events does not exist"


Pele
Posts: 12
Joined: Tue Apr 17, 2018 9:40 am

Re: Linux Noob Setting up from a blank hard drive. Installation problems.

Post by Pele » Wed Apr 25, 2018 10:37 am

I just recreated the directories.
If I create a new text file with nano in "/var/cache/zoneminder/images" it shows up in "/video/zoneminder/images."
If I create a new text file with nano in "/var/cache/zoneminder/events" it shows up in "/video/zoneminder/events."

Deleting files in one deletes it in its respective directory.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests