(SOLVED) foscam FI9851P v2 shows blue screen

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
ssl
Posts: 6
Joined: Thu Feb 18, 2016 11:47 am

(SOLVED) foscam FI9851P v2 shows blue screen

Post by ssl » Thu Aug 25, 2016 2:20 pm

Hi, I have 2 cameras foscam FI9851P. one works me well and that is only V2 above shows me a blue screen,.
This is the configuration that works well:

GENERAL
Name: Pirulo
Server: None
Source Type: Ffmpeg
Function: Modect
Enabled: v

SOURCE
Source Path: rtsp://user:password@192.168.5.54:8054/videoMain
Remote Method: RTP/Unicast
Options (?): -
Target colorspace: 24 bit colour
Capture Width (pixels) :640
Capture Height (pixels) :480

I place the same settings for FI9851P V2 and does not work.
The firmware of the camera is the last of the page foscam
Can somebody help me?
Last edited by ssl on Fri Sep 09, 2016 1:28 pm, edited 1 time in total.

Soljia
Posts: 8
Joined: Wed Aug 03, 2016 9:29 pm

Re: foscam FI9851P v2 shows blue screen

Post by Soljia » Tue Aug 30, 2016 12:19 pm

Did you change your port? According to the documentation the ports are HTTP: 88 HTTPS 443 AND ONVIF: 888. Try rtsp://user:password@192.168.5.54:88/videoMain Unless you changed the ports..then nevermind.

User avatar
knight-of-ni
Posts: 2100
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: foscam FI9851P v2 shows blue screen

Post by knight-of-ni » Wed Aug 31, 2016 1:54 pm

Use VLC to verify the url you are using is correct.

Also verify the resolution is correct. You have to match what the camera is sending ZoneMinder, down to the exact pixel.
It seems odd you've got the resolution set to 640x480, when the camera streams 720p natively. You can use vlc to tell you what the exact resolution should be.

PS: Set your colorspace to 32bit for a performance boost
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

ssl
Posts: 6
Joined: Thu Feb 18, 2016 11:47 am

Re: foscam FI9851P v2 shows blue screen

Post by ssl » Wed Sep 07, 2016 12:15 pm

Hi knnniggett , Soljia, if the port is also correct and resolution, both cameras have the same configuration.

I also tried with VLC and the old camera works ok but the new version of the camera does not work.

I'm sending mails to the Chinese to send me a new firmware because of foscam page does not work well.

I can not think of anything else...

User avatar
knight-of-ni
Posts: 2100
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: foscam FI9851P v2 shows blue screen

Post by knight-of-ni » Wed Sep 07, 2016 11:25 pm

If you cannot get vlc to view the camera then the camera will not work in ZoneMinder.
You either don't have the url correct, there is an incorrect setting in the camera, or the camera is faulty.

Note that you can also use the free Windows based Onvif Device Manager to autodetect the camera's url.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

ssl
Posts: 6
Joined: Thu Feb 18, 2016 11:47 am

Re: foscam FI9851P v2 shows blue screen

Post by ssl » Fri Sep 09, 2016 11:39 am

Hello knnniggett, thanks for answering, the parameters are right, I think the version FI9851P V2 of the camera is what does not work, because the version V1 if it works and is the one I'm using, but I can not operate the camera with V2 version.
I set the same parameters in both houses and not make it work in Zoneminder achievement, I'll try in version 1.30 ZoneMinder if there was any corecccion, maybe work.

ssl
Posts: 6
Joined: Thu Feb 18, 2016 11:47 am

Re: foscam FI9851P v2 shows blue screen

Post by ssl » Fri Sep 09, 2016 1:26 pm

Hi I could finally solve, these are the parameters to work:

GENERAL
Name: Pirulo
Server: None
Source Type: remote
Function: Modect
Enabled: v

SOURCE
Remote Protocol: HTTP
Remote Method : Simple
Remote Host Name:192.168.5.132
Remote Host Port:8132
Remote Host Path:/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=user&pwd=password
Target colorspace: 24 bit colour
Capture Width (pixels)
Capture Width (pixels) :640
Capture Height (pixels) :480

mic07
Posts: 7
Joined: Tue Feb 06, 2018 9:10 pm

Re: (SOLVED) foscam FI9851P v2 shows blue screen

Post by mic07 » Wed Feb 07, 2018 12:45 am

Hi all!

Since I had a very strange problem with FI9900P (FW 2.74.1.54 and 2.74.1.49), which might be relevant for this thread, I decided to post it here.
For me VLC and Zoneminder have not been working with FI9900P RTSP (no video) or ffmpeg (blue screen) settings. After hours of trial and error, I found that the Foscam Admin Password was the problem. It simple was too long (14 characters) and the Foscam WebInteface (password change page and login page) is cutting it after 12 characters (however it allows to input much longer passwords).

BR

rockedge
Posts: 857
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: (SOLVED) foscam FI9851P v2 shows blue screen

Post by rockedge » Wed Feb 07, 2018 5:55 pm

wow !! great detective work mic07.

GringoMG
Posts: 2
Joined: Mon Mar 05, 2018 11:08 am

Re: (SOLVED) foscam FI9851P v2 shows blue screen

Post by GringoMG » Thu Mar 08, 2018 4:44 pm

@mic07
Can you please share how you got the Foscam FI9900P working?
I bought one too yesterday.
No way to get the thing working in Zm 1.30.4 on Linux Mint 17.3 Rosa.
thanks in advance.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests