Export ZIP

Forum for questions and support relating to the 1.29.x releases only.
rockedge
Posts: 903
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Export ZIP

Post by rockedge » Fri Mar 25, 2016 2:45 pm

further examination shows that the path in /usr/share/zoneminder/www/skins/classic/views/video.php line 69 is for example
events/2/16/03/26/13/33/11 but actually is events/2/16/03/25/10/33/11 causing the error. The video is generated and is here:
/usr/share/zoneminder/www/events/2/16/03/25/10/33/11/Event-3-r1-s1.avi but one recieves a Video generated Success and shows NO video found.

Can this be a time-date issue during the DEEP Storage processes? Or am I way off here.
I upgraded and lost the ability to generate video or export events.

rockedge
Posts: 903
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Export ZIP

Post by rockedge » Fri Mar 25, 2016 3:53 pm

notice the date and time difference. The time stamp on the camera stream is correct.

Image

So when I attempt to generate a video or export an event the process fails.
Also the stills view of an event fails.

rockedge
Posts: 903
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Export ZIP

Post by rockedge » Fri Mar 25, 2016 6:20 pm

I stopped all the servers checked the php.ini Date section which is OK and restarted all the servers which seems to have fixed the issue.
I can export and create videos again.

RyGy7
Posts: 36
Joined: Mon Feb 02, 2015 3:15 pm

Re: Export ZIP

Post by RyGy7 » Tue Mar 29, 2016 1:22 pm

Nope i'm still at a loss, my time stamps match correctly.

RyGy7
Posts: 36
Joined: Mon Feb 02, 2015 3:15 pm

Re: Export ZIP

Post by RyGy7 » Sun Apr 17, 2016 1:23 pm

just wanted to update I still have no solution for this. (i was away for awhile) But still states that video generation succeeded but no download.
no-vid.PNG
no-vid.PNG (5.35 KiB) Viewed 1942 times

rockedge
Posts: 903
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Export ZIP

Post by rockedge » Tue Apr 26, 2016 1:18 am

On Puppy Linux I open a terminal or run a script at startup to do the following :

Code: Select all

#chmod 666 /dev/random
and then the video generation and export function worked flawlessly.
I stumbled across this when configuring ZM for a Hiawatha server.

haake
Posts: 4
Joined: Fri Feb 13, 2015 9:08 pm

Re: Export ZIP

Post by haake » Wed Jan 17, 2018 5:43 pm

This is a fairly old thread but I thought I would point out my workaround since I've had to figure it out again after I patched my installation more than year ago.

One reason you may get empty zmExport.tar files or no zmExport.zip file at all is if you have an empty zmFileList.txt. That in turn can be caused by a bug in the export_functions.php regular expression that matches the video file formats. The default (FFMPEG_FORMATS option) allows you to generate .mov and .swf format files but the video export regex doesn't look for those. The workaround is to change

Code: Select all

                if ( preg_match( "/\.(?:mpg|mpeg|avi|asf|3gp)$/", $file ) )
to

Code: Select all

                if ( preg_match( "/\.(?:mpg|mov|swf|mpeg|avi|asf|3gp)$/", $file ) )
or something that matches your FFMPEG_FORMATS options if you change them.

I've just submitted on issue for a fix on github

User avatar
iconnor
Posts: 569
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Export ZIP

Post by iconnor » Thu Jan 18, 2018 1:34 pm

I have submitted a PR with your proposed fix.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest