Debian 8 (OMV) - Can't find sockets

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
Skorm92
Posts: 4
Joined: Sat Aug 12, 2017 2:53 pm

Debian 8 (OMV) - Can't find sockets

Post by Skorm92 » Sat Aug 12, 2017 3:00 pm

Hi there!

I've been crawling numerous threads where nearly the same answer is being applied where it is not a sollution for me;
Whenever I open the "Cycle/Montage" view the chrome console tells me that

Code: Select all

/zm/cgi-bin/nph-zms
is forbidden. (403)
Server info;
OS: Debian 8
Interface: Open Media Vault
Zoneminder: v.1.29.0


When I open the NGINX log I see the following:

Code: Select all

2017/08/12 16:43:37 [error] 2399#0: *83 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-759779s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:01 [error] 2399#0: *81 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-303671s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:03 [error] 2399#0: *83 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-759779s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:14 [error] 2399#0: *83 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-303671s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:16 [error] 2399#0: *81 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-759779s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:27 [error] 2399#0: *81 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-303671s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:29 [error] 2399#0: *83 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-759779s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:40 [error] 2399#0: *83 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-303671s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:42 [error] 2399#0: *81 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-759779s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:53 [error] 2399#0: *81 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-303671s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:44:55 [error] 2399#0: *166 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-759779s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
2017/08/12 16:45:06 [error] 2399#0: *166 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-303671s.sock ) failed: No such file or directory]" while reading response header from upstream, client: 192.168.1.73, server: , request: "POST /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock:", host: "192.168.1.250:81", referrer: "http://192.168.1.250:81/index.php?view=montage&group=0"
Everwhere is stated that my PATH_ZMS and/or PATH_SOCKS are incorrect, but the given sollution is already applied for me.
I've been struggling at first for quite a while to get the nginx configuration working as I didn't know where to place this.

zz-omv-nginx.conf contents;

Code: Select all

server {
    listen 81;
    listen [::]:81;
    set $root_path "/mnt/data/webserver/secnet";
    root $root_path;
    index index.html;
    set $socket "unix:/var/run/fpm-d93d75cf-7eec-4480-8581-d349a88c225c.sock";
    location ~ \.php$ {
        include snippets/fastcgi-php.conf;
        fastcgi_pass $socket;
    }
    access_log /var/log/nginx/3e553d85-5354-4319-9deb-88fc1f3ae805-access.log;
    error_log  /var/log/nginx/3e553d85-5354-4319-9deb-88fc1f3ae805-error.log;
    large_client_header_buffers 4 8k;

    location /zm/cgi-bin {
        gzip off;
        alias /usr/lib/cgi-bin;

        include /etc/nginx/fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $request_filename;
        fastcgi_pass  unix:/var/run/fcgiwrap.socket;
    }

    location /zm {
        gzip off;
        alias                   /usr/share/zoneminder;
        index                   index.php;

        location ~ \.php$ {
            if (!-f $request_filename) { return 404; }
            expires             epoch;
            include             /etc/nginx/fastcgi_params;
            fastcgi_param       SCRIPT_FILENAME         $request_filename;
            fastcgi_index       index.php;
            fastcgi_pass        unix:/var/run/php5-fpm.sock;
        }

        location ~ \.(jpg|jpeg|gif|png|ico)$ {
            access_log          off;
            expires         33d;
        }

        location /zm/api/ {
            alias                   /usr/share/zoneminder/api;
            rewrite ^/zm/api(.+)$ /zm/api/index.php?p=$1 last;
        }
    }
}
Clearly I'm missing something here, but after 2 days of endless lines of codes an file/folder browsing I'm starting to stare into a void.
I already have 2 camera's configured which are working, as when I click on "zone" in the camera overview I see a snapshot of that moment.

I'm extremely thankful to the person(s) that are willing to help me solve this issue, or that happen to resolve it for/with me!
(If any information is left out, please ask me and I'll provide whatever I can!)

bbunge
Posts: 1478
Joined: Mon Mar 26, 2012 11:40 am

Re: Debian 8 (OMV) - Can't find sockets

Post by bbunge » Sat Aug 12, 2017 7:19 pm

I did an install on open media vault, Changed the default browser to use port 8080 and installed Apache2. Search the forum and you can find my procedure.


Skorm92
Posts: 4
Joined: Sat Aug 12, 2017 2:53 pm

Re: Debian 8 (OMV) - Can't find sockets

Post by Skorm92 » Sat Aug 12, 2017 7:56 pm

My OMV isn't running on apache, it's running on NGINX. hence the NGINX install of Zoneminder.

That means for this fix I'd have to reinstall nearly everything just for the sockets to work.
I'd rather have this one thing fixed that remains from a fully functioning Zoneminder.

bbunge
Posts: 1478
Joined: Mon Mar 26, 2012 11:40 am

Re: Debian 8 (OMV) - Can't find sockets

Post by bbunge » Sat Aug 12, 2017 11:46 pm

Your call. What i did worked! I did not change the default web program but just added Apache2.

Skorm92
Posts: 4
Joined: Sat Aug 12, 2017 2:53 pm

Re: Debian 8 (OMV) - Can't find sockets

Post by Skorm92 » Sun Aug 13, 2017 12:14 pm

I installed Apache2, been working an hour or so to get it properly working.
But I end up having the very same issue if not worse!

This time it can't even find the nph-zms and another buckload of socket errors...
Image

Skorm92
Posts: 4
Joined: Sat Aug 12, 2017 2:53 pm

Re: Debian 8 (OMV) - Can't find sockets

Post by Skorm92 » Sun Aug 13, 2017 1:35 pm

Nevermind, I seem to have fixed it by moving the /usr/lib/zoneminder/cgi-bin files to /usr/lib/cgi-bin!
It's running on apache now while I don't really know if that actually made the difference.

But thank you for your help anyhow!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests