Happy with ZM just a few details left

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
Crogge
Posts: 2
Joined: Sun Jun 18, 2017 5:36 pm

Happy with ZM just a few details left

Post by Crogge » Sun Jun 18, 2017 5:52 pm

First of all I would like to say that I really like ZM 1.29 and had no issues to do the basic setup incl. external access. After some tweaking I managed to get motion detection properly working and it has now a very low amount of false positives. Moving the file location to a HDD Raid was also easily done.

I use a very old noname USB webcam (VGA quality only) as simple security camera, the automatic camera settings are not working on Linux (At least I couldn't get them to work). I created a day / night script which is setting them manually, it works perfectly fine but ZM seems to override those settings from time to time to the ones which are set in ZM.

OS: Ubuntu 16 Server LTS
Camera: ID 0c45:612c Microdia PC Camera (SN9C110) <- Using default (Limited) Ubuntu driver, couldn't find a better one

How can I disable the settings override by ZM and make sure those values will be only set by my script? I think it happens each time the log says "Hue control not supported" but I'm not even logged into the ACP at those times.

cam_day.sh
v4l2-ctl -d /dev/video0 -c gain_automatic=0
v4l2-ctl -d /dev/video0 -c brightness=85
v4l2-ctl -d /dev/video0 -c contrast=15
v4l2-ctl -d /dev/video0 -c saturation=22
v4l2-ctl -d /dev/video0 -c gamma=20
v4l2-ctl -d /dev/video0 -c sharpness=100
cam_night.sh
v4l2-ctl -d /dev/video0 -c gain_automatic=0
v4l2-ctl -d /dev/video0 -c brightness=250
v4l2-ctl -d /dev/video0 -c contrast=30
v4l2-ctl -d /dev/video0 -c saturation=18
v4l2-ctl -d /dev/video0 -c gamma=40
v4l2-ctl -d /dev/video0 -c sharpness=100
The other issue I got is that the API isn't working, it says that mod_rewrite isn't properly configured/enabled but it actually is. This isn't important though cause I don't need the API currently.

Picture of my recent logs:
Image

bbunge
Posts: 1555
Joined: Mon Mar 26, 2012 11:40 am

Re: Happy with ZM just a few details left

Post by bbunge » Sun Jun 18, 2017 8:57 pm


Crogge
Posts: 2
Joined: Sun Jun 18, 2017 5:36 pm

Re: Happy with ZM just a few details left

Post by Crogge » Sun Jun 18, 2017 10:25 pm

bbunge wrote:
Sun Jun 18, 2017 8:57 pm
See the WIKI instructions
https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way
I followed the Wiki instructions and as written above all base functions of ZM work fine and I'm happy with it.

There are no Wiki entries regarding the camera setting overwrite. I'm sorry though If I'm mistaken and there is actually a page, I would appreciate the link to it.

bbunge
Posts: 1555
Joined: Mon Mar 26, 2012 11:40 am

Re: Happy with ZM just a few details left

Post by bbunge » Mon Jun 19, 2017 2:10 am

For local cameras you need to be sure that you add the user for video per the instructions in the WIKI. For USB cameras i use PAL B and 32 bit color and set the frame rate down to 5. The fixes and edits in the instructions are to allow the API to work. You may want to upgrade to ZM 1.30.4.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest