Event Notification Server error

Discussion topics related to mobile applications and ZoneMinder Event Server (including machine learning)
Post Reply
nick1974
Posts: 1
Joined: Wed Jun 16, 2021 11:31 pm

Event Notification Server error

Post by nick1974 » Wed Jun 16, 2021 11:36 pm

Hi all,

Just installed the event notification server today (first time user of it).

All seems to have installed ok, and in zmninjapro, it's connected to the event server.

All is well until an event occurs, at which point the following errors gets thrown into the log:

Component is zmesdetect_m1, level is FAT..

Unrecoverable error:Expecting value: line 1 column 1 (char 0) Traceback:Traceback (most recent call last): File "/var/lib/zmeventnotification/bin/zm_detect.py", line 556, in main_handler() File "/var/lib/zmeventnotification/bin/zm_detect.py", line 335, in main_handler zmapi = zmapi.ZMApi(options=api_options) File "/usr/local/lib/python3.9/dist-packages/pyzm/api.py", line 80, in __init__ self._login() File "/usr/local/lib/python3.9/dist-packages/pyzm/api.py", line 205, in _login rj = r.json() File "/usr/lib/python3/dist-packages/requests/models.py", line 900, in json return complexjson.loads(self.text, **kwargs) File "/usr/lib/python3/dist-packages/simplejson/__init__.py", line 525, in loads return _default_decoder.decode(s) File "/usr/lib/python3/dist-packages/simplejson/decoder.py", line 370, in decode obj, end = self.raw_decode(s) File "/usr/lib/python3/dist-packages/simplejson/decoder.py", line 400, in raw_decode return self.scan_once(s, idx=_w(s, idx).end())simplejson.errors.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

Zoneminder is v1.36.4

I can't work this one out - any help great appreciated

Nick.

User avatar
asker
Posts: 1511
Joined: Sun Mar 01, 2015 12:12 pm

Re: Event Notification Server error

Post by asker » Thu Jun 17, 2021 10:34 am

1. You will see a link in my signature that points to how to configure logs. Please follow that, enable debug logs
2. You will also see a link in my signature that points to how to report logs, also please take a look.

Now, looking at what you posted:
When the ES is trying to log into ZM, it is erroring out. There could be several reasons, but I'll start with the likeliest one,
- Your secrets.ini is not configured correctly

More insights can come by when you post more logs.
Please don't ask me questions via PM. Please post in these forums or GitHub.

Please read before posting:
How to set up logging properly
How to troubleshoot and report - ES
How to troubleshoot and report - zmNinja
ES docs
zmNinja docs

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests