ZMEventnotification working with Debian 9 / stretch

Discussion topics related to mobile applications for ZoneMinder
Post Reply
dad1
Posts: 7
Joined: Fri Feb 04, 2011 10:18 am

ZMEventnotification working with Debian 9 / stretch

Post by dad1 » Fri Jul 12, 2019 10:14 am

Hi,

I have seen a number of threads about getting event notification working with Debian 9/ stretch.

If you follow the installation guide you get errors such as:

ImportError: No module named 'cv2'

This happens because by default Stretch installs python 2.7. Following the installation guide installs python 3.

However, buried inside some of the zmeventnotification scripts some of the python calls are pip rather than pip3, so the commands get sent to the python 2.7 interpreter which does not have all the prerequisite modules installed and so throws errors like the one above.

Repeating all the pip3 commands in the installation guide with the pip versions so installing the prerequisites allowed me to get to a working system.

It's a bit of a kludge but it worked. I think the correct solution would be to go through the zmeventnotification scripts and make sure they all refer to pip3.

HTH

User avatar
asker
Posts: 1070
Joined: Sun Mar 01, 2015 12:12 pm

Re: ZMEventnotification working with Debian 9 / stretch

Post by asker » Fri Jul 12, 2019 11:59 am

Hi,
Glad you got it worked out. This is actually covered in the install steps. See this

I've come across one system where Python3 was the only version and "pip3" did not exist. pip was the right tool to use. That's why I chose to leave it as pip and not explicitly state pip3 everywhere.
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests