Stream works on web but not on ZMNinja

Discussion topics related to mobile applications for ZoneMinder
Post Reply
el_mechon_
Posts: 6
Joined: Wed Nov 01, 2017 6:50 pm

Stream works on web but not on ZMNinja

Post by el_mechon_ » Tue Nov 14, 2017 3:37 pm

Hello all.

I just installed v1.30.4 on CentOS7. Everything is working fine, I can see my stream and events. However, after purchasing ZMNinja isn't showing my monitors on iOS.

I used the wizard and also followed the F.A.Q. without success. I think the issue may be related to the cgi-bin path. Right now I have "/cgi-bin-zm/nph-zms" on the web server and the full path "https://190.167.104.69/zm/cgi-bin-zm" on ZMNinja. HTTP Auth is disabled. Please see attached screenshots.
IMG_5769.PNG
IMG_5769.PNG (49.19 KiB) Viewed 1749 times
IMG_5770.PNG
IMG_5770.PNG (94.15 KiB) Viewed 1749 times
ZMNinja.JPG
ZMNinja.JPG (81.7 KiB) Viewed 1749 times
If needed, I can provide remote access.

User avatar
asker
Posts: 959
Joined: Sun Mar 01, 2015 12:12 pm

Re: Stream works on web but not on ZMNinja

Post by asker » Tue Nov 14, 2017 5:52 pm

Settings look ok. Any chance you can come online to irc.freenode.net channel #zoneminder so we can debug? Also, try to use the desktop version first (easier to debug) - once we fix it, we can fix mobile https://github.com/pliablepixels/zmNinja/releases

PS: Enable ZM Auth and just put a dummy username password (x/x) or something - and see if that helps
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

el_mechon_
Posts: 6
Joined: Wed Nov 01, 2017 6:50 pm

Re: Stream works on web but not on ZMNinja

Post by el_mechon_ » Tue Nov 14, 2017 7:31 pm

I tried the desktop app and got it working using the wizard. I looked at the path the wizard on the desktop app found and turns out the correct path to cgi-bin is "https://190.167.104.69/cgi-bin-zm" (notice the missing /zm). I placed that path on the mobile app and that fixed the issue.
CGIPath.JPG
CGIPath.JPG (28.76 KiB) Viewed 1740 times
I'm leaving this here for anyone having this problem.

asker, thanks for your quick response and support.

User avatar
asker
Posts: 959
Joined: Sun Mar 01, 2015 12:12 pm

Re: Stream works on web but not on ZMNinja

Post by asker » Tue Nov 14, 2017 7:57 pm

ok cool - glad you solved it!
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests