ZMNinja on iPhone working great, iPad not so much...

Discussion topics related to mobile applications for ZoneMinder
Post Reply
JonUKRed
Posts: 2
Joined: Tue May 09, 2017 9:06 am

ZMNinja on iPhone working great, iPad not so much...

Post by JonUKRed » Tue May 09, 2017 9:15 am

Good morning All,

I am having some strange issues and hoped somebody here may be able to help.

I have recently setup ZM v1.30.3 on my UnRaid server and everything works great. Just testing with 1x 1080p IP camera just now, once I know all the functionality I require is there I will expand.

I have bought the Pro version of ZMNinja from the App store and installed it on both mine and my partners iPhones and iPads (1 x iPhone 7, 1 x iPhone 5s, 2 x iPad Air 2). The app works brilliantly on the iPhones, perfect live streaming and playback of events - no problems at all, very happy.

On the 2 iPads though the live streaming is very choppy, it will play a few seconds then stop for a few seconds then play again. All the settings are exactly the same as the iPhones, same network everything. No matter what I try I just can't get the same good performance on our iPads as we do on our iPhones. Bandwidth and processing is not an issue on my setup, confirmed also by good iPhone performance.

Is this a known issue? If anyone could help I would really appreciate it. Love the app just need it working on the iPads now :)

Cheers, Jon

asker
Posts: 807
Joined: Sun Mar 01, 2015 12:12 pm

Re: ZMNinja on iPhone working great, iPad not so much...

Post by asker » Tue May 09, 2017 2:33 pm

Hmm, that's odd.
I use it on my iPads regularly (air and pro)

The code is exactly the same. Can you confirm that you have disabled low bandwidth mode?
Also how many cameras?
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

JonUKRed
Posts: 2
Joined: Tue May 09, 2017 9:06 am

Re: ZMNinja on iPhone working great, iPad not so much...

Post by JonUKRed » Wed May 10, 2017 8:42 am

Hi Asker,

Many thanks for your prompt reply - glad to inform that I found the cause of the problem, and of course it wasn't the app - just for info I'll explain.

So we have 2 wireless networks at home, a 2.4GHz 11n at 300Mbps and a 5GHz 11ac @ 1.3Gbps. The iPhone were on the slower 2.4GHz band and the iPad on the quicker 5GHz band.

This was the only difference so I changed the iPad to the 2.4 (not expecting that to help) and lo and behold -Viola! Perfect.

I obviously have some very strange network gremlins as my Mac is on the 5GHz band and works with the ZMNinja Mac App perfectly! My only problem now is the iPad's are struggling to steam 4k GoPro content as that is ridiculous bitrates and 11n just can't cope :(

Oh well - at least the ZMNinja app works now and I can figure out what is going on. My brother is about to start a CCTV project and I'll definitely be recommending ZM with ZMNinja!

Many thanks for the great app.

Jon

asker
Posts: 807
Joined: Sun Mar 01, 2015 12:12 pm

Re: ZMNinja on iPhone working great, iPad not so much...

Post by asker » Wed May 10, 2017 1:04 pm

Hi Jon, glad you found the problem and happy you like the app.
I'm happy the problem was not with zmN, because if it was, I'd have no darn idea how to fix this sort of a problem :-)
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests