ZmNinja on CAT S60

Discussion topics related to mobile applications for ZoneMinder
Post Reply
LupoSpelacchiato
Posts: 4
Joined: Fri Nov 18, 2016 3:12 pm

ZmNinja on CAT S60

Post by LupoSpelacchiato » Wed May 03, 2017 8:56 pm

Hi, sorry but my english is not great...

I installed Zoneminder v 1.29 on Raspbian Jessie Lite and Raspberry Pi 3.
My LAN is composed of a router wifi, a Raspberry Pi 3 and two IP Cam wifi.
No connection a Internet.
It works well.

I run the commands to verify my APIs were working and they all passed for my installation.
I installed zmNinja on Samsung Galaxy S5 running Android version 6.0.1. .... works well.
I installed zmNinja on Samsung XCover 3 running Android version 5.1.1. .... works well.
I installed zmNinja on Samsung S7 running Android version 6.0.1. .... works well.
I watch my IP Cam with notebook Windows 8.1 and Chrome .... works well.

My problem is:
I installed zmNinja on Caterpillar CAT S60 running Android version 6.0.1.
I've always "zoneminder failed authentication". I've read for the topics (for example, "zmNinja on Galaxy S5") made some recommended changes without luck.
can someone help me ?
I attach the log file to an authentication attempt:

---------------------------------------------------------------------------------------------------------
Logs for version:1.2.35 (android)

May 3, 2017 07:38 PM DEBUG Latest post dated 2017-02-25 14:54:24 but you read 2017-04-29 16:57:29
May 3, 2017 07:38 PM DEBUG current version: 1.2.35 & available version 1.2.41
May 3, 2017 07:38 PM INFO Checking if reCaptcha is enabled in ZM...
May 3, 2017 07:38 PM INFO zmAutologin called
May 3, 2017 07:38 PM DEBUG Resetting zmCookie...
May 3, 2017 07:38 PM INFO Cancelling zmAutologin timer
May 3, 2017 07:38 PM DEBUG PIN code entered is correct, or there is no PIN set
May 3, 2017 07:38 PM DEBUG unlock called with check PIN=true
May 3, 2017 07:38 PM INFO not checking for touchID
May 3, 2017 07:38 PM INFO User credentials are provided
May 3, 2017 07:38 PM DEBUG Inside Portal login Enter handler
May 3, 2017 07:38 PM INFO Entering Portal Main
May 3, 2017 07:38 PM INFO >>>>>>>>>>>>>>> All init over, going to portal login
May 3, 2017 07:38 PM INFO DataModel init recovered this loginData as {"serverName":"192.168.2.2","username":"guest",<password removed>,"fallbackConfiguration":"","url":"http://<server>","apiurl":"http://<server>/api","eventServer":"","maxMontage":"100","streamingurl":"http://<server>/cgi-bin","maxFPS":"3","montageQuality":"50","singleImageQuality":"100","monSingleImageQuality":"100","montageHistoryQuality":"50","useSSL":false,"keepAwake":true,"isUseAuth":true,"isUseEventServer":false,"disablePush":false,"eventServerMonitors":"","eventServerInterval":"","refreshSec":"2","refreshSecLowBW":8,"enableLogs":true,"enableDebug":true,"usePin":false,"pinCode":"","canSwipeMonitors":true,"persistMontageOrder":true,"onTapScreen":"Montaggio","enableh264":true,"gapless":false,"montageOrder":"","montageHiddenOrder":"","montageArraySize":"0","showMontageSubMenu":false,"graphSize":2000,"enableAlarmCount":true,"minAlarmCount":1,"montageSize":"3","useNphZms":true,"useNphZmsForEvents":true,"packMontage":false,"exitOnSleep":false,"forceNetworkStop":false,"defaultPushSound":false,"enableBlog":true,"use24hr":false,"packeryPositions":"","packeryPositionsArray":{},"EHpackeryPositions":"","packerySizes":"","timelineModalGraphType":"Tutti","resumeDelay":0,"language":"en","reachability":true,"forceImageModePath":false,"disableNative":false,"vibrateOnPush":true,"soundOnPush":true,"cycleMonitors":false,"cycleMonitorsInterval":10,"enableLowBandwidth":false,"autoSwitchBandwidth":false,"disableAlarmCheckMontage":false,"useLocalTimeZone":true,"fastLogin":true,"followTimeLine":false,"timelineScale":-1}
May 3, 2017 07:38 PM INFO Setting DataModel init bandwidth to: highbw
May 3, 2017 07:38 PM DEBUG timeline graph type not set. Setting to all
May 3, 2017 07:38 PM INFO user profile encrypted, decoding...
May 3, 2017 07:38 PM INFO Setting up pause and resume handler AFTER language is loaded...
May 3, 2017 07:38 PM INFO Setting up POST LOGIN timer
May 3, 2017 07:38 PM INFO Checking for news updates
May 3, 2017 07:38 PM INFO Checking for new version updates...
May 3, 2017 07:38 PM INFO No Event Server present. Not initializing
May 3, 2017 07:38 PM INFO ZMData init: checking for stored variables & setting up log file
May 3, 2017 07:38 PM INFO Language file loaded, continuing with rest
May 3, 2017 07:38 PM INFO >>>>Language to be used:undefined
May 3, 2017 07:38 PM INFO Device Language is:it
May 3, 2017 07:38 PM INFO Language stored as:it
May 3, 2017 07:38 PM INFO App Version: 1.2.35
May 3, 2017 07:38 PM INFO Retrieving language before init is called...
May 3, 2017 07:38 PM INFO Enabling native transitions...
2017-05-03T17:38:27.256Z INFO Enabling insecure SSL
2017-05-03T17:38:27.246Z INFO Updating statusbar
2017-05-03T17:38:27.238Z INFO >>>>No data to import....
2017-05-03T17:38:26.953Z INFO localforage driver for storage:asyncStorage
2017-05-03T17:38:26.951Z DEBUG text zoom factor is 1
2017-05-03T17:38:26.341Z INFO You are running on android
May 3, 2017 07:36 PM INFO zmAutologin Error null and status 0
May 3, 2017 07:36 PM INFO ROOT APP: Stopping network pull...
May 3, 2017 07:36 PM INFO ROOT APP:App is going into background
May 3, 2017 07:36 PM INFO Checking if reCaptcha is enabled in ZM...
May 3, 2017 07:36 PM INFO zmAutologin called
May 3, 2017 07:36 PM DEBUG Resetting zmCookie...
May 3, 2017 07:36 PM INFO Cancelling zmAutologin timer
May 3, 2017 07:36 PM DEBUG PIN code entered is correct, or there is no PIN set
May 3, 2017 07:36 PM DEBUG unlock called with check PIN=true
May 3, 2017 07:36 PM INFO not checking for touchID
May 3, 2017 07:36 PM INFO User credentials are provided
May 3, 2017 07:36 PM DEBUG Inside Portal login Enter handler
May 3, 2017 07:36 PM INFO Entering Portal Main
May 3, 2017 07:36 PM DEBUG going to portal login
May 3, 2017 07:36 PM DEBUG Last State recorded:{"viewId":"ion30","index":1,"historyId":"ion3","backViewId":null,"forwardViewId":null,"stateId":"login_wizard=false","stateName":"login","stateParams":{"wizard":"false"},"url":"/login/false","canSwipeBack":true,"title":"Impostazioni"}
May 3, 2017 07:36 PM INFO Login screen resumed
May 3, 2017 07:36 PM DEBUG LogCtrl: resume called, starting log timer
May 3, 2017 07:36 PM INFO Login screen resumed
May 3, 2017 07:36 PM DEBUG LogCtrl: resume called, starting log timer
May 3, 2017 07:36 PM INFO >>> Resume delayed for 0 ms, to wait for network stack...
May 3, 2017 07:36 PM INFO App is resuming from background
May 3, 2017 07:32 PM INFO retrieved pre-stored loginData on past pause: {"serverName":"Zm","username":"guest",<password removed>,"fallbackConfiguration":"","url":"http://<server>","apiurl":"http://<server>/api","eventServer":"","maxMontage":"100","streamingurl":"http://<server>/cgi-bin","maxFPS":"3","montageQuality":"50","singleImageQuality":"100","monSingleImageQuality":"100","montageHistoryQuality":"50","useSSL":false,"keepAwake":true,"isUseAuth":true,"isUseEventServer":false,"disablePush":false,"eventServerMonitors":"","eventServerInterval":"","refreshSec":"2","refreshSecLowBW":8,"enableLogs":true,"enableDebug":true,"usePin":false,"pinCode":"","canSwipeMonitors":true,"persistMontageOrder":true,"onTapScreen":"Montaggio","enableh264":true,"gapless":false,"montageOrder":"","montageHiddenOrder":"","montageArraySize":"0","showMontageSubMenu":false,"graphSize":2000,"enableAlarmCount":true,"minAlarmCount":1,"montageSize":"3","useNphZms":true,"useNphZmsForEvents":true,"packMontage":false,"exitOnSleep":false,"forceNetworkStop":false,"defaultPushSound":false,"enableBlog":true,"use24hr":false,"packeryPositions":"","packeryPositionsArray":{},"EHpackeryPositions":"","packerySizes":"","timelineModalGraphType":"Tutti","resumeDelay":0,"language":"en","reachability":true,"forceImageModePath":false,"disableNative":false,"vibrateOnPush":true,"soundOnPush":true,"cycleMonitors":false,"cycleMonitorsInterval":10,"enableLowBandwidth":false,"autoSwitchBandwidth":false,"disableAlarmCheckMontage":false,"useLocalTimeZone":true,"fastLogin":true,"followTimeLine":false,"timelineScale":-1}
May 3, 2017 07:32 PM DEBUG Does login need to hear the wizard? false
May 3, 2017 07:32 PM DEBUG PortalLogin: error authenticating "No servers reachable"
May 3, 2017 07:32 PM INFO Failed reachability on http://<server>/index.php with error {"data":null,"status":0,"config":{"method":"GET","transformRequest":[null],"transformResponse":[null],"url":"http://<server>/index.php","headers":{"Accept":"application/json, text/plain, */*"}},"statusText":""}
May 3, 2017 07:32 PM DEBUG LogCtrl: pause called, killing log timer
May 3, 2017 07:32 PM INFO Login screen going to background, saving data
May 3, 2017 07:32 PM DEBUG LogCtrl: pause called, killing log timer
May 3, 2017 07:32 PM INFO Cancelling zmAutologin timer
May 3, 2017 07:32 PM INFO Reachability test..http://<server>/index.php
May 3, 2017 07:32 PM INFO detected loop when 192.168.2.2 fallsback to
May 3, 2017 07:32 PM INFO reached end of chain loop
May 3, 2017 07:32 PM INFO Fallback of 192.168.2.2 is
May 3, 2017 07:32 PM INFO Adding to chain stack: 192.168.2.2>http://<server>
May 3, 2017 07:32 PM DEBUG zmAutoLogin: Inside auth-error emit
May 3, 2017 07:32 PM INFO zmAutologin Error null and status 0
May 3, 2017 07:32 PM INFO ROOT APP: Stopping network pull...
May 3, 2017 07:32 PM INFO ROOT APP:App is going into background
May 3, 2017 07:31 PM INFO Checking if reCaptcha is enabled in ZM...
May 3, 2017 07:31 PM INFO zmAutologin called
May 3, 2017 07:31 PM DEBUG Resetting zmCookie...
May 3, 2017 07:31 PM INFO Cancelling zmAutologin timer
May 3, 2017 07:31 PM DEBUG PIN code entered is correct, or there is no PIN set
May 3, 2017 07:31 PM DEBUG unlock called with check PIN=true
May 3, 2017 07:31 PM INFO not checking for touchID
May 3, 2017 07:31 PM INFO User credentials are provided
May 3, 2017 07:31 PM DEBUG Inside Portal login Enter handler
May 3, 2017 07:31 PM INFO Entering Portal Main
May 3, 2017 07:31 PM DEBUG going to portal login
May 3, 2017 07:31 PM DEBUG Last State recorded:{"viewId":"ion19","index":1,"historyId":"ion3","backViewId":null,"forwardViewId":null,"stateId":"login_wizard=false","stateName":"login","stateParams":{"wizard":"false"},"url":"/login/false","canSwipeBack":true,"title":"Impostazioni"}
May 3, 2017 07:31 PM INFO Login screen resumed
May 3, 2017 07:31 PM DEBUG LogCtrl: resume called, starting log timer
May 3, 2017 07:31 PM INFO >>> Resume delayed for 0 ms, to wait for network stack...
May 3, 2017 07:31 PM INFO App is resuming from background
May 3, 2017 07:31 PM INFO retrieved pre-stored loginData on past pause: {"serverName":"Zm","username":"guest",<password removed>,"fallbackConfiguration":"","url":"http://<server>","apiurl":"http://<server>/api","eventServer":"","maxMontage":"100","streamingurl":"http://<server>/cgi-bin","maxFPS":"3","montageQuality":"50","singleImageQuality":"100","monSingleImageQuality":"100","montageHistoryQuality":"50","useSSL":false,"keepAwake":true,"isUseAuth":true,"isUseEventServer":false,"disablePush":false,"eventServerMonitors":"","eventServerInterval":"","refreshSec":"2","refreshSecLowBW":8,"enableLogs":true,"enableDebug":true,"usePin":false,"pinCode":"","canSwipeMonitors":true,"persistMontageOrder":true,"onTapScreen":"Montaggio","enableh264":true,"gapless":false,"montageOrder":"","montageHiddenOrder":"","montageArraySize":"0","showMontageSubMenu":false,"graphSize":2000,"enableAlarmCount":true,"minAlarmCount":1,"montageSize":"3","useNphZms":true,"useNphZmsForEvents":true,"packMontage":false,"exitOnSleep":false,"forceNetworkStop":false,"defaultPushSound":false,"enableBlog":true,"use24hr":false,"packeryPositions":"","packeryPositionsArray":{},"EHpackeryPositions":"","packerySizes":"","timelineModalGraphType":"Tutti","resumeDelay":0,"language":"en","reachability":true,"forceImageModePath":false,"disableNative":false,"vibrateOnPush":true,"soundOnPush":true,"cycleMonitors":false,"cycleMonitorsInterval":10,"enableLowBandwidth":false,"autoSwitchBandwidth":false,"disableAlarmCheckMontage":false,"useLocalTimeZone":true,"fastLogin":true,"followTimeLine":false,"timelineScale":-1}
May 3, 2017 07:31 PM DEBUG Does login need to hear the wizard? false
May 3, 2017 07:31 PM DEBUG PortalLogin: error authenticating "No servers reachable"
May 3, 2017 07:31 PM INFO Failed reachability on http://<server>/index.php with error {"data":null,"status":0,"config":{"method":"GET","transformRequest":[null],"transformResponse":[null],"url":"http://<server>/index.php","headers":{"Accept":"application/json, text/plain, */*"}},"statusText":""}
May 3, 2017 07:31 PM DEBUG LogCtrl: pause called, killing log timer
May 3, 2017 07:31 PM INFO Cancelling zmAutologin timer
May 3, 2017 07:31 PM INFO Reachability test..http://<server>/index.php
May 3, 2017 07:31 PM INFO detected loop when 192.168.2.2 fallsback to
May 3, 2017 07:31 PM INFO reached end of chain loop
May 3, 2017 07:31 PM INFO Fallback of 192.168.2.2 is
May 3, 2017 07:31 PM INFO Adding to chain stack: 192.168.2.2>http://<server>
May 3, 2017 07:31 PM DEBUG zmAutoLogin: Inside auth-error emit
May 3, 2017 07:31 PM INFO zmAutologin Error null and status 0
May 3, 2017 07:31 PM INFO ROOT APP: Stopping network pull...
May 3, 2017 07:31 PM INFO ROOT APP:App is going into background
May 3, 2017 07:30 PM DEBUG Latest post dated 2017-02-25 14:54:24 but you read 2017-04-29 16:57:29
May 3, 2017 07:30 PM DEBUG current version: 1.2.35 & available version 1.2.41
May 3, 2017 07:30 PM INFO Checking if reCaptcha is enabled in ZM...
May 3, 2017 07:30 PM INFO zmAutologin called
May 3, 2017 07:30 PM DEBUG Resetting zmCookie...
May 3, 2017 07:30 PM INFO Cancelling zmAutologin timer
May 3, 2017 07:30 PM DEBUG PIN code entered is correct, or there is no PIN set
May 3, 2017 07:30 PM DEBUG unlock called with check PIN=true
May 3, 2017 07:30 PM INFO not checking for touchID
May 3, 2017 07:30 PM INFO User credentials are provided
May 3, 2017 07:30 PM DEBUG Inside Portal login Enter handler
May 3, 2017 07:30 PM DEBUG Not changing bandwidth state, as auto change is not on
May 3, 2017 07:30 PM DEBUG getBandwidth() normalized it as: highbw
May 3, 2017 07:30 PM DEBUG Detected network type as: 4g
May 3, 2017 07:30 PM INFO Entering Portal Main
May 3, 2017 07:30 PM INFO >>>>>>>>>>>>>>> All init over, going to portal login
May 3, 2017 07:30 PM INFO DataModel init recovered this loginData as {"serverName":"192.168.2.2","username":"guest",<password removed>,"fallbackConfiguration":"","url":"http://<server>","apiurl":"http://<server>/api","eventServer":"","maxMontage":"100","streamingurl":"http://<server>/cgi-bin","maxFPS":"3","montageQuality":"50","singleImageQuality":"100","monSingleImageQuality":"100","montageHistoryQuality":"50","useSSL":false,"keepAwake":true,"isUseAuth":true,"isUseEventServer":false,"disablePush":false,"eventServerMonitors":"","eventServerInterval":"","refreshSec":"2","refreshSecLowBW":8,"enableLogs":true,"enableDebug":true,"usePin":false,"pinCode":"","canSwipeMonitors":true,"persistMontageOrder":true,"onTapScreen":"Montaggio","enableh264":true,"gapless":false,"montageOrder":"","montageHiddenOrder":"","montageArraySize":"0","showMontageSubMenu":false,"graphSize":2000,"enableAlarmCount":true,"minAlarmCount":1,"montageSize":"3","useNphZms":true,"useNphZmsForEvents":true,"packMontage":false,"exitOnSleep":false,"forceNetworkStop":false,"defaultPushSound":false,"enableBlog":true,"use24hr":false,"packeryPositions":"","packeryPositionsArray":{},"EHpackeryPositions":"","packerySizes":"","timelineModalGraphType":"Tutti","resumeDelay":0,"language":"en","reachability":true,"forceImageModePath":false,"disableNative":false,"vibrateOnPush":true,"soundOnPush":true,"cycleMonitors":false,"cycleMonitorsInterval":10,"enableLowBandwidth":false,"autoSwitchBandwidth":false,"disableAlarmCheckMontage":false,"useLocalTimeZone":true,"fastLogin":true,"followTimeLine":false,"timelineScale":-1}
May 3, 2017 07:30 PM INFO Setting DataModel init bandwidth to: highbw
May 3, 2017 07:30 PM DEBUG timeline graph type not set. Setting to all
May 3, 2017 07:30 PM INFO user profile encrypted, decoding...
May 3, 2017 07:30 PM INFO Setting up pause and resume handler AFTER language is loaded...
May 3, 2017 07:30 PM INFO Setting up POST LOGIN timer
May 3, 2017 07:30 PM INFO Checking for news updates
May 3, 2017 07:30 PM INFO Checking for new version updates...
May 3, 2017 07:30 PM INFO No Event Server present. Not initializing
May 3, 2017 07:30 PM INFO ZMData init: checking for stored variables & setting up log file
May 3, 2017 07:30 PM INFO Language file loaded, continuing with rest
May 3, 2017 07:30 PM INFO >>>>Language to be used:undefined
May 3, 2017 07:30 PM INFO Device Language is:it
May 3, 2017 07:30 PM INFO Language stored as:it
May 3, 2017 07:30 PM INFO App Version: 1.2.35
May 3, 2017 07:30 PM INFO Retrieving language before init is called...
May 3, 2017 07:30 PM INFO Enabling native transitions...
2017-05-03T17:30:52.209Z INFO Enabling insecure SSL
2017-05-03T17:30:52.200Z INFO Updating statusbar
2017-05-03T17:30:52.193Z INFO >>>>No data to import....
2017-05-03T17:30:52.053Z INFO Reachable: No server name configured, likely first use?
2017-05-03T17:30:52.016Z DEBUG zmAutoLogin: Inside auth-error emit
2017-05-03T17:30:52.015Z INFO zmAutologin Error null and status 0
2017-05-03T17:30:51.996Z INFO ZM has recaptcha disabled - good
2017-05-03T17:30:51.754Z INFO Checking if reCaptcha is enabled in ZM...
2017-05-03T17:30:51.751Z INFO zmAutologin called
2017-05-03T17:30:51.749Z DEBUG Resetting zmCookie...
2017-05-03T17:30:51.745Z INFO Your network is online, re-authenticating
2017-05-03T17:30:51.738Z INFO localforage driver for storage:asyncStorage
2017-05-03T17:30:51.736Z DEBUG text zoom factor is 1
2017-05-03T17:30:51.216Z INFO You are running on android
May 3, 2017 07:30 PM INFO Login screen going to background, saving data
May 3, 2017 07:30 PM DEBUG LogCtrl: pause called, killing log timer
May 3, 2017 07:30 PM INFO Cancelling zmAutologin timer
May 3, 2017 07:30 PM INFO ROOT APP: Stopping network pull...
May 3, 2017 07:30 PM INFO ROOT APP:App is going into background
---------------------------------------------------------------------------------------------------------------------------

Tanks

asker
Posts: 795
Joined: Sun Mar 01, 2015 12:12 pm

Re: ZmNinja on CAT S60

Post by asker » Thu May 04, 2017 2:16 pm

So if I understand correctly, zmNinja works fine on multiple devices except one?

Questions:
1) When zmNinja says auth failed, what is the log shown in ZM ? (syslog, apache error log and mysql error log)
2) Based on your logs, it looks like https is not being used correct?
3) On the caterpillar device, did you use Wizard to configure or manual? If manual try wizard
4) Go to Developer settings in zmNinja, enable "Enable strict SSL". Save. Then disable it. Save. Kill the app and launch. Try.
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

LupoSpelacchiato
Posts: 4
Joined: Fri Nov 18, 2016 3:12 pm

Re: ZmNinja on CAT S60

Post by LupoSpelacchiato » Fri May 05, 2017 9:07 am

Hi,
yes, correct, problem is on only one device (cat s60, android 6.0.1).
I perform the 4 points and post the results.
Thanks !

LupoSpelacchiato
Posts: 4
Joined: Fri Nov 18, 2016 3:12 pm

Re: ZmNinja on CAT S60

Post by LupoSpelacchiato » Tue May 09, 2017 10:20 am

Hi,
i report the results in order of execution:

3) I reconfigured cat60 device with Wizard and manual procedure. Problem failed authentication keep on.
4) I enabled SSL, save, disable SSL and save, reboot the device and tried. Problem keep on.
1) I tried to see the differences between the log file of Galaxy S5 Android 6.0.1 (works fine) and log file Cat S60 (problem authentication):

File log on ZM with login Galaxy S5:

Logs for version:1.2.35 (android)
May 8, 2017 12:26 PM INFO Got API version: 1.29.0
May 8, 2017 12:26 PM INFO ZM has recaptcha disabled - good
May 8, 2017 12:26 PM DEBUG getAPIversion called
May 8, 2017 12:26 PM DEBUG PortalLogin: auth success
May 8, 2017 12:26 PM INFO Stream authentication construction:
May 8, 2017 12:26 PM DEBUG Storing login time as Mon May 08 2017 12:26:18 GMT+0200
May 8, 2017 12:26 PM INFO Deferring auth key, as monitorId unknown
May 8, 2017 12:26 PM DEBUG auth-success emit:Successful
May 8, 2017 12:26 PM INFO zmAutologin successfully logged into Zoneminder <------ INIT DIFFERENCES WITH CAT60
May 8, 2017 12:26 PM INFO Checking if reCaptcha is enabled in ZM...
May 8, 2017 12:26 PM INFO zmAutologin called
May 8, 2017 12:26 PM DEBUG Resetting zmCookie...
May 8, 2017 12:26 PM INFO Cancelling zmAutologin timer
May 8, 2017 12:26 PM DEBUG PIN code entered is correct, or there is no PIN set
May 8, 2017 12:26 PM DEBUG unlock called with check PIN=true
May 8, 2017 12:26 PM INFO not checking for touchID
May 8, 2017 12:26 PM INFO User credentials are provided
May 8, 2017 12:26 PM DEBUG Inside Portal login Enter handler
May 8, 2017 12:26 PM INFO Entering Portal Main
May 8, 2017 12:26 PM INFO >>>>>>>>>>>>>>> All init over, going to portal login
May 8, 2017 12:26 PM INFO DataModel init recovered this loginData as {"serverName":"192.168.2.2","username":"guest",<password removed>,"fallbackConfiguration":"","url":"http://<server>","apiurl":"http://<server>/api","eventServer":"","maxMontage":"100","streamingurl":"http://<server>/cgi-bin","maxFPS":"3","montageQuality":100,"singleImageQuality":"100","monSingleImageQuality":"100","montageHistoryQuality":"50","useSSL":false,"keepAwake":true,"isUseAuth":true,"isUseEventServer":false,"disablePush":false,"eventServerMonitors":"","eventServerInterval":"","refreshSec":"2","refreshSecLowBW":8,"enableLogs":true,"enableDebug":true,"usePin":false,"pinCode":"","canSwipeMonitors":true,"persistMontageOrder":true,"onTapScreen":"Montaggio","enableh264":true,"gapless":true,"montageOrder":"","montageHiddenOrder":"","montageArraySize":"0","showMontageSubMenu":false,"graphSize":2000,"enableAlarmCount":true,"minAlarmCount":1,"montageSize":"3","useNphZms":true,"useNphZmsForEvents":true,"packMontage":false,"exitOnSleep":false,"forceNetworkStop":false,"defaultPushSound":false,"enableBlog":true,"use24hr":false,"packeryPositions":"[{\"attr\":\"1\",\"size\":\"50\",\"display\":\"show\",\"x\":0,\"y\":0},{\"attr\":\"2\",\"size\":\"50\",\"display\":\"show\",\"x\":0.5,\"y\":0}]","packeryPositionsArray":{},"EHpackeryPositions":"","packerySizes":"","timelineModalGraphType":"Tutti","resumeDelay":0,"language":"en","reachability":true,"forceImageModePath":false,"disableNative":false,"vibrateOnPush":true,"soundOnPush":true,"cycleMonitors":false,"cycleMonitorsInterval":10,"enableLowBandwidth":false,"autoSwitchBandwidth":false,"disableAlarmCheckMontage":false,"useLocalTimeZone":true,"fastLogin":true,"followTimeLine":false,"timelineScale":86400}
May 8, 2017 12:26 PM INFO Setting DataModel init bandwidth to: highbw
May 8, 2017 12:26 PM DEBUG timeline graph type not set. Setting to all
May 8, 2017 12:26 PM INFO user profile encrypted, decoding...
May 8, 2017 12:26 PM INFO Setting up pause and resume handler AFTER language is loaded...
May 8, 2017 12:26 PM INFO Setting up POST LOGIN timer
May 8, 2017 12:26 PM INFO Checking for news updates
May 8, 2017 12:26 PM INFO Checking for new version updates...
May 8, 2017 12:26 PM INFO No Event Server present. Not initializing
May 8, 2017 12:26 PM INFO ZMData init: checking for stored variables & setting up log file
May 8, 2017 12:26 PM INFO Language file loaded, continuing with rest
May 8, 2017 12:26 PM INFO >>>>Language to be used:undefined
May 8, 2017 12:26 PM INFO Device Language is:it
May 8, 2017 12:26 PM INFO Language stored as:it
May 8, 2017 12:26 PM INFO App Version: 1.2.35
May 8, 2017 12:26 PM INFO Retrieving language before init is called...
May 8, 2017 12:26 PM INFO Enabling native transitions...
2017-05-08T10:26:16.260Z INFO Enabling insecure SSL
2017-05-08T10:26:16.255Z INFO Updating statusbar
2017-05-08T10:26:16.251Z INFO >>>>No data to import....
2017-05-08T10:26:15.853Z INFO localforage driver for storage:asyncStorage
2017-05-08T10:26:15.850Z DEBUG text zoom factor is 1.09
2017-05-08T10:26:15.268Z INFO You are running on android


File log on ZM with login CAT S60 :

Logs for version:1.2.35 (android)
May 7, 2017 05:54 PM INFO Cancelling zmAutologin timer
May 7, 2017 05:54 PM INFO Reachability test..http://<server>/index.php
May 7, 2017 05:54 PM INFO detected loop when 192.168.2.2 fallsback to
May 7, 2017 05:54 PM INFO reached end of chain loop
May 7, 2017 05:54 PM INFO Fallback of 192.168.2.2 is
May 7, 2017 05:54 PM INFO Adding to chain stack: 192.168.2.2>http://<server>
May 7, 2017 05:54 PM DEBUG zmAutoLogin: Inside auth-error emit
May 7, 2017 05:54 PM INFO zmAutologin Error null and status 0
May 7, 2017 05:54 PM INFO ROOT APP: Stopping network pull...
May 7, 2017 05:54 PM INFO ROOT APP:App is going into background
May 7, 2017 05:54 PM DEBUG current version: 1.2.35 & available version 1.2.41
May 7, 2017 05:54 PM DEBUG Latest post dated 2017-02-25 14:54:24 but you read 2017-04-29 16:57:29 <-------------------------
May 7, 2017 05:54 PM INFO Checking if reCaptcha is enabled in ZM...
May 7, 2017 05:54 PM INFO zmAutologin called
May 7, 2017 05:54 PM DEBUG Resetting zmCookie...
May 7, 2017 05:54 PM INFO Cancelling zmAutologin timer
May 7, 2017 05:54 PM DEBUG PIN code entered is correct, or there is no PIN set
May 7, 2017 05:54 PM DEBUG unlock called with check PIN=true
May 7, 2017 05:54 PM INFO not checking for touchID
May 7, 2017 05:54 PM INFO User credentials are provided
May 7, 2017 05:54 PM DEBUG Inside Portal login Enter handler
May 7, 2017 05:54 PM INFO Entering Portal Main
May 7, 2017 05:54 PM INFO >>>>>>>>>>>>>>> All init over, going to portal login
May 7, 2017 05:54 PM INFO DataModel init recovered this loginData as {"serverName":"192.168.2.2","username":"guest",<password removed>,"fallbackConfiguration":"","url":"http://<server>","apiurl":"http://<server>/api","eventServer":"","maxMontage":"100","streamingurl":"http://<server>/cgi-bin","maxFPS":"3","montageQuality":"50","singleImageQuality":"100","monSingleImageQuality":"100","montageHistoryQuality":"50","useSSL":false,"keepAwake":true,"isUseAuth":true,"isUseEventServer":false,"disablePush":false,"eventServerMonitors":"","eventServerInterval":"","refreshSec":"2","refreshSecLowBW":8,"enableLogs":true,"enableDebug":true,"usePin":false,"pinCode":"","canSwipeMonitors":true,"persistMontageOrder":true,"onTapScreen":"Montaggio","enableh264":true,"gapless":false,"montageOrder":"","montageHiddenOrder":"","montageArraySize":"0","showMontageSubMenu":false,"graphSize":2000,"enableAlarmCount":true,"minAlarmCount":1,"montageSize":"3","useNphZms":true,"useNphZmsForEvents":true,"packMontage":false,"exitOnSleep":false,"forceNetworkStop":false,"defaultPushSound":false,"enableBlog":true,"use24hr":false,"packeryPositions":"","packeryPositionsArray":{},"EHpackeryPositions":"","packerySizes":"","timelineModalGraphType":"Tutti","resumeDelay":0,"language":"en","reachability":true,"forceImageModePath":false,"disableNative":false,"vibrateOnPush":true,"soundOnPush":true,"cycleMonitors":false,"cycleMonitorsInterval":10,"enableLowBandwidth":false,"autoSwitchBandwidth":false,"disableAlarmCheckMontage":false,"useLocalTimeZone":true,"fastLogin":true,"followTimeLine":false,"timelineScale":-1}
May 7, 2017 05:54 PM INFO Setting DataModel init bandwidth to: highbw
May 7, 2017 05:54 PM DEBUG timeline graph type not set. Setting to all
May 7, 2017 05:54 PM INFO user profile encrypted, decoding...
May 7, 2017 05:54 PM INFO Setting up pause and resume handler AFTER language is loaded...
May 7, 2017 05:54 PM INFO Setting up POST LOGIN timer
May 7, 2017 05:54 PM INFO Checking for news updates
May 7, 2017 05:54 PM INFO Checking for new version updates...
May 7, 2017 05:54 PM INFO No Event Server present. Not initializing
May 7, 2017 05:54 PM INFO ZMData init: checking for stored variables & setting up log file
May 7, 2017 05:54 PM INFO Language file loaded, continuing with rest
May 7, 2017 05:54 PM INFO >>>>Language to be used:undefined
May 7, 2017 05:54 PM INFO Device Language is:it
May 7, 2017 05:54 PM INFO Language stored as:it
May 7, 2017 05:54 PM INFO App Version: 1.2.35

Also, I tried to analyze the files in folder /var/log but there's nothing of interest.
I saved the folder.

I tried install ZmView app on CAT and that too has trouble.

Unfortunately I don't have a lot of practice of linux and apache.
what advice can you give me ...files to analize ..test ...
thanks in advance
Paolo

asker
Posts: 795
Joined: Sun Mar 01, 2015 12:12 pm

Re: ZmNinja on CAT S60

Post by asker » Wed May 17, 2017 5:53 pm

It looks to me like network access is failing on your CATS60

Try this:

1. Open up a regular chrome browser in your S60 and try and access your ZM portal - does it work? can you log in? (Please make sure you use Chrome - if you need to please download and install)

2. What port are you running ZM on? Is it 80?
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

LupoSpelacchiato
Posts: 4
Joined: Fri Nov 18, 2016 3:12 pm

Re: ZmNinja on CAT S60

Post by LupoSpelacchiato » Mon May 22, 2017 8:15 am

Hi Asker,
resolved ! resolved !
As your advice, I carefully checked the connection to the wifi network (network dedicated to cameras)...
... I did it many times!
I start ZmNinja with CAT S60 and it work fine !!
Honestly I did not understand why.
Thanks for time and your tips !
Paolo

asker
Posts: 795
Joined: Sun Mar 01, 2015 12:12 pm

Re: ZmNinja on CAT S60

Post by asker » Mon May 22, 2017 5:10 pm

Glad you got it working!
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest