zmninja centos 6 cgi-bin detection failed

Discussion topics related to mobile applications for ZoneMinder
Post Reply
bipolarbear
Posts: 2
Joined: Sat Feb 04, 2017 3:59 pm

zmninja centos 6 cgi-bin detection failed

Post by bipolarbear » Sat Feb 04, 2017 4:15 pm

Hi, I've found lots of posts on this issue but I've been searching for hours and I cannot find a solution. I have zm 1.30.0 up and running with 4 ip cameras and it all appears to be recording and streaming fine. I have installed php 5.4 from a 3rd-party repo, and zmninja setup wizard reports portal and api detection is ok. But then I get the red cross - cgi-bin detection failed. This is using the windows version of zmninja on windows 10 x64. As per the instructions I have tried changing PATH_ZMS from the default /cgi-bin/zm/nph-zms to https://<serverip>/cgi-bin/zm/nph-zms, but it makes no difference. My apache config is stock, I have not messed with it. At this point I don't know what else to try. Any help appreciated.

thanks.

asker
Posts: 801
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmninja centos 6 cgi-bin detection failed

Post by asker » Sun Feb 05, 2017 8:33 am

Zoneminder and zmNinja require different URL settings.

PATH_ZMS is used by Zoneminder and must always be a relative path. For example

Code: Select all

/zm/cgi-bin/nph-zms
First make sure you are able to view live feeds and events footage in zoneminder web console.
Do not try zmNinja till you are able to confirm web console works.

Once you have that working in zmNinja cgi bin specify the absolute path and without nph-zms

Example

Code: Select all

https://server/zm/cgi-bin/
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

bipolarbear
Posts: 2
Joined: Sat Feb 04, 2017 3:59 pm

Re: zmninja centos 6 cgi-bin detection failed

Post by bipolarbear » Sun Feb 05, 2017 11:37 am

Thanks Asker I think I fixed it last night. The wizard wouldnet get past the cgi-bin detection, but if I cancelled the wizard and just set it up manually like so:

ZM portal: https://serverip/zm
path to cgi-bin: https://serverip/cgi-bin/zm
ZM api url: https://serverip/zm/api

then it just seemed to spring into life. don't know why. So now that I know my setup is ok I will purchase the android version. thanks for your help.

asker
Posts: 801
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmninja centos 6 cgi-bin detection failed

Post by asker » Mon Feb 06, 2017 7:59 am

Sounds good. Yes, the wizard doesn't alway work (I don't know why)
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest