zmninja question

Discussion topics related to mobile applications for ZoneMinder
Post Reply
romany
Posts: 8
Joined: Fri Dec 23, 2016 3:28 am

zmninja question

Post by romany » Sun Jan 01, 2017 8:18 pm

I have Zmninja set up an working when my android phone is connected to my local home network. My internal ZM server is 192.168.1.110. I want to be able to access this via the internet - but I don't want to use 443 - since it a well known port and easily scanned. So I confiugred my SSL port to be - say 50000 - and set up a port forwarding statement on my router for 50000. On my zmninja client I went into setup and AFTER the host name I added ":50000" for the portal, cgi, and api url. That all works - from my internet connected phone I can bring up ZM and see my cameras - but the API now fails. I have a TCPDUMP capture going on my local router - internet facing interface. I see all TCP50000 traffic coming in - but NOT any TCP9000. In ZMninja log I see what I THINK may be the issue: wss://192.168.1.110:9000 is being pushed down. If my phone is using that link than that is not going to work. If I bring up my OpenVPN client on my phone than ZMninja works perfectly. I have the VPN client confiugred to use my home router DNS - so the address that is pushed down for my ZM host is the 192.168.1.110 (so the traffic going to/from 192.168.1.x travels over the vpn tunnel). If the VPN is not running the ZM URL resolves via DDNS - my ISP IP address assigned to my router. Hoping "asker" can give me some pointers on how to get around this issue. I would prefer not to use OpenVPN - it adds another level of complexity. Thanks for any tips...

asker
Posts: 807
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmninja question

Post by asker » Sun Jan 01, 2017 11:36 pm

Code: Select all

 wss://192.168.1.110:9000


This is used by the EventServer (if you have it installed). You need to provide more details/logs when you say API is not working.
Please also post a screenshot of your settings page.
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

romany
Posts: 8
Joined: Fri Dec 23, 2016 3:28 am

Re: zmninja question

Post by romany » Mon Jan 02, 2017 3:19 pm

That was the issue asker - I had the internal IP address of my ZM server configured in the ZMnimja event server field. Changed it to the DDNS host name and it now works. Thanks for the quick reply to my question though.

So great app and thanks for all your work on it. I'm going to make a donation for your efforts on this but you really should start charging for it :-)

Romany

asker
Posts: 807
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmninja question

Post by asker » Tue Jan 03, 2017 12:39 am

Glad it worked for you :-)
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests