Can't view feeds

Discussion topics related to mobile applications for ZoneMinder
Post Reply
kireol
Posts: 7
Joined: Wed Jul 03, 2013 11:28 am

Can't view feeds

Post by kireol » Thu Dec 03, 2015 1:53 am

Just got Android and OSX installed today.

If I use a browser, I can view the feeds.

If I use ZMNinja, I get camera question marks.

Image

json looks right.
{
"version": "1.28.109",
"apiversion": "1.28.109.1"
}


Any ideas?

User avatar
asker
Posts: 1396
Joined: Sun Mar 01, 2015 12:12 pm

Re: Can't view feeds

Post by asker » Thu Dec 03, 2015 2:02 am

please check your cgi-bin path. Its most likely set incorrectly in zmninja
Also useful to enable debug logs in zmninja
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

kireol
Posts: 7
Joined: Wed Jul 03, 2013 11:28 am

Re: Can't view feeds

Post by kireol » Thu Dec 03, 2015 2:24 am

that's a bingo!


Thanks man. perfect.

FreeSoftwareServers
Posts: 21
Joined: Mon Dec 07, 2015 10:37 pm

Re: Can't view feeds

Post by FreeSoftwareServers » Wed Dec 09, 2015 9:23 am

I also have the same issue, except I had to fix PATH_ZM by adding /zm/ to get the Web View to work, but in zmNinja, just a question mark.

my PATHS_ZM looks like

/zm/cgi-bin/nph-zms

FreeSoftwareServers
Posts: 21
Joined: Mon Dec 07, 2015 10:37 pm

Re: Can't view feeds

Post by FreeSoftwareServers » Wed Dec 09, 2015 9:37 am

Got it working, figured I would share.. cough cough.

The PATH_ZMS setting inside the Options >> PATH variable inside of ZoneMinder Consol fix viewing stream in WebBrowser but to fix zmNinja I had to manually edit

path to cgi-bin

http://server/zm/cgi-bin/nph-zms

I figured since it literally copied the text I pasted into ZM portal URL it was filling in the information as needed. A nice feature but perhaps it should just add /cgi-bin/nph-zms to whatever is typed for ZM Portal. Anyway one problem down!

rockandroller
Posts: 51
Joined: Tue Dec 22, 2015 12:44 am

Re: Can't view feeds

Post by rockandroller » Sat Jan 30, 2016 4:25 am

Briefly had the same issue here, and for my Centos7 ZM install, the correct ZMninja CGI-BIN path was http://server/zm/cgi-bin-zm/nph-zms

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests