I am lost in the configuration of zmeventnotification

Discussion topics related to mobile applications for ZoneMinder
Magic919
Posts: 518
Joined: Wed Sep 18, 2013 6:56 am

Re: I am lost in the configuration of zmeventnotification

Post by Magic919 » Thu May 13, 2021 1:58 pm

9000 is just for the ZMES (Event Server) alerts and it's not mandatory.

User avatar
asker
Posts: 1497
Joined: Sun Mar 01, 2015 12:12 pm

Re: I am lost in the configuration of zmeventnotification

Post by asker » Fri May 14, 2021 12:11 am

There is a gotcha here.
There are times your device token will change. One example is if you delete and reinstall your app. The other is if the app unregisters a token - I’ll have to go see if I unregister for any case. Apple or Google may unregister a token and regenerate - this has happened to me after I messed up on some notification code - maybe they have some guard checks. Finally - they actually have an expiry time (a year plus I think). In all these situations your ZmNinja device needs to send the new token value to the ES over the web socket port (9000 by default). If it is unable to, you’ll stop receiving notifications. If you don’t expose 9000 over wan then make sure your client is at least able to communicate via LAN to 9000 once in a while.
Please don't ask me questions via PM. Feel free to post in the forums or Github

Please read before posting:
How to set up logging properly How to troubleshoot and report - ES
How to troubleshoot and report - zmNinja
ES docs
zmNinja docs

titof2375
Posts: 66
Joined: Sat Dec 12, 2020 2:32 pm

Re: I am lost in the configuration of zmeventnotification

Post by titof2375 » Sat May 15, 2021 9:08 pm

I think it came from my nus not powerful enough because I redid the same installation and no more problem

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests