MODECT not picking up properly

Forum for questions and support relating to the 1.28.x releases only.
Post Reply
jbreslau
Posts: 1
Joined: Tue Mar 01, 2016 3:51 pm

MODECT not picking up properly

Post by jbreslau » Tue Mar 01, 2016 3:52 pm

Hello -
Kind of new to all of this but I have a IP camera set up and its recording larger motion detection but I am trying to get it to pick up the dog and its not. Any help with settings?

bbunge
Posts: 2420
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: MODECT not picking up properly

Post by bbunge » Tue Mar 01, 2016 10:17 pm


Nerre
Posts: 100
Joined: Thu Sep 25, 2014 10:22 am

Re: MODECT not picking up properly

Post by Nerre » Wed Mar 02, 2016 7:08 am

Fine tuning motion detection in Zoneminder is IMO extremely hard.

One feature I would love is to be able to make a recording and then perform motion detection on the recorded images. That way it would be possible to fine tune the parameters.

Today you can (as far as I know) only get statistics for alarm frames, not non-alarming frames. And you only get visual indication of where the alarming pixels are when you are using blobs.

akg1508
Posts: 22
Joined: Sun Aug 02, 2015 9:06 am

Re: MODECT not picking up properly

Post by akg1508 » Wed Mar 02, 2016 11:35 am

jbreslau wrote:Hello -
Kind of new to all of this but I have a IP camera set up and its recording larger motion detection but I am trying to get it to pick up the dog and its not. Any help with settings?
As another newbie to configuring ZM, my suggestion is that if you have a single zone that covers most of the frame, try breaking it up in to smaller zones, so that what you are trying to detect, the dog in this case, is a significant part of the zone, maybe a 1/4 of the zone.

PacoLM
Posts: 967
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: MODECT not picking up properly

Post by PacoLM » Thu Mar 03, 2016 7:32 am


mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.31.1)

davidma
Posts: 22
Joined: Fri Oct 16, 2015 1:40 am

Re: MODECT not picking up properly

Post by davidma » Thu Mar 03, 2016 10:12 pm

Try setting the various parameters as low as is reasonable then slowly work up to eliminate false alarms yet still get what you seek. With a high resolution camera changing to pixels as opposed to percentage might make tuning for smaller objects easier. Either way it will almost always take some tuning to get it right and it will probably never be perfect.

Nerre
Posts: 100
Joined: Thu Sep 25, 2014 10:22 am

Re: MODECT not picking up properly

Post by Nerre » Sun Mar 06, 2016 5:50 pm

My problem is that at one setting I get like 10 false positives an hour, changing the percentage 5% instead gives me zero events...

One big problem is that the pixel level change is the same no matter the initial level.

Pixel changing from 2 to 12 is a change of 10, but also a change from 200 to 210 is a change of 10. This means noise in low light conditions will trigger on low settings, but to be able to detect a white object moving in broad daylight I can not set the sensitivity lower.

Also clouds moving (and changing the overall light conditions) is problematic. Setting a preclusive zone does not always work because the preclusive zone may need to be set on an area with a different background color. For example I have a zone on my light gray concrete stair outside, the rail is dark brown and the wall is red brick. When clouds move the stair changes a lot, but the dark brown rail and the brick wall does not change enough...

And setting "max pixels" does not help, because depending on the time of day the rail shadows half the stair (so only 50% av the pixels change, and that is close to the change when a person walks by).

And then I haven't begun talking about findings settings that will work both day and night....

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests