Bug in snapshot 1.28.109-trusty-2015122301

Forum for questions and support relating to the 1.28.x releases only.
Post Reply
fennec
Posts: 39
Joined: Thu Mar 20, 2014 1:17 am

Bug in snapshot 1.28.109-trusty-2015122301

Post by fennec » Thu Dec 24, 2015 9:38 am

Hi

i use update with https://launchpad.net/~iconnor/+archive ... der-master

and with the last update zoneminder:amd64 1.28.109-trusty-2015122301 all my cam is red nothing to do

I downgrade to zoneminder:amd64 1.28.109-trusty-2015120403 and all is ok

Ubuntu 14.04 LTS 64bits

Thanks a lot

User avatar
asker
Posts: 1140
Joined: Sun Mar 01, 2015 12:12 pm

Re: Bug in snapshot 1.28.109-trusty-2015122301

Post by asker » Thu Dec 24, 2015 11:17 am

You have likely not read that the cgi-bin path has changed. Please read this https://wiki.zoneminder.com/Common_Issu ... _on_Ubuntu (and refer to the PATH_ZMS part)
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

fennec
Posts: 39
Joined: Thu Mar 20, 2014 1:17 am

Re: Bug in snapshot 1.28.109-trusty-2015122301

Post by fennec » Thu Dec 24, 2015 12:07 pm

Thanks for your help

my PATH_ZMS is set to: /zm/cgi-bin/nph-zms so no update to 109 My version is 109

And all is ok alarm etc etc but no viewer and IP is in red But il have events record

User avatar
asker
Posts: 1140
Joined: Sun Mar 01, 2015 12:12 pm

Re: Bug in snapshot 1.28.109-trusty-2015122301

Post by asker » Thu Dec 24, 2015 12:17 pm

Oh sorry, looks like you were already on 109 and you moved from 2015122301 to 2015120403 - I thought you upgraded from 1.28.1 to 109

Hmmm - what does syslog and apache error logs say when you view a feed?
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

DVB Hardware
Posts: 99
Joined: Thu Jan 01, 2015 5:12 pm

Re: Bug in snapshot 1.28.109-trusty-2015122301

Post by DVB Hardware » Thu Dec 24, 2015 5:31 pm

Broken Image Icon in monitor window, ip address red,, cgi settings were correct
I had the same problem, can't remember everything I tried but I ran " zmupdate.pl -f " lastly
and seemed to fix it
ERROR
Config mismatch, expected 224 items, read 223. Try running 'zmupdate.pl -f' to reload config

I learned my lesson, back up ZM before doing an apt-get upgrade !!!! Now to remenber it
Linux Mint 19.3 Cinnamon Mariadb using Master

DVB stands for Digital VIdeo Broadcasting , retired satellite downlink supplier

bbunge
Posts: 2507
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Bug in snapshot 1.28.109-trusty-2015122301

Post by bbunge » Fri Dec 25, 2015 12:33 am

Did you change permissions in your database?

mysql -e "grant select,insert,update,delete,create,alter,lock tables,index on zm.* to 'zmuser'@localhost identified by 'zmpass';"

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: Bug in snapshot 1.28.109-trusty-2015122301

Post by McFuzz » Fri Dec 25, 2015 8:41 pm

Hi all

I hit the same exact issue on two of my boxes; running zmupdate.pl -f followed by zm restart fixed it on my end.

Thanks!

DVB Hardware
Posts: 99
Joined: Thu Jan 01, 2015 5:12 pm

Re: Bug in snapshot 1.28.109-trusty-2015122301

Post by DVB Hardware » Sat Dec 26, 2015 7:58 pm

bbunge wrote:Did you change permissions in your database?

mysql -e "grant select,insert,update,delete,create,alter,lock tables,index on zm.* to 'zmuser'@localhost identified by 'zmpass';"
No I left them alone when I upgraded before...just a test box
Linux Mint 19.3 Cinnamon Mariadb using Master

DVB stands for Digital VIdeo Broadcasting , retired satellite downlink supplier

User avatar
knight-of-ni
Posts: 2241
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Bug in snapshot 1.28.109-trusty-2015122301

Post by knight-of-ni » Sat Dec 26, 2015 8:37 pm

The point bbunge was trying to make is the minimum dB permission required for ZoneMinder has changed in the latest development snapshot, and if you have not updated the permissions of your sql account then that will cause problems. For rpm packages in zmrepo, I've started recommending the end user simply grant all permissions and be done with it, but I'm not sure Debian packages will follow suite.

Note that, when upgrading zoneminder, you should always run "zmupdate -f" as root before starting zoneminder. Ubuntu users might not be used to this as it was previously done for them in the packaging scripts. You will have to contact the package maintainer if you think this should be automatic.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests