Ubuntu 14.04 - No installation candidate

Forum for questions and support relating to the 1.28.x releases only.
Post Reply
joaoduarte
Posts: 4
Joined: Sat Dec 12, 2015 5:06 pm

Ubuntu 14.04 - No installation candidate

Post by joaoduarte » Sat Dec 12, 2015 5:32 pm

Hey there!

Not sure if this is the right place for this but, from what I've searched I couldn't find anyone else with the same issues, so here it goes:

I've been trying to install ZM for a couple of days now, without success, on Ubuntu Server 14.04.3. Initially I was following this: https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way

But I always got the error "Package 'zoneminder' has no installation candidate".
Later I noticed what it says in here:
https://wiki.zoneminder.com/Common_Issu ... PA_version

So basically the PPA version was removed on 10NOV15. But supposedly it should work if I use the development PPA Zoneminder-Master. So I removed the old one and added the master to my repo and after apt-get update and apt-get install zoneminder I still keep getting the same error, "no installation candidate".

I also noticed the other topic there where it says 05DEC15 it was verified that the upgrade from 1.26 to 1.28 or later would work on Ubuntu 14.04 but for that I had to have some zoneminder installed, and I can't get any version to work.

So I'm not sure what to try next.

I've been considering building from source even though it is discouraged:
http://zoneminder.readthedocs.org/en/la ... buntu.html

But I noticed that there was nothing for Ubuntu 14.04 on the distros directory:
https://github.com/ZoneMinder/ZoneMinder

So now I'm thinking that maybe I should just install any other version of Ubuntu although I don't think that makes much sense..

Any tips?

bbunge
Posts: 2430
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 14.04 - No installation candidate

Post by bbunge » Sat Dec 12, 2015 7:00 pm

Well, you must not be following the install procedure. The iconnor PPA has the ZM version for Ubuntu 14.04 and it looks like my procedure has not been changed by a friendly helper. I will rerun the procedure to make sure it still works and post the results later.

bb

bbunge
Posts: 2430
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 14.04 - No installation candidate

Post by bbunge » Sat Dec 12, 2015 7:23 pm

Just ran the install at:
https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way
with no issues. As I use an image of Ubuntu 14.04 server with LAMP I started the setup at: Add Repository

joaoduarte
Posts: 4
Joined: Sat Dec 12, 2015 5:06 pm

Re: Ubuntu 14.04 - No installation candidate

Post by joaoduarte » Sun Dec 13, 2015 5:41 pm

bbunge wrote:Just ran the install at:
https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way
with no issues. As I use an image of Ubuntu 14.04 server with LAMP I started the setup at: Add Repository
I've followed all instructions carefully. Then it must be something wrong with my system.. What repository did you use? Zoneminder or Zoneminder-master?

I think my system is not picking up on the PPA. I was able to install version 1.26.5, by going to /etc/apt/sources and uncommenting the "universe" related lines. Now I'm running that version ok. But I've tried the upgrade procedure and it doesn't work. After following those steps, after dist-upgrade, nothing happens, I never receive the question about replacing the file /etc/init.d/zoneminder.

bbunge
Posts: 2430
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 14.04 - No installation candidate

Post by bbunge » Sun Dec 13, 2015 8:07 pm

You are trying too hard. Do not use the iconnor zoneminder-master unless you want to run a development version. Suggest you start with a fresh server install. There is no reason to edit your sources file if you follow the instructions.

joaoduarte
Posts: 4
Joined: Sat Dec 12, 2015 5:06 pm

Re: Ubuntu 14.04 - No installation candidate

Post by joaoduarte » Mon Dec 14, 2015 6:36 pm

Thanks. I was able to install it on another machine. I supposed there was something wrong with my Ubuntu Server. It's always a headache running it on ARM architecture..

SteveGilvarry
Posts: 418
Joined: Sun Jun 29, 2014 1:12 pm
Location: Melbourne, AU

Re: Ubuntu 14.04 - No installation candidate

Post by SteveGilvarry » Wed Dec 16, 2015 1:44 pm

joaoduarte wrote:It's always a headache running it on ARM architecture..
Tell us about it...
By default I do not believe any PPA's are built for arm by default, you have to request it. Always worth stating some information about your system in any posts as sometimes it is important.
Production Zoneminder 1.32.3
Random Selection of Cameras (Dahua and Hikvision)
More Dev VM's than I care to count.

joaoduarte
Posts: 4
Joined: Sat Dec 12, 2015 5:06 pm

Re: Ubuntu 14.04 - No installation candidate

Post by joaoduarte » Wed Dec 16, 2015 7:10 pm

SteveGilvarry wrote:
joaoduarte wrote:It's always a headache running it on ARM architecture..
Tell us about it...
By default I do not believe any PPA's are built for arm by default, you have to request it. Always worth stating some information about your system in any posts as sometimes it is important.
Maybe that's why I cant get it working. I should have mentioned it was for arm.
The idea was to create a low cost video surveillance system, using a Cubieboard 2 + 2.5'' HDD + Zoneminder Server.
I installed Ubuntu Server 14.04.3 trusty, kernel 3.4.86 on the cubieboard. I was able to install zoneminder 1.26.5, but I cant upgrade it, possibly because like you said, the PPA's aren't built for arm, and I didn't know that.

Cubieboard2 full specs:
-Allwiner A20
-CPU: ARM® Cortex™-A7 Dual-Core
-GPU: ARM® Mali400MP2, Complies with OpenGL ES 2.0/1.1
-Memory: 1GB DDR3 @960M
-Storage: 4GB internal NAND flash

Because the specs are limited, this version of ubuntu server is quite limited as well, which also might cause problems. Not sure, I'm just a basic linux user.

So how could I request a PPA for arm?

SteveGilvarry
Posts: 418
Joined: Sun Jun 29, 2014 1:12 pm
Location: Melbourne, AU

Re: Ubuntu 14.04 - No installation candidate

Post by SteveGilvarry » Thu Dec 17, 2015 9:57 am

Have a look at what people are doing with Raspberry Pi, I think zmrepo has a build for arm. http://zmrepo.zoneminder.com Yep fedora builds, just make sure you disable the default fedora version of Zoneminder, which doesn't have ffmpeg or libvlc.
Production Zoneminder 1.32.3
Random Selection of Cameras (Dahua and Hikvision)
More Dev VM's than I care to count.

mrd
Posts: 245
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Re: Ubuntu 14.04 - No installation candidate

Post by mrd » Mon Jan 11, 2016 9:09 pm

I'm seeing a similar issue, but not on an ARM.

I tried the same install instructions and ended up with 1.26.5.

Does anyone know if the PPA is broken or if this is an issue with a fresh install of Ubuntu 14.04 server?
MRD

SteveGilvarry
Posts: 418
Joined: Sun Jun 29, 2014 1:12 pm
Location: Melbourne, AU

Re: Ubuntu 14.04 - No installation candidate

Post by SteveGilvarry » Tue Jan 12, 2016 1:12 pm

mrd wrote:Does anyone know if the PPA is broken or if this is an issue with a fresh install of Ubuntu 14.04 server?
No PPA is working fine. And not related to Ubuntu 14.04 Server as I just tested it. Double check your PPA add command and apt-get update afterwards.

1.26.5 means you are getting the standard repo old version.
Production Zoneminder 1.32.3
Random Selection of Cameras (Dahua and Hikvision)
More Dev VM's than I care to count.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests