modect stopped working

Forum for questions and support relating to the 1.28.x releases only.
Post Reply
raydude
Posts: 63
Joined: Sun Jul 21, 2013 6:09 pm

modect stopped working

Post by raydude » Thu Sep 24, 2015 4:29 pm

I've been running zoneminder with foscam cameras for a couple of years. I updated my gentoo a few months ago and motion detection stopped working. Images are still capturing because I can see them in montage. But motion is never detected and images are never stored.

I reinstalled and created a new mysql database and got back to exactly the same point. I even switched from a self build to installing with the portage ebuild.

All my logs look completely normal. I have the logs set to debug level and the sql log only mentions the capture rate. The log files in /var/log/zm are normal except zms.log is empty.

Since there are no errors, I have no idea what to look at.

Does anyone have an idea of how to approach this issue?

Thanks.

raydude
Posts: 63
Joined: Sun Jul 21, 2013 6:09 pm

Re: modect stopped working

Post by raydude » Fri Sep 25, 2015 6:05 am

I mokeyed with some symbolic links (I store the images and events on a raid array with more space than my boot drive. I just restarted it and I get errors, but the streams are viewable.

zms.log looks like this:
09/24/15 22:55:35.502469 zms[16108].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_user.cpp/241 [Authenticated user 'admin']
09/24/15 22:55:35.520952 zms[16108].WAR-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp/426 [Shared data not initialised by capture daemon, some query functions may not be available or produce invalid results for monitor SideYard]
09/24/15 22:55:45.256675 zms[16108].ERR-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp/3893 [Unable to send stream frame: Broken pipe]
09/24/15 22:55:45.384275 zms[16108].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_logger.cpp/235 [Terminating Logger]

zmdc.log shows this:

09/22/2015 23:32:32.530604 zmdc[9280].INF [Server starting at 15/09/22 23:32:32]
09/22/2015 23:32:35.618182 zmdc[9280].INF ['zmc -m 1' starting at 15/09/22 23:32:35, pid = 9312]
09/22/2015 23:32:35.618186 zmdc[9312].INF ['zmc -m 1' started at 15/09/22 23:32:35]
09/22/2015 23:32:35.630728 zmdc[9280].ERR ['zmc -m 1' exited abnormally, exit status 255]
09/22/2015 23:32:35.631612 zmdc[9280].INF [Starting pending process, zmc -m 1]
09/22/2015 23:32:35.633686 zmdc[9280].INF ['zmc -m 1' starting at 15/09/22 23:32:35, pid = 9314]
09/22/2015 23:32:35.633689 zmdc[9314].INF ['zmc -m 1' started at 15/09/22 23:32:35]
09/22/2015 23:32:35.694085 zmdc[9280].INF ['zma -m 1' starting at 15/09/22 23:32:35, pid = 9316]
09/22/2015 23:32:35.694093 zmdc[9316].INF ['zma -m 1' started at 15/09/22 23:32:35]
09/22/2015 23:32:35.758367 zmdc[9280].INF ['zmc -m 2' starting at 15/09/22 23:32:35, pid = 9320]
09/22/2015 23:32:35.758371 zmdc[9320].INF ['zmc -m 2' started at 15/09/22 23:32:35]
09/22/2015 23:32:35.769536 zmdc[9280].ERR ['zmc -m 2' exited abnormally, exit status 255]
09/22/2015 23:32:35.770378 zmdc[9280].INF [Starting pending process, zmc -m 2]
09/22/2015 23:32:35.771952 zmdc[9280].INF ['zmc -m 2' starting at 15/09/22 23:32:35, pid = 9325]
09/22/2015 23:32:35.772009 zmdc[9325].INF ['zmc -m 2' started at 15/09/22 23:32:35]
09/22/2015 23:32:35.827229 zmdc[9280].INF ['zma -m 2' starting at 15/09/22 23:32:35, pid = 9335]
09/22/2015 23:32:35.827239 zmdc[9335].INF ['zma -m 2' started at 15/09/22 23:32:35]
09/22/2015 23:32:35.897949 zmdc[9280].INF ['zmfilter.pl' starting at 15/09/22 23:32:35, pid = 9340]
09/22/2015 23:32:35.897952 zmdc[9340].INF ['zmfilter.pl' started at 15/09/22 23:32:35]
09/22/2015 23:32:35.982385 zmdc[9280].INF ['zmaudit.pl -c' starting at 15/09/22 23:32:35, pid = 9345]
09/22/2015 23:32:35.982389 zmdc[9345].INF ['zmaudit.pl -c' started at 15/09/22 23:32:35]
09/22/2015 23:32:36.047785 zmdc[9280].INF ['zmwatch.pl' starting at 15/09/22 23:32:36, pid = 9349]
09/22/2015 23:32:36.047789 zmdc[9349].INF ['zmwatch.pl' started at 15/09/22 23:32:36]
09/22/2015 23:32:36.111878 zmdc[9280].INF ['zmupdate.pl -c' starting at 15/09/22 23:32:36, pid = 9358]
09/22/2015 23:32:36.111883 zmdc[9358].INF ['zmupdate.pl -c' started at 15/09/22 23:32:36]
09/23/2015 20:39:55.209333 zmdc[9280].INF ['zmc -m 1' stopping at 15/09/23 20:39:55]
09/23/2015 20:40:01.215245 zmdc[9280].INF ['zmc -m 1' crashed, signal 8]
09/23/2015 20:40:01.316843 zmdc[9280].INF [Starting pending process, zmc -m 1]
09/23/2015 20:40:01.319876 zmdc[9280].INF ['zmc -m 1' starting at 15/09/23 20:40:01, pid = 23616]
09/23/2015 20:40:01.319947 zmdc[23616].INF ['zmc -m 1' started at 15/09/23 20:40:01]
09/24/2015 01:32:36.512758 zmdc[9280].ERR ['zmupdate.pl -c' exited abnormally, exit status 9]
09/24/2015 01:32:36.513579 zmdc[9280].INF [Starting pending process, zmupdate.pl -c]
09/24/2015 01:32:36.515204 zmdc[9280].INF ['zmupdate.pl -c' starting at 15/09/24 01:32:36, pid = 21538]
09/24/2015 01:32:36.515206 zmdc[21538].INF ['zmupdate.pl -c' started at 15/09/24 01:32:36]
09/24/2015 22:52:12.704782 zmdc[9280].INF ['zma -m 1' stopping at 15/09/24 22:52:12]
09/24/2015 22:52:18.710966 zmdc[9280].INF ['zma -m 1' crashed, signal 8]
09/24/2015 22:52:18.712932 zmdc[9280].INF ['zmupdate.pl -c' stopping at 15/09/24 22:52:18]
09/24/2015 22:52:24.716698 zmdc[9280].INF ['zmupdate.pl -c' crashed, signal 8]
09/24/2015 22:52:24.718470 zmdc[9280].INF ['zmwatch.pl ' stopping at 15/09/24 22:52:24]
09/24/2015 22:52:30.720491 zmdc[9280].INF ['zmwatch.pl ' crashed, signal 8]
09/24/2015 22:52:30.721801 zmdc[9280].INF ['zmc -m 2' stopping at 15/09/24 22:52:30]
09/24/2015 22:52:36.725053 zmdc[9280].INF ['zmc -m 2' crashed, signal 8]
09/24/2015 22:52:36.727166 zmdc[9280].INF ['zmc -m 1' stopping at 15/09/24 22:52:36]
09/24/2015 22:52:42.731055 zmdc[9280].INF ['zmc -m 1' crashed, signal 8]
09/24/2015 22:52:42.733306 zmdc[9280].INF ['zmaudit.pl -c' stopping at 15/09/24 22:52:42]
09/24/2015 22:52:48.735821 zmdc[9280].INF ['zmaudit.pl -c' crashed, signal 8]
09/24/2015 22:52:48.737812 zmdc[9280].INF ['zmfilter.pl ' stopping at 15/09/24 22:52:48]
09/24/2015 22:52:54.740371 zmdc[9280].INF ['zmfilter.pl ' crashed, signal 8]
09/24/2015 22:52:54.741716 zmdc[9280].INF ['zma -m 2' stopping at 15/09/24 22:52:54]
09/24/2015 22:53:00.747620 zmdc[9280].INF ['zma -m 2' crashed, signal 8]
09/24/2015 22:53:10.830265 zmdc[9280].INF [Server shutdown at 15/09/24 22:53:10]
09/24/2015 22:55:26.500049 zmdc[15955].INF [Server starting at 15/09/24 22:55:26]
09/24/2015 22:55:29.567540 zmdc[15955].INF ['zmc -m 1' starting at 15/09/24 22:55:29, pid = 15987]
09/24/2015 22:55:29.567543 zmdc[15987].INF ['zmc -m 1' started at 15/09/24 22:55:29]
09/24/2015 22:55:29.591842 zmdc[15955].ERR ['zmc -m 1' exited abnormally, exit status 255]
09/24/2015 22:55:29.758893 zmdc[15955].INF [Starting pending process, zmc -m 1]
09/24/2015 22:55:29.761171 zmdc[15955].INF ['zmc -m 1' starting at 15/09/24 22:55:29, pid = 15990]
09/24/2015 22:55:29.761177 zmdc[15990].INF ['zmc -m 1' started at 15/09/24 22:55:29]
09/24/2015 22:55:29.763138 zmdc[15955].INF ['zma -m 1' starting at 15/09/24 22:55:29, pid = 15991]
09/24/2015 22:55:29.763179 zmdc[15991].INF ['zma -m 1' started at 15/09/24 22:55:29]
09/24/2015 22:55:29.829815 zmdc[15955].INF ['zmc -m 2' starting at 15/09/24 22:55:29, pid = 15994]
09/24/2015 22:55:29.829817 zmdc[15994].INF ['zmc -m 2' started at 15/09/24 22:55:29]
09/24/2015 22:55:29.910631 zmdc[15955].ERR ['zma -m 1' exited abnormally, exit status 255]
09/24/2015 22:55:29.910955 zmdc[15955].INF [Starting pending process, zma -m 1]
09/24/2015 22:55:29.912506 zmdc[15955].INF ['zma -m 1' starting at 15/09/24 22:55:29, pid = 15995]
09/24/2015 22:55:29.917306 zmdc[15995].INF ['zma -m 1' started at 15/09/24 22:55:29]
09/24/2015 22:55:29.921114 zmdc[15955].ERR ['zmc -m 2' exited abnormally, exit status 255]
09/24/2015 22:55:29.921481 zmdc[15955].INF [Starting pending process, zmc -m 2]
09/24/2015 22:55:30.090052 zmdc[15955].INF ['zmc -m 2' starting at 15/09/24 22:55:30, pid = 16007]
09/24/2015 22:55:30.090073 zmdc[16007].INF ['zmc -m 2' started at 15/09/24 22:55:30]
09/24/2015 22:55:30.101059 zmdc[15955].INF ['zma -m 2' starting at 15/09/24 22:55:30, pid = 16008]
09/24/2015 22:55:30.101072 zmdc[16008].INF ['zma -m 2' started at 15/09/24 22:55:30]
09/24/2015 22:55:30.165416 zmdc[15955].INF ['zmfilter.pl' starting at 15/09/24 22:55:30, pid = 16015]
09/24/2015 22:55:30.165419 zmdc[16015].INF ['zmfilter.pl' started at 15/09/24 22:55:30]
09/24/2015 22:55:30.280407 zmdc[15955].ERR ['zma -m 2' exited abnormally, exit status 255]
09/24/2015 22:55:30.280748 zmdc[15955].INF [Starting pending process, zma -m 2]
09/24/2015 22:55:30.282467 zmdc[15955].INF ['zma -m 2' starting at 15/09/24 22:55:30, pid = 16016]
09/24/2015 22:55:30.282470 zmdc[16016].INF ['zma -m 2' started at 15/09/24 22:55:30]
09/24/2015 22:55:30.344810 zmdc[15955].INF ['zmaudit.pl -c' starting at 15/09/24 22:55:30, pid = 16021]
09/24/2015 22:55:30.344812 zmdc[16021].INF ['zmaudit.pl -c' started at 15/09/24 22:55:30]
09/24/2015 22:55:30.408316 zmdc[15955].INF ['zmwatch.pl' starting at 15/09/24 22:55:30, pid = 16025]
09/24/2015 22:55:30.408331 zmdc[16025].INF ['zmwatch.pl' started at 15/09/24 22:55:30]
09/24/2015 22:55:30.470793 zmdc[15955].INF ['zmupdate.pl -c' starting at 15/09/24 22:55:30, pid = 16033]
09/24/2015 22:55:30.470795 zmdc[16033].INF ['zmupdate.pl -c' started at 15/09/24 22:55:30]

zmu.log looks like this:
09/24/15 00:21:11.574017 zmu[27492].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_user.cpp/241 [Authenticated user 'admin']
09/24/15 00:21:11.576214 zmu[27492].WAR-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp/426 [Shared data not initialised by capture daemon, some query functions may not be available or produce invalid results for monitor SideYard]
09/24/15 00:21:11.616374 zmu[27492].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_logger.cpp/235 [Terminating Logger]

User avatar
asker
Posts: 1419
Joined: Sun Mar 01, 2015 12:12 pm

Re: modect stopped working

Post by asker » Fri Sep 25, 2015 4:15 pm

Your monitors seem to be regularly crashing, which is probably why no detection is working. You should debug that.
Please don't ask me questions via PM. Feel free to post in the forums or Github

My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

raydude
Posts: 63
Joined: Sun Jul 21, 2013 6:09 pm

Re: modect stopped working

Post by raydude » Sat Sep 26, 2015 2:37 am

More information:

zmc_m1 and zmc_m2 are running fine.

It is alarming, as evidence in zma_m1.log, but later, the pictures aren't found and the alarm is deleted. It looks like it can't write the files out to the drive.

I'll keep hunting.

Here's a snip of one of the zma logs:

09/25/15 19:26:24.260909 zma_m1[15995].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp/1464 [SideYard: 465082 - Opening new event 164, alarm start]
09/25/15 19:26:25.285458 zma_m1[15995].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp/1500 [SideYard: 465086 - Gone into alert state]
09/25/15 19:26:31.727715 zma_m1[15995].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp/1507 [SideYard: 465111 - Left alarm state (164) - 54(4) images]

raydude
Posts: 63
Joined: Sun Jul 21, 2013 6:09 pm

Re: modect stopped working

Post by raydude » Sat Sep 26, 2015 2:40 am

Here's zmfilter.log which shows it deleting the events.

09/25/2015 19:26:39.967747 zmfilter[16015].INF [Deleting event 162]
09/25/2015 19:26:39.968593 zmfilter[16015].INF [Deleting event 163]
09/25/2015 19:26:39.969448 zmfilter[16015].INF [Deleting event 164]

It's had 164 events but none of them were stored

zmaudit.log:

09/25/2015 06:55:30.760569 zmaudit[16021].INF [deleting]
09/25/2015 07:10:30.764696 zmaudit[16021].INF [Filesystem event '1/139' does not exist in database]
09/25/2015 07:10:30.765654 zmaudit[16021].INF [deleting]
09/25/2015 19:10:31.347882 zmaudit[16021].INF [Found orphaned frame records for event '140']
09/25/2015 19:10:31.350039 zmaudit[16021].INF [deleting]
09/25/2015 19:10:31.355279 zmaudit[16021].INF [Found orphaned statistic records for event '140']
09/25/2015 19:10:31.355802 zmaudit[16021].INF [deleting]
09/25/2015 19:25:31.361536 zmaudit[16021].INF [Filesystem event '1/140' does not exist in database]
09/25/2015 19:25:31.363159 zmaudit[16021].INF [deleting]
09/25/2015 19:25:31.371827 zmaudit[16021].INF [Filesystem event '1/141' does not exist in database]
09/25/2015 19:25:31.372618 zmaudit[16021].INF [deleting]
09/25/2015 19:25:31.376688 zmaudit[16021].INF [Found orphaned frame records for event '141']
09/25/2015 19:25:31.376927 zmaudit[16021].INF [deleting]
09/25/2015 19:25:31.379083 zmaudit[16021].INF [Found orphaned statistic records for event '141']
09/25/2015 19:25:31.379381 zmaudit[16021].INF [deleting]

I checked the permissions... The files are written as apache, right? Hmmm maybe not... I'll chmod 666 and see what happens.

raydude
Posts: 63
Joined: Sun Jul 21, 2013 6:09 pm

Re: modect stopped working

Post by raydude » Sat Sep 26, 2015 9:19 pm

I'm really stuck. Permissions seem okay. I think the real problem is zms is crashing, I don't even know what the process is called, but there is no zms running as can be seen here:

ps -ef | grep zm
apache 20064 1 0 Sep25 ? 00:00:22 /usr/bin/perl -wT /usr/bin/zmdc.pl startup
apache 20108 20064 2 Sep25 ? 00:19:41 /usr/bin/zmc -m 1
apache 20113 20064 0 Sep25 ? 00:06:53 /usr/bin/zma -m 1
apache 20116 20064 2 Sep25 ? 00:23:10 /usr/bin/zmc -m 2
apache 20124 20064 0 Sep25 ? 00:00:01 /usr/bin/perl -wT /usr/bin/zmfilter.pl
apache 20128 20064 0 Sep25 ? 00:00:00 /usr/bin/perl -wT /usr/bin/zmaudit.pl -c
apache 20132 20064 0 Sep25 ? 00:00:04 /usr/bin/perl -wT /usr/bin/zmwatch.pl
apache 20139 20064 0 Sep25 ? 00:00:00 /usr/bin/perl -w /usr/bin/zmupdate.pl -c
apache 20181 20064 0 Sep25 ? 00:08:13 /usr/bin/zma -m 2


How can I run zms by hand to see it's output, since the log doesn't seem to be enough:

cat zms.log
09/26/15 14:02:05.013060 zms[19719].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_user.cpp/241 [Authenticated user 'admin']
09/26/15 14:02:05.027791 zms[19719].WAR-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp/426 [Shared data not initialised by capture daemon, some query functions may not be available or produce invalid results for monitor FrontYard]
09/26/15 14:02:16.873855 zms[19719].ERR-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp/3893 [Unable to send stream frame: Broken pipe]
09/26/15 14:02:16.939976 zms[19719].INF-/var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_logger.cpp/235 [Terminating Logger]

User avatar
asker
Posts: 1419
Joined: Sun Mar 01, 2015 12:12 pm

Re: modect stopped working

Post by asker » Sat Sep 26, 2015 10:31 pm

Let's step back

1. Which version are you running

2. How did you install it

3. If you are running development snapshots (anything above 1.28.1) did you make sure to read notices like this one from package maintainers about a breaking change in cgi-bin http://www.zoneminder.com/forums/viewto ... 75&p=89087

4. I am confused by 2 statements. Somewhere in your earlier posts, you said modect is not working. Later you said it is working but alarms are being deleted. Please confirm which of this is true.

5. Where are you storing your events? It is in some external NAS? or is it in the same HD that your OS is installed on?

6. Please list all the filters you have configured

7. Please provide snapshots of one of the camera's configuration - I'd like to see if its configured as RTSP or MJPEG

8. Monkeying around can mess things up - especially with symbolic links - you said you've done it above in an attempt to fix it - it might have made things worse. Any chance you can start afresh with a package and no messing around and then report what happens?

The reason I ask: If you somehow broke the symbolic links between where events are supposed to be stored vs where they are being stored, and zmaudit does not find events where its supposed to it, it will delete the entries from the DB in frequent intervals

For example, in ubuntu, if your ZM is installed in /usr/share/zoneminder then inside www in that directory you'll find two symbolic links - events and images pointing to /var/lib/zoneminder/events and images --> if you break that, zmaudit won't find the events and regularly purge them from the DB
Please don't ask me questions via PM. Feel free to post in the forums or Github

My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

raydude
Posts: 63
Joined: Sun Jul 21, 2013 6:09 pm

Re: modect stopped working

Post by raydude » Sun Sep 27, 2015 11:04 pm

Thanks for the help.

My answers:

1) 1.28.1. Originally I installed from source on my gentoo linux server, but since it stopped working (similar symptoms) I removed the database and installed from ebuild since 1.28.1 is now in portage.

2) emerge zoneminder

From the web console: "ZoneMinder Console - Running - v1.28.1"

3) I'm not. But I haven't removed my symlinks, removed the database and started from scratch yet. I should do that, but I'm learning kaltura for a friend and that's taking priority at the moment.

4) I'm not entirely sure what's going on. In my web console I never see any alarms or any links to video captures. This is the symptom that started with a gentoo update and still existed after the reinstall (note: I didn't remove my symlinks). If you look at the latest logs posted you can see that there are alarms being generated, yet no videos are captured. The logs also indicate that the videos are missing so the events are being deleted.

5) I have a raid6 array with much more space than my boot ssd. My symlinks used to work:

server lib # cat /etc/zm.conf
ZM_PATH_DATA=/usr/share/zoneminder
ZM_PATH_BIN=/usr/bin
ZM_PATH_LIB=/usr/lib64
ZM_PATH_CONF=/etc
ZM_PATH_WEB=/usr/share/zoneminder/www
ZM_PATH_CGI=/usr/libexec/zoneminder/cgi-bin
ZM_WEB_USER=apache
ZM_WEB_GROUP=apache
ZM_DB_TYPE=mysql
ZM_DB_HOST=localhost
... rest removed

server www # pwd
/usr/share/zoneminder/www
server www # ls -lah
total 60K
drwxr-xr-x 13 root root 4.0K Sep 24 22:54 .
drwxr-xr-x 4 root root 4.0K Sep 21 23:28 ..
drwxr-xr-x 2 root root 4.0K Sep 21 23:28 ajax
drwxr-xr-x 4 root root 4.0K Sep 21 23:28 api
drwxr-xr-x 2 root root 4.0K Sep 21 23:28 css
lrwxrwxrwx 1 root root 28 Sep 24 22:54 events -> /mnt/raid6/zoneminder/events
drwxr-xr-x 2 root root 4.0K Sep 21 23:28 graphics
lrwxrwxrwx 1 root root 28 Sep 24 22:54 images -> /mnt/raid6/zoneminder/images
drwxr-xr-x 2 root root 4.0K Sep 21 23:28 includes
-rw-r--r-- 1 root root 4.5K Feb 4 2015 index.php
drwxr-xr-x 2 root root 4.0K Sep 21 23:28 js
drwxr-xr-x 2 root root 4.0K Sep 21 23:28 lang
drwxr-xr-x 6 root root 4.0K Sep 21 23:28 skins
lrwxrwxrwx 1 root root 28 Sep 24 22:54 sounds -> /mnt/raid6/zoneminder/sounds
drwxr-xr-x 2 apache apache 4.0K Sep 21 23:28 temp
drwxr-xr-x 3 root root 4.0K Sep 21 23:28 tools
drwxr-xr-x 2 root root 4.0K Sep 21 23:28 views


6) I haven't configured any filters. Are there default filters?

7) MJPEG and it works, I can see the images in the Montage view.

8) Yeah. While preparing this reply I found that the cgi-bin mentioned above has zms in it, but it's owned by root, not apache, so I've changed it. I'll see if it working now...

raydude
Posts: 63
Joined: Sun Jul 21, 2013 6:09 pm

Re: modect stopped working

Post by raydude » Sun Oct 18, 2015 12:59 am

Whelp. I completely blew it away, including /usr/share/zoneminder, the database, /var/lib/zoneminder, etc.

gentoo puts symlinks for events and images in the usr/share/zoneminder/www folder that links to /var/lib/zoneminder/events and /var/lib/zoneminder/images. Those files were not automatically created by gentoo's emerge package manager, so I created them. I made the owner apache and the group root. I have tried apache:apache in the past, no difference. I tried root:root and that won't store images.

zmc_m1 is running with no output in /var/log/zm/zmc_m1.log with info messages enabled.

video is streaming, if I click on the ip address of the camera in zoneminder browser, then I can see the stream.

The other error message I get is this:

2015-10-17 17:46:12.891149 zms 24430 ERR Unable to send stream frame: Broken pipe /var/tmp/portage/www-misc/zoneminder-1.28.1/work/ZoneMinder-1.28.1/src/zm_monitor.cpp 3893

Clearly, zms can't forward the capture images to something that does post processing... Probably the detector. I don't know enough about the software to figure out what's going on...

Can anyone give me somewhere to look?

Thanks in advance.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests