Edit main page layout

Forum for questions and support relating to the 1.28.x releases only.
iitywygms
Posts: 118
Joined: Thu Nov 08, 2012 5:19 am

Re: Edit main page layout

Post by iitywygms » Fri Sep 25, 2015 6:10 pm

I added /live to the end of the source path. Now the username and password are not showing. Only live.
Everything still works. So this kind of solves the issue.

Another thing I ran across. If I add just / to the end of the source path, nothing displays in the source column on the main page. Nothing to even click on.
I had to delete the camera and re add it to get source to show on the main page.

I would love to lsee the "remote" option working. Maybe save some cpu load?
If it does save cpu, then I will start another thread to see if anyone can figure out what I have wrong.

User avatar
asker
Posts: 1421
Joined: Sun Mar 01, 2015 12:12 pm

Re: Edit main page layout

Post by asker » Fri Sep 25, 2015 6:23 pm

So there must have been some fixes after 1.28.1 then - looks like 1.28.1 needs a path suffix like you and bbunge reported
On 1.28.106 which I am on, whether you put a suffix or not, / or not, it always shows only the IP/hostname which is probably a more robust fix.

In the mean time, glad your issue is solved.

The fact that you add a "/" and nothing after bringing up a null string is probably due to this too - t
iitywygms wrote:I added /live to the end of the source path. Now the username and password are not showing. Only live.
Everything still works. So this kind of solves the issue.

Another thing I ran across. If I add just / to the end of the source path, nothing displays in the source column on the main page. Nothing to even click on.
I had to delete the camera and re add it to get source to show on the main page.

I would love to lsee the "remote" option working. Maybe save some cpu load?
If it does save cpu, then I will start another thread to see if anyone can figure out what I have wrong.
Please don't ask me questions via PM. Feel free to post in the forums or Github

My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

User avatar
asker
Posts: 1421
Joined: Sun Mar 01, 2015 12:12 pm

Re: Edit main page layout

Post by asker » Fri Sep 25, 2015 6:38 pm

So to close this issue,
I checked with knnnigget, he pointed out to me the following:

1.28.1 and prior releases parsed the URL to show only what is after "/" (suffix) if found which is why adding "/live" shows live and adding on "/" shows null (it found / and displayed empty after that)

This was fixed in later released and it now only shows the host/IP - but that change has not made it yet to a stable release as 1.28.1 is the latest stable release. Those on dev snapshots (like my version) has this fix
Please don't ask me questions via PM. Feel free to post in the forums or Github

My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

ExMM
Posts: 5
Joined: Tue Jan 12, 2016 1:20 pm

Re: Edit main page layout

Post by ExMM » Sat Jan 16, 2016 6:43 am

Hi,

I am having exactly the same problem, I want to hide username and password in the panel.

The above solution is not working for me on ZM 1.28.1.

Any help to do it ?

ExMM
Posts: 5
Joined: Tue Jan 12, 2016 1:20 pm

Re: Edit main page layout

Post by ExMM » Sat Jan 16, 2016 6:48 am

Never mind sorry.

I added /live at the end of the path, now scourse doesn't show the user and password anymore.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests