issues after "apt-get update"

Forum for questions and support relating to the 1.28.x releases only.
Post Reply
speedamaster
Posts: 25
Joined: Wed Dec 30, 2009 11:29 am

issues after "apt-get update"

Post by speedamaster » Sat Feb 14, 2015 4:35 pm

I did an overall "apt-get update" on my UBUNTU 14.04 server.
As a result I got massive issues on my zoneminder.
BTW: all was working perfectly before!

1) I get a strange WEB page for zoneminder - even missing any video play after going to the monitors - looks like the CSS would be gone

Code: Select all

Sat 14th Feb, 5:27pm
Load: 0.1 / Disk: 10%
ZoneMinder Console - Running - v1.28.0
Group: All: 3 Monitors
Options / Log
Cycle / Montage
Configured for Low Bandwidth
Name	Function	Source	Events	Hour	Day	Week	Month	Archived	Zones	Order	Mark
    	0	0	0	0	0	0	3	
gate	Monitor	/dev/video0 (0)	0	0	0	0	0	0	1	UpDown	
garage	Monitor	/dev/video0 (1)	0	0	0	0	0	0	1	UpDown	
entrance	Monitor	IPcamEntranceWLAN	0	0	0	0	0	0	1	UpDown	
2) in my /var/log/syslog if do get error messages like

Code: Select all

  web_php[2645]: ERR [socket_sendto( /var/run/zm/zms-678984s.sock ) failed: No such file or directory]
Feb 14 17:33:52 basement zmwatch[2418]: ERR [Memory map file '/dev/shm/zm.mmap.1' does not exist.  zmc might not be running.]
Feb 14 17:33:52 basement zmwatch[2418]: ERR [Memory map file '/dev/shm/zm.mmap.2' does not exist.  zmc might not be running.]
Feb 14 17:33:52 basement zmwatch[2418]: ERR [Memory map file '/dev/shm/zm.mmap.8' does not exist.  zmc might not be running.]
Feb 14 17:34:03 basement zmwatch[2418]: ERR [Memory map file '/dev/shm/zm.mmap.1' does not exist.  zmc might not be running.]
Feb 14 17:34:03 basement zmwatch[2418]: ERR [Memory map file '/dev/shm/zm.mmap.2' does not exist.  zmc might not be running.]
Feb 14 17:34:03 basement zmwatch[2418]: ERR [Memory map file '/dev/shm/zm.mmap.8' does not exist.  zmc might not be running.]

tyler_h
Posts: 20
Joined: Mon Feb 09, 2015 4:47 pm

Re: issues after "apt-get update"

Post by tyler_h » Sat Feb 14, 2015 10:26 pm

I got this exact same issue. I read that upgrading to 1.28.1 from the website, not the PPA will solve the issue. It was released today. I am unable to figure out how to install/upgrade 1.28.1 though :(

puempel
Posts: 5
Joined: Sun Feb 15, 2015 5:55 pm

Re: issues after "apt-get update"

Post by puempel » Sun Feb 15, 2015 6:00 pm

i also get the same issue.

Code: Select all

2015-02-15 18:57:30.612050	zmwatch	3507	ERR	Memory map file '/dev/shm/zm.mmap.1' does not exist. zmc might not be running.	zmwatch.pl	
2015-02-15 18:57:20.610560	zmwatch	3507	ERR	Memory map file '/dev/shm/zm.mmap.2' does not exist. zmc might not be running.	zmwatch.pl	
2015-02-15 18:57:20.607460	zmwatch	3507	ERR	Memory map file '/dev/shm/zm.mmap.1' does not exist. zmc might not be running.	zmwatch.pl

speedamaster
Posts: 25
Joined: Wed Dec 30, 2009 11:29 am

Re: issues after "apt-get update"

Post by speedamaster » Tue Feb 17, 2015 10:35 pm

I do not want to totally crash my apt-get install with a manual install out of sources..... or shall I?
ZM web console tells me 1.28.0 is most recent and on ZM homepage there is just the source.....

WHAT TO DO?

speedamaster
Posts: 25
Joined: Wed Dec 30, 2009 11:29 am

[SOLVED] issues after "apt-get update"

Post by speedamaster » Tue Feb 17, 2015 10:39 pm

saw the other posts on that forum.

go to "options/display" and choose another skin (eg flat or classic) and you are back again.

so easy!

k4r71k
Posts: 1
Joined: Tue Jan 24, 2017 4:17 am

Re: issues after "apt-get update"

Post by k4r71k » Tue Jan 24, 2017 4:21 am

I had the same problem, then I went through zmpkg.pl and found that zmc was being run separately (which was what was crashing). I tried running this myself and it said libva.so.1 not found. So I installed libva and then zm did not crash. Strange that the rpm never checked libva for dependency. This is on opensuse leap 42.2

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest