Help! Disaster! Can't reinstall 1.27.x after accidental removal

Forum for questions and support relating to the 1.27.x releases only.
Post Reply
TheKorn
Posts: 142
Joined: Fri Aug 02, 2013 12:39 pm

Help! Disaster! Can't reinstall 1.27.x after accidental removal

Post by TheKorn » Tue Nov 10, 2015 9:41 pm

Shoulda left well enough alone, but... decided to untwist the whole "ffmpeg is dead, use libAV" coup cluster**** debacle that shipped with ubuntu 12.04LTS. I ran the install script located here: https://gist.github.com/xdamman/e4f713c8cd1a389a5917

Unfortunately that script has all the safeties off, and I noticed a shade late that apt was going to uninstall zoneminder since it has ffmpeg as a dependency.

FFFFFFUUUUUUUUUUUu.... you get the idea. Unfortunately apt was faster than my reading and hitting control-c. So... old install of zoneminder 1.27.(can't remember) nuked. Great. Wonderful.


OK, no problem... just go and do an apt-get install zoneminder, should fix everything, right?


Er, um, no. Not even close.


First I snapshotted the filesystem with all my zm events and images. So they're all safe and sound, and I can roll back the file system if things should go south.

Then I exported the existing zoneminder database to a file. So between the filesystem snapshot and the database dump, I can pretty much recover from just about anything as long as I can get zoneminder to actually install.


Next, I did an apt-get update. Not looking so good:

Code: Select all

W: Failed to fetch http://ppa.launchpad.net/iconnor/zoneminder/ubuntu/dists/precise/main/source/Sources  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/iconnor/zoneminder/ubuntu/dists/precise/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/iconnor/zoneminder/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found
So... how do I get zoneminder 1.27.whatever back? If I do an apt-get install zoneminder at this point, since the iconnor ppa looks dead it pulls zoneminder from the precise repo which is all the way back at 1.25.

I tried following the easy docker install for 1.28 in the wiki, but that was just a giant clusterf*** as my mysql has other databases in it (not to mention my apache instance!) and I really don't want to have to run mysql regular and a separate docker instance of mysql just for zoneminder. But I can't seem to find any instructions on how to install/run the docker version of zoneminder without the docker mysql dependency. (I've since uninstalled docker since zm is the only thing that uses it that I would possibly run.)

Help! Looking for good ideas here!

Thanks in advance!

TheKorn
Posts: 142
Joined: Fri Aug 02, 2013 12:39 pm

Re: Help! Disaster! Can't reinstall 1.27.x after accidental removal

Post by TheKorn » Tue Nov 10, 2015 10:09 pm

Why is it every time I write a message I figure out the answer on my own five minutes later?

Oh well, in case anyone else has this happen to them, apparently the PPA was renamed.

So, head over to /etc/apt/sources.list.d, and

Code: Select all

cp iconnor-zoneminder-precise.list iconnor-zoneminder-precise.list.save
vi iconnor-zoneminder-precise.list
and change

Code: Select all

deb http://ppa.launchpad.net/iconnor/zoneminder/ubuntu precise main
deb-src http://ppa.launchpad.net/iconnor/zoneminder/ubuntu precise main
to

Code: Select all

deb http://ppa.launchpad.net/iconnor/zoneminder-master/ubuntu precise main
deb-src http://ppa.launchpad.net/iconnor/zoneminder-master/ubuntu precise main

Then... do an apt-get update, then apt-get install zoneminder, and back in business! (And upgraded to 1.28.1 along the way as well. Meh, whatevs!)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest