Camera Config Issue

Forum for questions and support relating to the 1.27.x releases only.
Post Reply
Medeoker
Posts: 2
Joined: Fri Sep 05, 2014 11:36 pm

Camera Config Issue

Post by Medeoker » Sat Sep 06, 2014 2:09 am

Ok,

I resolved my last problem on my own after posting here, so maybe I'll get lucky and do it again.

I've got things setup and now I'm trying to connect a few cameras. I'm connecting using the cURL method and providing credentials and a path to the video.

I'm just seeing black screens.

Upon checking the log, I've found the following messages repeating:
2014-09-05 22:07:20.207711 zmc_m4 22539 ERR Failed requesting writeable buffer for reading JPEG image. zm_image.cpp 993
2014-09-05 22:07:20.206846 zmc_m4 22539 ERR Held buffer is undersized for requested buffer zm_image.cpp 314

I've done some searching and the only things I can find is the source code on github. :)

Any quick ideas? Thanks

mastertheknife
Posts: 678
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Re: Camera Config Issue

Post by mastertheknife » Fri Sep 12, 2014 3:50 pm

Hi,

That error means there is a resolution mismatch. The resolution you entered for the monitor does not match the actual resolution of the stream.

mastertheknife
Kfir Itzhak.

BiloxiGeek
Posts: 240
Joined: Tue Feb 11, 2014 2:04 pm

Re: Camera Config Issue

Post by BiloxiGeek » Fri Sep 12, 2014 5:18 pm

I'm pretty sure I saw a similar issue when I was setting up some Grandstream HiDef IP cameras, but it has been a more than a few months.

After setting the camera up to do 1920x1080 I configured the zm monitor the same and had problems. When I viewed the rtsp stream from the camera in vlc I noticed the resolution that was coming from the camera was actually 1920x1088. Weird resolution and not what the camera config said, but it's working once I told zm to use the 1920x1088.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests