Ubuntu 14.04 getting libvlc to work!!!

Forum for questions and support relating to the 1.27.x releases only.
Post Reply
bbunge
Posts: 2661
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Ubuntu 14.04 getting libvlc to work!!!

Post by bbunge » Sun Aug 10, 2014 1:18 am

Thanks to some input on another forum subject I was able to get ZM libvlc working on Ubuntu 14.04 server. My tested procedure follows. I'm not sure if all the "extra" VLC installs are necessary but it works! I am monitoring an H.264 camera 30 miles away ported through a firewall with the libvlc option. Since the current version of ZM from the PPA is not "final" this is a better place for this procedure than the WIKI.

Install Ubuntu Server

Install Basic Server (if you used the mini.iso), OpenSSH Server, and LAMP Server (LAMP installs Apache2, PHP, and MySQL server)

Log in then become root:

sudo su

apt-get update
apt-get upgrade
apt-get dist-upgrade

Optional: Set static IP address

nano /etc/network/interfaces

Make changes similar to this:

auto eth0
iface eth0 inet static
address 192.168.1.10
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameservers 192.168.1.1

Note: for Ubuntu 14.04 the resolv.conf is dynamically assigned. The "dns-servers" entry in the interfaces file will set the DNS Multiple DNS server entries can be used.

Reboot server

Add Repository

apt-get install python-software-properties
add-apt-repository ppa:iconnor/zoneminder-master
apt-get update

Install Zoneminder

apt-get install zoneminder

Note: a couple of package configurations will open up. These are to configure Nullmailer. You can just OK them and come back to configure them later.

Install "extra" VLC components (vlc may be optional?)

apt-get install libvlc-dev libvlccore-dev vlc

Add delay to allow MySQL to start before Zoneminder

nano /etc/init.d/zoneminder

Add sleep 15 as shown:

start() {
sleep 15
echo -n "Starting $prog: "

Ctrl+o Enter to save

CTRL+x to exit

Create a directory in apache2

mkdir /etc/apache2/conf.d

Create two symbolic links

ln -s /etc/zm/apache.conf /etc/apache2/conf.d/zoneminder.conf

ln -s /etc/zm/apache.conf /etc/apache2/conf-enabled/zoneminder.conf

CGI is not enabled in Ubuntu 14.04 by default. Enable it this way:

a2enmod cgi

Create a new user

adduser www-data video

Restart Apache

/etc/init.d/apache2 force-reload

or

service apache2 restart



Install Cambozola (needed if you use Internet Explorer)


cd /usr/src && wget http://www.andywilcock.com/code/cambozo ... est.tar.gz

tar -xzvf cambozola-latest.tar.gz

replace 935 with cambozola version downloaded

cp cambozola-0.935/dist/cambozola.jar /usr/share/zoneminder

You should now be able to access the web server using https://servername

NTP Daily Sync

nano /etc/cron.daily/ntpdate

Copy the following into nano

!/bin/sh ntpdate ntp.ubuntu.com

Ctrl+o Enter to save

CTRL+x to exit

chmod 755 /etc/cron.daily/ntpdate

Open Zoneminder in web browser

http://serverip/zm

Click Options

Uncheck: Check with zoneminder.com for updated versions (?) click Save

Click Images tab

check Is the (optional) cambozola java streaming client installed (?) Click Save

dazed
Posts: 66
Joined: Thu Feb 13, 2014 5:32 pm

Re: Ubuntu 14.04 getting libvlc to work!!!

Post by dazed » Fri Aug 15, 2014 4:49 pm

What version of ZM are you using 1.27 ?

bbunge
Posts: 2661
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 14.04 getting libvlc to work!!!

Post by bbunge » Sun Aug 17, 2014 1:48 am

This setup will get you the latest 1.27 from the master repository. As of this, the version is: 1.27.99+1-trusty-SNAPSHOT2014080402. When a new version is released on the PPA you can do an update/upgrade to get it.
bb

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest