Can I disable web interface security from CLI?

Forum for questions and support relating to the 1.27.x releases only.
Post Reply
tstrike
Posts: 14
Joined: Tue Apr 01, 2014 1:05 pm

Can I disable web interface security from CLI?

Post by tstrike » Sun Jul 27, 2014 2:09 pm

Hi all,

Its been awhile.

Apparently my Zoneminder installation webinterface is not letting me in. I checked the ZM database to verify I was using the correct password I had setup and even reset up the admin password to make sure.

Its just getting stuck at the login screen. Can I disable security via CLI?

Thanks in advance

linuxsense
Posts: 374
Joined: Wed Nov 07, 2007 1:59 am
Location: Huntington Beach, California
Contact:

Re: Can I disable web interface security from CLI?

Post by linuxsense » Mon Jul 28, 2014 12:36 am

Add:

Code: Select all

ZM_OPT_USE_AUTH=0
to your zm.conf and restart zoneminder, should do the trick. If that fails you can change the value of ZM_OPT_USE_AUTH in the mySQL "Config" table to a "0". However, I just tested overriding it in zm.conf on one of my servers and it worked so that should be all you need. Just be sure to remove the option from the config if you want to re-enable auth.

tstrike
Posts: 14
Joined: Tue Apr 01, 2014 1:05 pm

Re: Can I disable web interface security from CLI?

Post by tstrike » Mon Jul 28, 2014 7:25 pm

linuxsense wrote:Add:

Code: Select all

ZM_OPT_USE_AUTH=0
to your zm.conf and restart zoneminder, should do the trick. If that fails you can change the value of ZM_OPT_USE_AUTH in the mySQL "Config" table to a "0". However, I just tested overriding it in zm.conf on one of my servers and it worked so that should be all you need. Just be sure to remove the option from the config if you want to re-enable auth.
Thank you so much. That worked for me perfectly!!! I was worried for a minute there!!!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests