Page 1 of 1

Cmake prob. ZLIB missing - found 1.2.7

Posted: Sun May 18, 2014 2:24 pm
by liderbug
-- Could NOT find ZLIB (missing: ZLIB_LIBRARY) (found version "1.2.7")
-- Could NOT find CURL (missing: CURL_LIBRARY) (found version "7.29.0")

What version is it looking for 1.2. 6 or 8?

Next day - what I want to do is RTSP. I'm running 25, and have ffmpeg installed but the logs say "You must have ffmpeg libraries installed to use remote camera protocol 'rtsp' for monitor 3". What have I missed?


Re: Cmake prob. ZLIB missing - found 1.2.7

Posted: Mon May 19, 2014 4:53 am
by mastertheknife

This looks like a bug within cmake, but no fear, zlib and curl are not required dependencies, so you should have no problems continuing the installation.

Re: Cmake prob. ZLIB missing - found 1.2.7

Posted: Mon May 19, 2014 2:41 pm
by liderbug
Thanks - when I ran make
and it errored out with:

In file included from src/zm_event.cpp:34:0:
src/zm_mpeg.h:43:7: error: use of enum ‘PixelFormat’ without previous declaration
enum PixelFormat pf;
src/zm_mpeg.h:44:2: error: ‘AVOutputFormat’ does not name a type
AVOutputFormat *of;
AVFormatContext *ofc;
AVStream *ost;
AVFrame *opicture;
AVFrame *tmp_opicture;

So now what am I missing?


Let me add, all I'm trying to do is get rtsp working - I have 25 installed now.

Re: Cmake prob. ZLIB missing - found 1.2.7

Posted: Tue May 20, 2014 2:22 pm
by liderbug
I found this: zoneminder-1.27.0-1.fc19.x86_64.rpm but haven't been able to install it.
error: Failed dependencies:

So with help from the Fedora Forum I did yum localinstall. Which ran better until:
Error: Package: zoneminder-1.27.0-1.fc19.x86_64 (/zoneminder-1.27.0-1.fc19.x86_64)
Requires: perl(X10::ActiveHome)

and after searching the web I (think) found it - for Mageia.

Again: All I want to do is: rtsp://cam.... RPM errors out, cmake/make errors out. VLC works fine - but it doen't detect/record like ZM

Please help.


was able to install 27 --> ... =9&t=21400 although it could have gone smoother

Also: functions.php needs to have
added to the beginning of the file.
and needed to be run.

Unable to get RTP Info identifier from response 'RTSP/1.0 200 OK Server: H264DVR 1.0 cseq: 3 Range: npt=now- Session: 33863030 '
but that'll be nuder post.

SOLVED: see: ... 29&t=22256